[RELEASE] Zooz Scene Controller (ZEN32)

@krlaframboise Tried to get the first of these to work, but no luck so far. Main button worked fine controlling a physical load, but I wanted to put a smart bulb on it, so I disabled the physical load. This brings me to my first question:

When would someone use “Disable Physical and Zwave” instead of “Disable Physical”? If Zwave is disabled on press, what does it do?

Regardless of the setting above, I am unable to get any automations to fire for “On or Off” or “Pressed” when using the actual button. Toggling the button in ST does trigger the event.

I am seeing something similar with the additional scene buttons. Pressing them is not triggering any of the events that I have setup. They remain in standby and just toggle the built-in LEDs.

Any advice? Thanks in advance.

For @TheSmartestHouse I am also noticing that the main button likes to stick if I tap on the top or bottom instead of the middle. The edge catches and the button sticks to the housing. I have seen it on each of the samples I purchased. Is this a known issue?

The controller is receiving and sending commands according to the IDE, but in real usage it doesn’t seem like anything is actually being sent from the controller. I do see that it is receiving messages because I can change the LED colors on the buttons. Debug logging is enabled, but I don’t see messages being sent in the Live Logging. The IDE indicates that 100s of messages have been sent.

Once the ZEN32 is installed, the button shouldn’t stick. It will behave differently when mounted so we recommend testing only once the device is installed in the switch box. If you keep experiencing issues, you may need to try a different button panel, please contact Zooz directly to request one if needed.

You would disable Z-Wave control if you have smart bulbs connected to the relay and would like to always provide power to them so that it’s not accidentally cut when you turn the relay on or off from SmartThings.

This sounds like a configuration issue. Have you tried excluding and re-including the device to see if it helps?

2 Likes

It is installed, so I assume there is an issue with it sticking and will contact Zooz.

Wouldn’t that be “Disable Physical” to maintain power? I assume that Zwave needs to stay enabled to send the event back to the hub. I must be misreading these options.

I did reset everything and exclude it. I have since configured a second switch that works fine, so I am leaning toward it being a faulty unit.

@TheSmartestHouse One last question…In addition to the Press (1-5x) triggers, there are also Toggle (Up/Down) triggers in the DTH. How does someone physically “toggle” these buttons up or down? What denotes up and down?

Thanks again.

If you’re still having this issue you should remove // in front of the log.trace line at the bottom of the code.

You’re using the child devices in Automations for the 4 buttons at the bottom, right?

Unless ST broke something again, you shouldn’t be seeing options for up/down.

1 Like

Thanks for the note on the log statement. I saw that earlier in the thread. :+1:

Yes, I am talking about the child devices. Going through the “Automations” tab, these options are not displayed. They are only displayed when clicking on the device in the “Devices” tab and then viewing the “Controls” tab. This shows the state and configuration for each trigger.

@krlaframboise he is right I can see them too. Since I added Automations, I didn’t look at the device as it works perfect. Today I just checked and they are all there

Routines look fine

Did the device get assigned the correct handler automatically when you joined the device?

It looks like ST broke the UI again…

1 Like

Yes. The handlers were chosen correctly when the devices were added.

Are you now able to trigger automations for the 4 buttons using the child devices?

If not, please make the trace change I mentioned above open live logging, try each button a few seconds apart, and post the live logging results.

It is working for the second device I installed. I was never able to get the first device working, so I am blaming it on a faulty unit. I have a tech support call with Zooz, for good measure, but plan to return at least that unit. Thanks for your help. The driver looks good.

:wink: Oh man, I was hoping that SmartThings magically 🪄 upgraded my Zooz ZEN32 to have toggle up and down :disappointed_relieved:.
@krlaframboise let me know if you need any help with testing

Have you tried factory resetting the device?

I haven’t. I will need to look up the instructions for that. In the meantime, I am swapping out the device since the button also sticks.

Following up for anyone that has this connection problem in the future…

After a chat with Zooz support, I learned that any comms failures during inclusion can forever hamper the device and cause it to not communicate properly, even if it looks like it succeeded. After multiple exclude/include attempts, I physically removed the controller and left it hanging out of the wall so that it would be free from obstructions during inclusion. This worked and the next inclusion attempt was a success. All of the features work as expected. The only thing I can think of is that there is another zwave device directly behind it on the other side of the wall. It possibly interfered in some way during inclusion. I’m up for suggestions on that point.

@TheSmartestHouse as for the buttons “sticking”, Zooz support indicated that there was a prior manufacturing flaw that resulted in this issue. All of the controllers I ordered stick in this way, even after install. You may want to check the batches being shipped out.

Also correcting myself on this point after contacting support. I found the labels confusing. In this context “Disable Physical and Zwave” does not mean you are disabling zwave transmission. What you are disabling is remote zwave control over the load. The zwave events all still work. This just means that tapping the power button in ST will not enable/disable the relay. So here is my interpretation and suggestions for renaming if @krlaframboise wants them…:wink:

Disable Physical → Disable Physical Button (I assumed it meant physical relay)
Disable Physcial and Zwave → Disable Physical and App Buttons (See above)
Enable Physical and Zwave → Enable Physical and App Buttons

2 Likes

Do they stick after installation or prior to being installed? We’ve seen issues with just a few units once the devices are installed so if this happens to all of them for you, please send us an email with your order number and we’ll gather the details to offer a solution.

1 Like

Yes, after installation. In fact, one unit didn’t stick prior to install, but does after install. If I don’t hit the buttons in the center, they do stick.

1 Like