[RELEASE] Orvibo Contact Sensor

dth_sensors

(Wayne) #1

Continuing the discussion from Cost effective door/window sensors (UK):

Here’s a device type for the orvibo contact sensor. I’ve flagged as beta as I haven’t been able to figure out how to fingerprint properly yet but seems to work okay for me. So you’ll need to manually assign the device type until that is fixed.

Any help correcting that appreciated! :slight_smile:

EDIT: fingerprinting all working fine and heartbeat event added to allow device monitor type apps to know if the device is alive.


Orvibo Zigbee sensors?
Cheap door sensor £15
Cost effective door/window sensors (UK)
SmartThings So far not impressed - not so smart
Cost effective door/window sensors (UK)
Cost effective door/window sensors (UK)
Cost effective door/window sensors (UK)
Cheapest (reliable) door/window sensor (UK)
Deal - Orvibo sensors
(Darren) #2

@a4refillpad late night I know but still reviewing the posts :slight_smile:

Just assigned my Sensor to the device type, I’ve an extra box underneath my device and it says –

Just wondering if this is correct (it might be as kris said it only calls the mother ship every 15 mins or so), just thought I’d mention it. Opening and closing indicator is working perfectly.

I’m on an Android device


(Wayne) #3

try pressing the button on the physical sensor device :slight_smile:


(Darren) #4

and if by magic the – become numbers :slight_smile:

but lets be honest the magic is time and effort given by others :slight_smile:

its looking good, ill keep you posted.


(Paul Ockenden) #5

Looking good here. And I still have 100% battery, which is a nice surprise!


(Jamie) #6

My sensor shows OPEN all the time, has anyone else experienced this? The green light flashes when I move the magnet next to the sensor and away, so it appears to be detecting the state on the device, but nothing changes in ST. Any help would be appreciated.

I’ve tried using Open/Close device type and also this custom device type and both act the same.


(Jamie) #7

OK - I’ve just deleted the device and re-paired and now it is working fine :slight_smile:


(Wayne) #8

Sensors occasionally stuck in a permanent active or inactive state is something we just have to live with in ST it seems regardless of devicetype.


(Wayne) #9

Fingerprint now working too. So out of beta :slight_smile:


#10

Thank you very much my friend. Your device type has made it really worthy investing on Orvibo open/close sensors instead of Smartsense ones.


(Paul Ockenden) #11

This is an odd one. One of my Orvibo sensors now isn’t seeing its own magnet, yet if I put a very strong N52 magnet nearby it sees that fine, but no green flash from its own magnet.

I wondered whether it might be a battery issue, but Wayne’s driver is seeing 100%.

Anyone else seen a failure like this?

P.


#12

This probably isn’t it, but just in case, anytime you have a sensor with a magnet that used to work and now isn’t working, it’s worth asking if there’s any metal nearby that might have become magnetized over time. That can throw off the sensor completely.


(Wayne) #13

Pretty sure the battery state works as I have varying levels of battery across the sensors. I have quite a few now. I’ve also noticed the orvibo magnets to very strong compared to the ST ones allowing me to leave a pretty wide gap so it’s surprising.


(Paul Ockenden) #14

Hmmm… all of my Orvibo sensors seem to be failing. They’ll work for a while, then completely stop, and then start working again! Not sure whether it’s due to a recent hub update.

When they fail (and they all seem to fail at the same time), the green ring doesn’t light when the magnet comes close, although I can hear the reed switch faintly clicking inside.

Most odd…


(Wayne) #15

I’ve had one of my 10 do the same yesterday. Had to reseat the battery. Green light would not even light when I click on the button. After reseating all was okay again. Hope it’s not endemic as I’ve another 10 on order!


(Paul Ockenden) #16

Weird gets weirder… If I wander around the house, in some places the sensors work, in other places they don’t!

I’m starting to wonder whether it’s an RF issue.

But it’s new - up until a few weeks ago they worked fine.

P.


#17

Some people are reporting zigbee problems with other devices in the last week. Really weird stuff.


(Paul Ockenden) #18

Perhaps the zigbee power in the hub has been reduced? I’d get out my RF Explorer (brilliant bit of kit), but don’t have a reference from a couple of weeks back to compare it with.

P.


(Paul Ockenden) #19

My Hub reports “zigbeePowerLevel: -14”

Anyone know if this is normal? -14 WHAT exactly? And how do I turn it up to 11?

P.


(Ron Anthony Quinn) #20

My Zibee power shows: zigbeePowerLevel: -2

And ALL of my devices have recently just dropped and I can no longer control them. I have a v1 Hub, and believe when I say I have tried EVERYTHING to try and regain control of them.

I have no idea how to raise the power level either. I’m also not sure if -2 is average or low power. From what I’ve seen and read this last week as my devices have been dropping, -2 may be a low reading.

Bueller?