How to connect my Fibaro FGR 222 to smart things


I’m completely new to this, excuse my ignorance. I have searched, read and watched what videos I could find… but cannot add my Fibaro FGR 222 rollers to SmartThings.

Bought a new house where the previous was using the system and I would like to make use of it.

I have bought a hub but cannot seem to add the Fibaro FGR 222 to the hub. I have gone to the switch and pressed the B button 3 times as part of the set up… but nothing seems to happen.

I think I need a bit of an idiots guide help as a lot of the instructions seem complex for me.

Any help would be appreciated


Hi @Shaidul_Hoque

Since you’re starting out with this, start using the edge drivers, which is what’s going to exist in the near future.

Edge drivers are controllers that are used to manage the devices that are installed in the hub.

The driver has to be installed on your hub from a web channel where the drivers are stored.

There are several channels, there is the official smartthings and many more. Each user or developer can create and share their channel with other users.

To enroll your hub in an edge driver channel you have to enter the invitation link to the channel and accept use it and press enroll for access to drivers.
Once hub enrolled you will see all the drivers available in the channel.
Install only the drivers you are going to use on your hub.
Once the driver is installed on your hub, you can add the device from the app with the option to search for nearby devices.

Open this link to the post where it is explained which fibaro Z-wave drivers are available on my shared channel.

At the end of post you will find the invitation link to the channel so you can install the Z-wave Window Treatment Mc driver

This the link to smartthings tutorial for Edge drivers


Hi @Mariano_Colmenarejo

thank you very much for your reply.

I’m still having issues connecting to Smartthings. I have accepted the invation and added the Z-wave Window Treatment Mc driver and then done a scan to search for nearby devices and nothing shows up.

Let me mention the set up I have inherited and maybe that will help identify potential issues. There are 4 windows and each window has been set up with Fibaro FGR 222 units attached to Dooya motors. I have opened up one switch unit and can see the FGR 222 unit wired in, but not connected to S1 or S2, I’m not sure if this matters. I will have to open the others and see how they are wired. My Assumption that all four are somehow linked and only once connection is to be made to one of the FGR units. However this is a totally guesss from me, with not much knowledge on this.

Can you think of anything else as to why I cant seem to add the unit(s) to smartthing?

Thank you


sorry another thing, I’m reading about Device Handlers and to have these set up… is this something I should be doing?

Thank you


Welcome! :sunglasses:

Device Type Handlers written in the Groovy programming language are part of the old architecture. They are still available but due to be discontinued at the end of September. So at this point it’s best to just start with the new architecture, Edge Drivers, as @Mariano_Colmenarejo suggested.

If you want to read more details about this transition, see the community FAQ:

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)


As far as your current issue, it’s very likely that you need to clear out the old network information from each device before it will accept being added to a new hub. In zwave, this process is called “exclusion.” It is different from just “resetting” the device. If you don’t have access to the original hub, that’s fine: zwave has a special utility called “general exclusion” which allows ANY certified zwave hub to issue an exclusion command to ANY certified zwave device even if they were never on the same network before.

It is likely that your new ST hub can’t find your Fibaro devices because your Fibaro devices think they still belong to their old network, so they are not responding to the scan. Only devices that are available to join a new network show up in the scan list. A general exclusion will clear out the old network information, so then the device should show up in the scan as available.

I am tired today so I will leave it to others to help you with the details. But your next step should be to issue a “general exclusion” to each of your Fibaro devices to get them ready to join a new network.

If S1 and S2 are not connected, it will be because they were only managed from the app. S1 and S2 must be connected to a double sucker switch to manually up and down

I don’t know how a general exclusion is done, but maybe in the manual you can find how to reset it to factory. this is the manual

1 Like

Many zwave device manufacturers use “reset” to mean “reset all the optional parameter settings to their default values” but NOT to “clear the old network information.”

This is probably because, according to the Zwave Alliance, over half of zwave devices are professionally installed.

Individual customers are allowed to reset all the optional parameters like dim rate on a light switch, but the manufacturer didn’t want them to accidentally change the network settings the professional installer had set up. So those are handled with a different set of utilities, in this case general exclusion.

Also, as a network function, exclusion requires having both the hub and the end device do something at the same time. Any “reset” instruction for a zwave device which only talks about doing something with the end device and doesn’t also mention having the hub do something is not doing an exclusion.

Zwave is very different from Zigbee in this regard. :thinking:

Thank you @JDRoberts & once again to @Mariano_Colmenarejo

I will work on the information provided. I very much appreciate your help.

just like a old Arnie movie, ‘i’l be back’ to report on my progress :slight_smile:


1 Like

Hi @Mariano_Colmenarejo & @JDRoberts

With your kind and very informative advice I have managed to now exclude the Fibara Roller Shutters (FGR 222) from Z Wave and have successfully adding them to my hub.

Both your advice, help and links to drivers and guides has been invaluable to a beginner such as me. I very much appreciate you helping me.

I have a couple of further queries please?

As mentioned earlier, there are four curtains in my family room. 3 of them connected as expected with a roller switch. One of them however connects as a switch only, which can be switched on or off. Any ideas as to why this would be happening? And how I could correct it? I’ve added a screenshot image below

1 Like

Hi @Shaidul_Hoque

  • Install my driver Z-wave thing Mc on your hub

  • On the affected device, open the menu at the top right and click on driver. See what driver you have installed.

  • Make a driver change to zwave thing Mc.

  • Take a screenshot of the fingerprint information of the device.
    It may physically look like the same device, but it could be a switch.

  • Then go back to the original driver

1 Like

Hi @Mariano_Colmenarejo

I’ve added the new driver, however when I go to the affected device and and open the menu… it doesn’t give the option of driver. Just has two options of as shown below:

Do you think now that I have added driver of Z Wave thing Mc, I should just remove the device and add it again?

I did do this already a few times to try and fix the issue, but it was prior to have this new driver installed

Thank you



Since it has been paired with a DTH, go into the IDE and look at the fingerprints in the IDE

I’m not sure what to do once I see the details on the IDE to change the driver?

Your device has been paired with a DTH, not with an edge controller.

To see the fingerprints and know what device it is, enter the IDE page and in the device you will find the DATA with all the information

Hi @Mariano_Colmenarejo

I have found the device and can see the finger print details, it won’t however allow me to edit it to look similar to the existing rollers I have…

I’ve tried deleting it and adding it again, but still connects up as a metered switch.

Is there some other way I should be Changing it?

This is a old version FGRM-222, instead the others FGR-222
link to manual:

I added with same profile of FGR-222, It seems that it has the same configuration parameters, I don’t know if it will work quite well

  - id: FibaroRollerShutter2-FGRM
    deviceLabel: Fibaro Window Treatment
    manufacturerId: 0x010F
    productType: 0x0301
    productId: 0x1001
    deviceProfileName: fibaro-roller-shutter-2

This is the new driver date version.
You need wait 12 hr maximum for driver updated automatically in your Hub.
When you see this version date 2022-08-21T20:05:52.13402359 in the two others devices driver menu, then you will can uninstall de device with zwave exclusion and now will could re-pair with the edge driver

│ Driver Id   │ 79679b70-6c89-4efa-a711-e5f6fa6f657e │
│ Version     │ 2022-08-21T20:05:52.13402359         │


Your are a genius… thank you so much, I have successfully added it with the driver.

As much as I’m very grateful for all your help, Is there a way I can give you something, as a little gesture of my appreciation. Ie some money to buy you a drink?


1 Like

I’m so glad it works for you.

Several users have already offered it to me and I am very grateful for it, but I had not thought about accepting donations or gifts, unless my family wants to kick me out of the house for spending too much time on smartthings instead of them :joy: :joy:


:joy: my family is already complaining that I’m spending so much time on this every evening :slightly_smiling_face:

If you ever change your mind, then the offer is there my friend.

I will continue to self learn as much I can now and see what other useful devices I can add to SmartThings.

Thank you


1 Like