(EDGE Driver-Mc): Z-Wave Edge Drivers and others with FIBARO devices:

This already exists in the stock driver.
I’ve been using it for a month or so
It works fine, but it has 6 buttons, which must correspond to the scenes.
The fact that they are in the details view does not make much sense

1 Like

If this is more similar to the walli in the configuration.
I will also put the Venetian blind option like the walli
When I have a while I’ll do it and you try it

1 Like

Added Fibaro Roller Shutter 3 (FGR-223) to Z-Wave Window Treatment Mc driver

Since I cannot test it and in case it has any errors, I have created another version with a different ID for Z-Wave Window Treatment Mc so that it does not affect those who already have the version with the FGR-222 installed, which is now called Z-Wave Window Treatment Mc-(OLD)

Those who already have the (OLD) version installed with the FGR-222, can change to this new driver whenever they want.

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Z-Wave Window Treatment Mc           │
│ Version     │ 2022-02-16T16:55:00.02404            │
└─────────────┴──────────────────────────────────────┘

I have added the configuration parameters, similar to the Walli Roller Shutter. These are:

  FIBARO_3 = {
    MATCHING_MATRIX = {
      mfrs = 0x010F,
      product_types = 0x0303,
      product_ids = 0x1000,
    },
    PARAMETERS = {
      switchType =                {parameter_number = 20, size = 1},
      calibration =               {parameter_number = 150, size = 1},
      operatingMode =             {parameter_number = 151, size = 1},
      venetianBlindTurnTime =     {parameter_number = 152, size = 4},
      delayAtEndSwitch =          {parameter_number = 154, size = 2},
      motorEndMoveDetection =     {parameter_number = 155, size = 2},
      timeUpMovement =            {parameter_number = 156, size = 4},
      inputsOrientation =         {parameter_number = 24, size = 1},
      outputsOrientation =        {parameter_number = 25, size = 1},
      powerWithSelfConsumption =  {parameter_number = 60, size = 1},
      powerReportsOnChange =      {parameter_number = 61, size = 2},
      powerReportsPeriodic =      {parameter_number = 62, size = 2},
      energyReportsOnChange =     {parameter_number = 65, size = 2},
      energyReportsPeriodic =     {parameter_number = 66, size = 2}
    }
  },

You may need to perform a calibration after installing it. It is done in preferences setting the parameter 150, value = 2

When Venetian blind is chosen in preferences, it switches to a different profile, which shows the controls of this type of blind as another component of the device.

I hope everything works fine, fatal errors do not have that is already tested.

3 Likes

i cant get the hold on how to change my fibaro double switch to this driver? How do i do that?

  1. Use the above link to enroll in the channel and install the driver on your hub.
  2. Use the SmartThings app to exclude your device.
  3. If you have any custom Groovy DTHs installed that have the device’s fingerprint, either delete the DTH or comment out the fingerprint by using “//” on fingerprint line.
  4. Use Add deviceScan nearby in the SmartThings app to include your device. Your device should pick up this driver if the fingerprint matches.
1 Like

Fixed problem with preferences and profiles for Fibaro Plug Typr E/F Product Type 0602 and Product Id 1001 and 1003

Wall Plug – type E/F

FGWPE-102 | FGWPF-102

Also added to preferences parameters 10 - High priority power report and 13 - Energy reporting threshold

Last driver version

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Z-Wave Switch Mc                     │
│ Version     │ 2022-02-19T12:39:07.4147             │
└─────────────┴──────────────────────────────────────┘

Hi,

I’m seeing some odd behaviour with my Fibaro Dimmer 2 and this driver.

S2 is either toggling the app to show the device is on or off (even if the physical state doesn’t change), or it is dimming the lights.

S1 with synchronised state for toggle switches is unreliable.

Sometimes S1 switches the load on, but not off. S2 toggles dimming steps.

I have S2 scene activation on. I use this to control some other devices via the hub - the dimmer was previously using a stock pre-Edge driver and I was using Webcore to use the scene to toggle a script (flipping between scene ID 20 and 21).

Ideally this driver would allow S1 to toggle on and off synchronised with a toggle switch. S2 would activate a scene and not control the load of S1.

In a perfect world, it would be great if S2 could be seen as a separate button so ST routines could be used to control devices independently of a load attached to S1.

Thanks, though! Really glad the Fibaro Dimmer 2 has seen some attention - I’ve got loads of these and Fibaro don’t seem to have shown any signs of an official Edge driver.

1 Like

@lewisburgess,

I can’t help you much in this case as I don’t have the device.

I added a button as capability, which should be the one used to send the value (1 click, 2 click…) for the scene, depending on the type of switch selected, momentary or toggle.

If someone is using it, can you help?

Hi,

It seems that the button state shows pushed/held regardless of S1 or S2 being pressed.

Other than the scene activation, it is definitely not right - the S1 button isn’t working correctly- it might be because I reset the dimmer.

Would it be possible to added parameters 1, 2, 20, 26, 28, 29 from this list? Advanced parameters | FIBARO Manuals

I’m going to reset the dimmer and manually set some parameters then try your driver again to see if it behaves more like the classic driver. Thankfully, I can still switch back to the classic one as the Z-Wave ID seems to have stayed as 1D.

If you are using the Z-Wave Switch Mc driver these parameters are available in preferences

 },
  FIBARO_DIMMER = {
    MATCHING_MATRIX = {
      mfrs = 0x010F,
      product_types = 0x0102,
      product_ids = {0x1000, 0x2000, 0x3000}
    },
    PARAMETERS = {
      restoreState = {parameter_number = 9, size = 1},
      autoOffTimer = {parameter_number = 10, size = 2},
      switchType = {parameter_number = 20, size = 1},
      doubleClickOption = {parameter_number = 23, size = 1},
      threeWaySwitch = {parameter_number = 26, size = 1},
      sceneActivation = {parameter_number = 28, size = 1},
      onOffMode = {parameter_number = 32, size = 1},
      activePowerReports = {parameter_number = 50, size = 2},
      periodicPowerReports = {parameter_number = 52, size = 2},
      energyReports = {parameter_number = 53, size = 2}
    }
  },

I had to factory reset my test one as it just would not exclude / include properly. I think it would work OK with S1 again now, but I’ve reverted back to the stock classic driver as I think, like you, S2 will be an issue.

I’ll give it a few weeks to see if ST make any changes.

Hopefully still plenty of time before they close the door on non-Edge stuff - doesn’t seem quite ready to come out of beta yet.

Good evening.
You could add these two Fibaro devices:

  • Smart Module (FGS-214)
  • Double Smart Module
    (FGS-224)

Thank you

If you send me the fingerprints and if you know the different productId I can look at it and if it is not too complicated I will do it.
The hardest part will be the scenes.
I think that Fibaro on its website only advertises the single, double switch, plugs and dimmer 2 of the devices that are in the stock Beta driver Z-Wave switch as working with smartthings
I don’t think he intends to do anything

  • Smart Module (FGS-214) :
    zw:Ls2a type:1001 mfr:010F prod:0404 model:1000 ver:5.00 zwv:6.08 lib:03 cc:5E,55,98,9F,56,6C,22
    sec:25,85,8E,59,86,72,5A,73,5B,70,75,71,7A

@Mariano_Colmenarejo
Just incase these are ever useful here is the raw description of my Fibaro RGBW hardware driver (441)

Raw Description zw:L type:1101 mfr:010F prod:0900 model:1000 ver:25.25 zwv:3.52 lib:03 cc:27,72,86,26,60,70,32,31,85,33 epc:5 ep:[‘1101 26’]

Added Smart Module (FGS-214), mfr:010F prod:0404 model:1000 ver:5.00

  • Added the following settings parameters in preferences:
  FIBARO_SMART_MODULE_SINGLE = {
    MATCHING_MATRIX = {
      mfrs = 0x010F,
      product_types = 0x0404,
      product_ids = 0x1000
    },
    PARAMETERS = {
      restoreState = {parameter_number = 1, size = 1},
      switchType = {parameter_number = 20, size = 1},
      s1ScenesSent = {parameter_number = 40, size = 1},
      s2ScenesSent = {parameter_number = 41, size = 1},
      ch1OperatingMode = {parameter_number = 150, size = 1},
      ch1ReactionToSwitch = {parameter_number = 152, size = 1},
      ch1TimeParameter = {parameter_number = 154, size = 2},
      outputTypeQ1 = {parameter_number = 162, size = 1},
    }
  },

Try it and tell me if it works well or if something important is missing

driver version

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Z-Wave Switch Mc                     │
│ Version     │ 2022-02-21T16:13:21.725323           │
└─────────────┴──────────────────────────────────────┘

Added old FIBARO WALL PLUG, FGWPx-102-EN-A-v1.00 (mfrs=0x010F, product_types = 0x0600, product_ids = 0x1000)

  • Added the following settings parameters in preferences
  FIBARO_WALL_PLUG_OLD_EU = {
    MATCHING_MATRIX = {
      mfrs = 0x010F,
      product_types = 0x0600,
      product_ids = 0x1000
    },
    PARAMETERS = {
      alwaysActive = {parameter_number = 1, size = 1},
      restoreState = {parameter_number = 16, size = 1},
      overloadSafety = {parameter_number = 70, size = 2},
      inmediatePowerReport = {parameter_number = 40, size = 1},
      standardPowerReports = {parameter_number = 42, size = 1},
      powerReportFrequency = {parameter_number = 43, size = 1},
      energyReportingThreshold = {parameter_number = 45, size = 1},
      periodicReports = {parameter_number = 47, size = 2},
      ringColorOn = {parameter_number = 61, size = 1},
      ringColorOff = {parameter_number = 62, size = 1}
    }
  },

driver version

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Z-Wave Switch Mc                     │
│ Version     │ 2022-02-21T16:13:21.725323           │
└─────────────┴──────────────────────────────────────┘

Good evening.
It works well and there are all the parameters you need. Thank you

Now I just have to find where I put the Double Smart Module
(FGS-224) after removing it a few months ago

1 Like

I just tested the FGR-223 for the first time and it works pretty good. Thank you!
The calibration is working perfectly, and the only issue I’ve encountered is that I couldn’t find how to set the preset. it seems to default to 50%, but how do I change it?

1 Like

Hi @jahrin
I don’t know how the presets work, I don’t have a device to test it.
How did you use them with the DTH?