BloomSky & Weather Underground

Continuing the discussion from Bloomsky Weather Station:

@Natec @brianjlambert @schapper05 @cdmobile @Turb02 @slagle

Any chance anybody would be willing to help me work through this? I followed the instructions quoted above, but it’s not working all the way through. So, I’m kind of stuck.

I now have a new (for me, second; the other one is for something else) station in my WU-PWS account.

I have a camera listed under ‘Your Current Cameras’.

However, the camera entry’s ‘source link’ field is blank, because I’m not sure what to do next.
If I go in to edit the camera, at the point where I choose a station to associate it with, I only see my old, original station ID in there; the new one for the BloomSky is not in the ‘Associate with PWS’ drop-down list, even though it’s in my WU-PWS account.

I can log into the site (webcam.wunderground.com) via ftp client, and I can see the blank directory.

However, when I go to http://bloomsky.com/wun (i.e. “Google Cloud Platform”), and fill in the fields according to instructions above, I get the following error, “Password and/or Station ID are incorrect” (both of which are false positives, because I am most certainly using the correct credentials).

Is this just the part where I have to wait an hour or something? :slight_smile:

4 Likes

I kept getting that error with my first one, as well as not seeing my first bloomsky in the drop down to select.
I couldn’t get it to go until i clicked the log out button on that page, then logged in again and filled out the relevant info and was able to select my station…

That said I don’t have 2 linked right now so I don’t know if I can help much further than that.

1 Like

Thanks. I will give that a try…

I logged out, logged back in and same thing.
Man, I’m sure glad these things were free; otherwise, I’d be asking for beta tester payments or something lol

I still love my BloomSky. :slight_smile: I’m just trying to figure out why it doesn’t love me :frowning:

Another thing that someone said worked for them in the previous thread was that they only filled out the camera section and left the station id field blank on the bloomsky. Com/wun site after having already submitted the station id separately.

If you can connect to the ftp site separately, then I dont think you’re running into the problem I was at first, since I couldn’t even connect to the ftp site until a short period of time had passed.

Yep. I did the same, except it won’t let me register the Station ID. I did like you mentioned (before your post here) and got the cam registered, but neither way (together or station id by itself) would work to get the Station ID registered.

Then, after reading your post, I decided to just back it all out, and try again. This time, I was able to get success in both columns (station id and cam), and the correct details are in the other columns.

HOWEVER

When I go here…
https://www.wunderground.com/webcams/signup.html
…I click ‘Edit’ on the far right on same line as the cam.
I go down to the ‘Associate with PWS’ drop-down, but it still doesn’t show this new StationID in the drop-down.

Also, it’s strange, but when I go here…
https://www.wunderground.com/personal-weather-station/mypws
…I click the gear icon for the PWS that I want to work on.
I go down to the ‘Associated Webcam’ drop-down, and it’s blank.
The odd thing is that, a little bit ago, when trying the first time, the new cam did show up in that drop-down list, and I was able to associate it.

So, it looks like I must be missing something about how the process is supposed to work.

Sure wish I could get a detailed, step-by-step guide. I guess they aren’t going to give us one, we have to write it ourselves.

We, of course, have a good head-start here, but we still need to tie up these loose ends so that even an idiot like me can follow along and get the task done in one try (I lost count now on my journey lol ).

Once we do have that step-by-step guide, I will update the OP of this thread to reflect what’s been achieved.

Did you mention before that you have two WU accounts? If so, did you make sure to associate the BS to only a single WU account for both the station and cam? I’m trying to think of other reasons it might not show up.

I have a single WU account.
I already had one PWS connected to my WU account prior to encountering the BloomSky.
Now, with the BloomSky in the mix, I have two weather stations connected to my single WU account.

However, I haven’t even touched the other/first weather station while working on the BloomSky, because I didn’t want to mingle them at all.

\Update

Now,
When I go here…
https://www.wunderground.com/personal-weather-station/mypws
…I click the gear icon for the PWS that I want to work on.
I go down to the ‘Associated Webcam’ drop-down, and when it’s there and I select it, it’s good.
However, each time I leave and come back to that page, it’s gone from the drop-down again.
Seems like I then have to change the equipment type, save, logout, come back in and go here again, and it’s there.
Then, go away again and come back, and it’s gone. :scratchinghead:

When I go here…
https://www.wunderground.com/webcams/signup.html
…First of all, the ‘Source Link’ column is blank (does that matter?).
Then, I click ‘Edit’ on the far right on same line as the cam.
I go down to the ‘Associate with PWS’ drop-down, but it still doesn’t show this new StationID in the drop-down.

When I go to the BS webcam’s webpage at WU, it displays correctly, and from that page, I can click “View My Personal Weather Station” and it takes me to correct PWS (the one I want to be connected with the BloomSky).

However, even though it appears to be getting the correct weather data and webcam, it doesn’t show this PWS on the map.
The map just shows one of those blue-ish location radius circles in the Apx. area where I selected on the map earlier. Only problem with that is that it won’t show to anyone else; only I get to see the radius circle while I’m logged into my WU account.

Hmm, you might have to reach out to the WU support people for help on this one. I created my WU account the day I got my BS, so I’m definitely not an expert there…

1 Like

I don’t know if someone has said this or not, but the FTP account creation can take a few hours.

I think I had to re-do this several times for everything to finally fall into place and work. Like I’ve said previously, the Wunderground integration with Bloomsky is very flaky.

Start with the station signup here: https://www.wunderground.com/personal-weather-station/mypws

Create an FTP camera upload here: https://www.wunderground.com/webcams/signup.html

Register the Webcam to upload to FTP here: https://wunderground-1112.appspot.com/uploader/submit/
It will deny the username and password for the camera upload for a few hours, then it will just work. I waited overnight.

Then go back to: https://www.wunderground.com/personal-weather-station/mypws
Click the gear icon, then edit, and see if the webcam shows up at some point.
I had to keep using the https://wunderground-1112.appspot.com/uploader/submit/ and resubmitting it until it finally showed up on Wunderground under the My PWS.

Once it showed up, it linked, but, shortly thereafter, it said unavailable. So I kept going through the steps over and over until it finally just linked together.
http://www.wunderground.com/personal-weather-station/dashboard?ID=KMOSTLOU63#history

The weird thing is, that when I go back to My PWS, it doesn’t show my webcam as linked anymore under the dropdown, even though it shows up on the actual public website. shrugs

I’m not gonna touch a darn thing unless it breaks.

1 Like

Indeed. If it doesn’t clear up in a few days, that’s what I’ll do.

I backed out what I could (couldn’t find a way of completely getting rid of the cam from my WU account).
Re-ran through the process (as yours above), and still have the same situation…weather data AND cam seem to be connected and working, but no PWS on the map.

I guess (in light of privacy concerns), this may be a more ideal situation to be in, but it’s just really strange, and makes me a bit uneasy, not knowing exactly what’s going on here. Oh well. I’ll just wait a few days and see what happens.

I think the reason for this particular PWS not showing up as a data point on the map, is because it is an outlier; it’s temp reading is significantly different from most of the other units in my area, and the system automatically keeps it out of the forecast data as well as preventing it from being displayed as a data point on the map.

Funny thing is that all three (SmartThings, BloomSky and WeatherUnderground) are showing same data when I look in my account at the station itself, but only WU is keeping it from appearing on their map. I assume that’s because WU has a more sophisticated data collection and verification process.

I’m having an issue as well… although a bit different than yours. I can eventually get my BS to register to WU (after many many tries) however it never uploads data. the chart on the submission page says none for both PSW and CAM upload. I left it as registered over night still nothing but emails from WU saying my station is offline… today i removed it and submitted only the weather data no cam and same issue

This is the same behavior I get. I haven’t touch the settings since Sunday — still the same (no uploads from the station/cam according to the BS/WU registration site) after two days.

1 Like

OK…mine appears to be working now. So, hopefully I’m good. :slight_smile:

I can try to troubleshoot a little bit with either or both of you.

Initial suggestions (not in order; just different things to try)…

  • back-out everything you’ve done so far (BloomSky setup, SmartThings integration, WU-PWS integration, etc) and start over (though few of us have discovered exactly what it was that finally made it work, this was one step for many of us in that process)

  • search the main BloomSky thread for posts about lights, colors, blinking, etc, and see if having any of that helps in the process (i.e. if you don’t know what state the BS unit is in, then you can’t know where you’re at in the process).

Here are some of my comments from over there via c/p…

For anyone familiar with how Chromecast works when initially setting it up from an Android phone (the main way I’ve done it), I wonder if that’s sort of like what this thing does when it first gets going.
As you notice, it gets which WiFi SSID to connect to directly from the phone. I wonder if, for just a moment (or longer, I don’t know), the phone actually makes a temporary direct WiFi connection with the BS unit, and then, once it gets the info needed from the phone, it severs the WiFi direct connection between phone and BS and goes to connect directly with WiFi router.




LIGHT COLORS, BLINK CODES AND LIGHT GROUP STATES




@Yongfeng_Zhang
I wasn’t sure where to put this. So, I just dumped it here for now.
If anybody has any more info that could help with this, please let me know (either here in this thread or via PM).


Power Status Light Color & Blink Codes
[NOTE: Of the three lights on the flat face that has all of those little brass dots, this is the one on the left; it looks like the standard power symbol.]

Off with No Blinking, ever = BS unit is completely off

Solid Green = This happens immediately after initially turning the BS unit on, and immediately after doing an 8-second WiFi button reset (It may come on solid for other things as well, but not sure).

Slow-Blinking Green (~10 seconds apart) = BS unit is on AND (I think) has an IP address from the router (i.e. regardless of whether or not it has a connection to your BloomSky account). In order to conserve battery life, they have it configured to have the lights mostly off most of the time, and it only blinks the power light occasionally in order to indicate to the user that it is on.


WiFi Status Light Color & Blink Codes
[NOTE: Of the three lights on the flat face that has all of those little brass dots, this is the one on the left; it looks like the standard ‘Power’ symbol.]

Blinking Red = ‘ready’ for WiFi configuration (i.e. no connecting to router has happened yet, because I’m assuming that, at this point, the BS is in a WiFi direct connection with phone)

Blinking Orange/Amber = got config data from phone, and is switching modes to go get a connection with router.

Fast-Blinking Green = BS unit NOT connected to WiFi router (probably need to do the 8-second WiFi-button reset and start over)

Slow-Blinking Green = BS unit is now connected to WiFi router

Solid Green = currently transmitting data to ‘homebase’ via WiFi router (IOW, assuming normal operation, it is ‘online’ while the WiFi light is solid green, and can be reached via ping from computer during this state)

Solid Red = This is simply the opposite condition of when it is solid green. During solid green, it is ‘online’; during solid red, it is attempting to get online, but not being successful (perhaps because it’s not able to get a good WiFi connection) for that cycle’s data transfer (no idea if it saves up data sets after an unsuccessful attempt to send them later, or if it just discards it and sends the latest data set the next time it gets a good connection; assumign the later).


Charging Status Light Color & Blink Codes
[NOTE: Of the three lights on the flat face that has all of those little brass dots, this is the one in the middle; it sort of looks like the plug end of a 2-prong power cord.]

Solid Red = currently charging

Off = charged (or…well…it could just be dead too lol )

Blinking Red = might mean not fully charged, and draining (this one is more of an inference from my experience. I’ve only seen it do this once. So can’t confirm 100% )



Light Group States
[Beyond the Color and Blink codes, it may also be handy to have a list of ‘known states’ of all of the lights together.]

Known State: Normal Operations
Circumstances: This is the state the lights should be in when everything is set up and working properly.
My Take: The BloomSky unit transmits data to the BloomSky servers once every 5 minutes or so (have seen it less at about 2-3 minutes, and have seen it much, much more at hours or more; it all depends on many factors). While it is transmitting, the WiFi light is solid green.
Power Light: Slow-Blinking Green (~10 seconds apart)
WiFi Light: Off most of the time; turns Solid-Green for about 10 seconds or so every 5 minutes or so.
Charging Light: Off

Unknown State1: ?
Circumstances: This was during the process of setting up one of these units; after one or more of the attempts.
My Guess: Since it had already received IP from router, it probably means that it’s on the network, but not connected to the BloomSky servers / or a BloomSky account.
Power Light: Solid Green
WiFi Light: Fast-Blinking Green
Charging Light: Off

Unknown State2: ?
Circumstances: This was during the process of setting up one of these units; after one or more of the attempts.
My Guess: Obviously, there is a network problem of some sort; just not sure of the rest.
Power Light: Off (probably more accurately a slow-blink)
WiFi Light: Solid Red
Charging Light: Off

1 Like

The BS<=>WU connection is not working for me, and apparently a number of other people:
https://bloomsky.desk.com/customer/portal/questions/16180746-weather-underground-this-pws-is-not-reporting

For a while my PWS was reporting it was being updated, but it never showed any data. Now it’s back to “This PWS is not reporting”.

The Bloomsky is working great; I just got my first timelapse.

1 Like

If you have any temp monitors in your SmartThings setup, I suggest the following (mind you, the process I’m suggesting is not an end in itself; it’s just a diagnostic tool)…

Not sure if you know this, but it’s possible to connect any temp sensor in SmartThings to a Weather Underground PWS via a SmartApp that’s made for this (I have one set up just to see how it works, etc).

Once you go set that up (let me know if you don’t have one set up yet and need assistance), you’ll have one more data point to use in determining what’s going on.

e.g. if you are able to successfully connect one of your temp sensors to a Weather Underground PWS, and if it starts sending data, and if that data ends up online as a PWS point on the ‘WunderMap’, then you’ll know that the problem is not on the WU-PWS end, and that you need to focus troubleshooting on your end with the BS unit, etc.

Not saying that will be the end of it, but it will at least give you confidence of knowing where the problem isn’t. :slight_smile:

Is this a standard SmartApp? I searched here and didn’t find anything.