TP Link Kasa Devices with new official integration (July 2019): reviews needed

Now that TP Link Kasa devices have an official integration, let us know what your experiences have been.

Note: as of October 2019, the official integration was updated to keep status is in synch, and now turning the device off with, say, echo should cause the status to update with SmartThings as well. :sunglasses:

When you report your reviews, please be specific as to the model number you are using and the DTH if it is not just the official out-of-the-box integration.

Dave Gutheinz @Gutheinz has now deprecated his TP Link community – created integration, and has some more details in that thread.
Thanks!

Make a smart lighting routine to control your switch. Make it turn off after power allowance of 1 minute. MANUALLY flip the switch.

It’ll never turn off.

Kasa single pole switch (HS200) and official c2c service that was recently added.

Edit: Exact same if you use the kasa app. It’ll never turn off. State changes are NOT reported to ST.

1 Like

That’s disappointing, but good to know. Thanks for the report.

However, I don’t see that switch on the official compatibility list. Just the bulbs and the pocket sockets. So I wonder if that makes a difference. What did smartthings identify it as?

I’m curious about a couple things re: officalKasa

  1. does the device work in classic?
  2. does the device work in smart lighting?
  3. does the device work in custom automation creator?

JD,

Official Integration. I deleted my integration, opened the new phone app. It discovered my TP-Link devices (all). Control worked; however, the state did not update as-expected. It seemed to be similar to same problem we had at one time with the classic app. State would update when you went to the details page or back to the devices page.

My Integration. I could not install the app in the new phone app. After installing using the classic phone app, it can be run in the new app to add devices. One good thing - with the energy monitor plugs (HS-300, HS-110, I was able to get the power and energy to display in the new app (it does not in the "official Integration). This required a change in the vid parameter.

Dave

2 Likes

Update: My devices include:
HS-100 plug
HS-105 mini-plug
HS-200 switch (not on list from SmartThings)
HS-107 multi-plug
HS-300 multi-plug with Energy Monitor (no EM functions in official integration)
LB-120 CT Bulb (not on list from SmartThings). Works great; including setting CT.
LB-130 Color Bulb.

1 Like

VID Parameters: If anyone has an official list of VID parameters, it would be GREAT. There are some unofficial lists, but rather incomplete. EG: Is there a VID parameter for color Temperature Bulbs?
dave

2 Likes

You’re right. I could have sworn this worked when I first set it up. I have the HS105 plug. Bummer. I guess it’s a ticket to support. Luckily I don’t really use that plug since I’ve been moving to the Samsung plugs as they run local with smart lighting.

Where do you find the smart app in classic so you can add the devices?

image Installed a WS200 switch and 2 HS105 yesterday.
Hub v3 with the new iOS application( SmartThings Samsung Connect V3)
When I use the Casa application, the status is not reported in Smartthings. When I use the SmartThings application, the status is reported correctly in the Casa application. When I swich on manually the WS200, the status is not reported in the Smartthings application.

I have done the same process as I did with my Lutron Caseta stuff that works perfectly.

Many WiFi switches do not report status when operated manually. You can often tell by checking the IFTTT channel: if there are no triggers, only actions, it’s quite likely the device doesn’t immediately report a change in state even to its own app. :disappointed_relieved:

1 Like

The unofficial integration has the same problem. A user could set refresh rate down to 1 minute (it would capture the use then). Some kept asking for 5 second refresh rates (which I resisted).
Dave

2 Likes

To add the official devices, you would use the new app and select add devices. They apparently do not install in the classic app. After adding, the devices are available in the classic app.
Dave

1 Like

I’m not concerned about polling traffic on a WiFi network, but you would still be adding tasks to the hub and the cloud, so I think you were right to be concerned.

These Devices should still work fine as the target of an Automation, but not the trigger, so it just depends how you want to use them.

2 Likes

BTW, there is a rumor that the reason Amazon has not added switches as a routine trigger is because of this issue. Too many of the cheap WiFi Devices sold for use with Echo wouldn’t work. :disappointed_relieved:

2 Likes

Summarizing: In my opinion, the official integration works as expected and supports all of the devices (including the Range Extender/Plug). The expected quirks of using the new ST app to install aside, it also works as expected in the Classic App.
Exception: Energy Monitor functions of the HS-300 and HS-110 do not work. I have updated the EM Device Handlers in my integration to support these functions in the new app - Power and Energy only, not statistics.
My Recommendations:

  • Use the official integration for all your devices.
  • If you still have a use case for Energy Monitor functions, use my integration for those devices only.

Final Issue: Does the new official integration work will with rules and Applications like Action Tiles???

2 Likes

Tagging @tgauchat

1 Like

New here, so hope I am not out of place here.
Loaded 3 @ HS-100 into the new ST app, and they work there. However there are two issues.
A) ST classic shows the 3 devices, but seems to try and operate, but gives up (no error msg tho). Also when I try and open the device settings (gear icon) I get
“Somethings wrong” “We cannot load your screen right now.”
B) Action Tiles also shows the 3 tiles, which do toggle, but no error msg and no action from the plugs.
Both situations have existed for 2 days.

Sounds like the normal experience using the official integration. I got a Kasa RGBW bulb to mess with in SmartThings and so far here’s what I’ve noticed:

  1. works fine in the new app and with scenes
  2. as others have said, doesn’t work with Classic and a lot of the older groovy apps Haven’t tried Smart Lights yet.
  3. the integration is “one way”. Changes from the Kasa app, Alexa, etc. aren’t reflected in SmartThings.
1 Like

We should also mention that most people find one way integrations are OK for pocket sockets and in wall receptacles as long as you set up the voice assistant integration through SmartThings rather than through the native app. That’s because it’s pretty rare for someone to walk over to a pocket socket and push the button on it. So the one-way issue doesn’t usually cause a lot of problems.

However, A one way integration just isn’t enough for a wall switch because then you’ll be continually getting out of sync when people use the wall switch manually. And, of course, you won’t be able to set up a virtual three-way.

So I think satisfaction levels will depend very much on the specific devices involved, and on how you set up the voice assistant integration.

4 Likes

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.