Supporting new E1 Aqara devices

Hi Veon,

I tried installing your driver for xiaomi blinds before and I couldn’t use it, but today it worked! I guess you added the E1 fingerprint, so really BIG THANKS!!! It does not refresh and the close function and setting the level to 0% don’t work but the rest does, so I can just use 1% and I don’t really care that much about refreshing as long as it carries out the commands, so it is really a big relieve.

Thanks again, mate!!


in v1.1

  • the open command sets the level to 1%,
  • minor changes to the level report
  • toggle button added to make it possible to toggle via routines

Awesome, it works quite well now. Thanks a lot for your effort!!!


Excellent. It’s working well. Thanks alot :ok_hand:t2:

Don’t suppose you have anything working with the Radiator valves E1?

no, unfortunately, I don’t have any of these, and they are pretty expensive just to change from another manufacturer

@Mariano_Colmenarejo ,
you already have ZigBee Thermostat Mc , can you add aqara Radiator valves E1?

Hi @dotan_shai

I don’t have a zigbee Thermostat driver, I have added some device fingerprints, which use standard zigbe 3.0 clusters, to the stock Zigbee Thermostat driver, which also uses the default libraries for zigbee 3.0

As far as I know, Aqara E1 does not use standard clusters for some functions.

I’m sorry, but I’m not going to do the work for aqara.

I try to adapt how I can the devices that worked in groovy so as not to leave users without their devices in the edge transition and another is to want to buy devices, which are known to have no edge driver or do not use standard clusters and are more difficult and laborious to adapt.

There are standard zigbee devices on the market, see stock driver fingerprints, or ask Aqara to make a driver


They did work in groovy, still do but I’m guessing it will soon be gone!
But yeah, it’s very annoying that their devices don’t just work with SmartThings. If I can’t find anything to get them to work, I will just bin them😂

Yeah they are. I bought 2 a while back as the eurotronic ones were a bit messy prior to moving it to their own edge driver. Now they work flawlessly to be fair. Just didn’t fancy throwing £100 in the bin. I do like their products but really can’t be bothered having multiple zigbee hubs! Thank you anyway

Hi @Rui_Rodrigues

If it works in groovy with a standard dth then it might use standard clusters and attributes.

What DTH do you use?


Just the standard zigbee thermostat. Its not fantastic but I can get the temperature and set the heating temperature. This in turn, opens or closes the valve. Thank you for looking into this.

Hi @Rui_Rodrigues

Added ti this driver version
This profile is the most similar to the DTH zigbee thermostat.

I see that the battery does not work, it shows 0% and I have added the xiaomi battery utilities in case it was sending the battery information through the cluster 0x0000 instead of 0x0001

 Name         Zigbee Thermostat Mc
 Version      2023-03-10T15:18:41.656772008        
- id: "Aqara-E1/lumi.airrtc.agl001"
    deviceLabel: Aqara-E1 Thermostat
    manufacturer: LUMI
    model: lumi.airrtc.agl001
    deviceProfileName: base-thermostat-battery-fanless

You’re a star! Battery still not reporting but it is working. For me all I need is the open and close so happy days. Thank you very much


Hi Andrew,

The driver works, thank you!
Question, what is the intended function for the power state button?

Also is there any way to implement limit settings in the driver? + fix on the battery status.

Thank you so much for your assistance.

Cheers! :+1:

Hey guys, just wanted to clarify that the purpose of this driver is to foster a community of developers interested in Aqara devices. I might not be able to help with customer support, especially for drives that I have not personally used.
Let’s work together to create something great


What about Aqara B1 ZNCLDJ12LM. It shows up as zigbee window treatment but doesn’t work. However I noticed when I click the motor button and it’s in process of closing then I can click open in the SmartThings app and it opens. So as long as it’s in motion I can change the direction. But once motion stops then I cannot control it from ST app anymore.

edit: I got the curtain motor working with Xiaomi/Aqara Blinds 1.1

1 Like

Haw to download this driver ?

From @veonua channel

1 Like

Hi all, need some help on aqara e1. Just got the machine today. I can pair with the driver. However, I can’t initialize and the button all can’t work (open, close and pause)

Here is the device info. Can anyone help. Thanks.

1 Like

@Joseph_Ong Did u managed to get this work?

Hi all, anyone manage to get the Aqara E1 curtain works on smartthings ? which edge driver if so ?