[ST Edge] Issues pairing a device with the driver

Hmm, I got a catchall in the IDE and the device paired with the hub, but is not showing up in the device list. . .

It finally showed up as a Thing but I get a “cannot connect to device” message when I try to access it.

I created this post to check this issue further. Is it possible that you make a query to the device list to check if your device is using a driver?
To do so, you need to follow these steps:

  1. Create a Personal Access Token using at least the “Devices” scope.
  2. When it gets generated, save it in a secure place as it won’t be displayed again.
  3. Use an API client such as Postman and configure it for the GET request

  1. Check the following:
    a. At the beginning, it shouldn’t have the property "deviceTypeId"
    b. Find the device in the list and look within its properties the one named "zigbee" or "zwave" depending on which kind of device it is. Inside, you should find the “driverId” property,

Note: If you have tried several times to pair your device with a driver but it is still connected to a stock DTH, this means no driver installed in your Hub has your device fingerprint.

      This is what I get. The Aqara Cube uses a custom DTH which I removed from the IDE so as not to interfere with setup.

“createTime”: “2021-10-22T16:38:50.443Z”,
“parentDeviceId”: "1fa6b2f9-6de6-4a2d-a34d-7441bd8bxxxx
“dth”: {
“completedSetup”: false,
“deviceNetworkType”: “ZIGBEE”,
“deviceTypeId”: "8a53ab1f3d88225d013d882308cexxxx
“deviceTypeName”: “Thing”,
“executingLocally”: false,
“hubId”: "1fa6b2f9-6de6-4a2d-a34d-7441bd8bxxxx
“networkSecurityLevel”: “UNKNOWN”

Ok, this is being paired with a DTH but not correctly. Could you provide more details about your device?

That is indeed the device. I had it working previously. About a year or so ago I switched platforms to WebThings, because it ran local, I could access it via internet, and I could integrate my Tuya devices. I started having issues with that and because of lack of support I migrated all my device back to SmartThings, using the original DTH and SmartApp. The cube was connected and recoginzed but only showed “pressed” in the app no matter what function I performed, but the right action was being shown in the IDE. I removed the custom DTH and Cube SmartApp and installed the veon Aqara cube driver.

Ah, do you mean this Edge driver published by a community member?

I found this comment where it’s mentioned that the developer intentions weren’t sharing and giving support to these drivers:

I didn’t find an official DTH for this device, but you also mentioned that you previously used a custom DTH and SmartApp.
As the driver you’re using wasn’t released from SmartThings and the developer won’t give support, it means you would need to create a copy and modify it to integrate your device correctly.

Thanks for your help Nayely . it’s just frustrating because it worked before and now it doesn’t. I will look for an updated DTH and SmartApp. Once again I appreciate your attention to this issue.

can you tell me the model version of your device?

1 Like

I have the Aqara MFKZQ01LM

It looks to me like there are two possible issues.

  1. The DTH probably converted all the actions into button presses with a buttonnumber in the data. That only really works with legacy apps. Might also be custom attributes and commands around. The app won’t notice them either.
  2. Your cube may well report as lumi.sensor_cube rather than lumi.sensor_cube.aqgl01 and so not match the fingerprint for the Edge driver. Whether it would have other differences I wouldn’t know.

I removed the DTH and related smartapp before trying to pair with driver.

The cube is being reported as lumi sensor_cube.

In that case it might simply be a case of adding that as a fingerprint. It rather depends on what differences there are between lumi.sensor_cube and lumi.sensor_cube.aqgl01 apart from the Zigbee model name itself.

“lumi sensor_cube” is added to the fingerprints

It works for me now.

2 Likes