SmartThings Classic app login error/loop

Hi guys I’m having an issue with my smartthings classic app. My Smartthings Classic app will no longer login. I am in a perpetual loop. When I open the app I get a screen, new user or existing, click existing, enter email, opens browser, asks if I agree, takes me to the app, two seconds later the whole process starts again!

I am using a Moto G5 Plus and it’s been fine for over a year. I reinstalled the app and that seems to have kicked me out. My account and the app works on my iPhone and Samsung tablet A8. I just installed it on my Samsung A10 and the same loop and login issues exist. Seems like new installations causes it.

I’ve tried clearing the cache…no joy.

Any thoughts?

Hi… I having the same issue now.
It comes with 2 options to login either “New to Smartthings” or “I’m a SmartThings User”

When i choosed “I’m a SmartThings User”… it keeps looping for login
When i choosed “New to Smartthings”… all my devices missing.

Any thoughts?
Cheers

Yeah that’s what is happening to me. Did you uninstall and reinstall for any reason?

No, i did not do that.
it happens to my Samsung S8+, meanwhile i have another account install on my ipad which works fine.

Yeah similar. I have account on other Samsung phones and tablets and iPhones and iPads that work just fine. It’s bloody annoying. I have contacted Samsung and am waiting on a response from them.

1 Like

If you’re using a Samsung login, choose new user.

Same issue for me. Android version was working fine an hour ago, but now I get the same as Terry… login loop.

Funny. This morning I logged in, selected new account and new user and used my original Samsung account details and I managed to log in!! I managed to control my devices and the app worked as expected.

Now it doesn’t work again! I reckon it is definitely something on Smartthings side…server migration issues? The errors seem to correspond with the issues EU users were facing last week. It was about that time my app started playing up as well.

Urgh…!

Update guys, just tried again as a new user and I’m logged in. Almost wanna just keep my phone constantly on so as not to log out!! Let’s see how long this lasts.

1 Like

Anyone had/got any updates on this please?

I’ve got the same problem. Its been reported here Can’t login on Android App and HELP! Smartthings classic app logged me out and won’t let me back in

No response from Smartthings help but my app has magically let me back in this morning. Fingers crossed…

Mine too! Suddenly works yesterday.

I’m having similar issues to what is described here. I opened up a ticket with SmartThings (useless customer support) and opened up a new thread: SmartThings Login Not Working (10 July 2019). If someone could please help me I’d be so grateful. Thanks.

you can try to uninstall the app or go to the android settings, apps, click Smarthings app, click the storage section and delete cache and data. The next time you reinstall/start the app you will have to enter your credentials again.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.