SmartThings Community

SmartThings Login Not Working (10 July 2019)

I have a Google Pixel 3. I recently logged out of my SmartThings Classic application and now I can’t log back in. When I hit the login screen, I type in my credentials (yes, they are correct) and the login just clears out and reprompts me. Sometimes I get the "Continue with Applicable service: SmartThings (Non Samsung Android). At the bottom of that screen, there’s a “Continue” button. When I click on that, NOTHING happens. Not screen change…no nothing. The URL doesn’t change either. What I have noticed is that the Smartthings Samsung account login URL https://us.account.samsung.com with all of the query string parameters added to it does not work, but if you go that URL directly without the query string parameters, then you get a completely different login screen, which does work. I have tried this on an iPhone that I have access to and everything works fine. I have tried different browsers on my phone (Edge, Firefox, Samsung browser) and setting each one of those as my default browser and it makes no difference. I’ve tried clearing my browser cache, uninstalling and reinstalling the app, restarting my phone…literally everything I can think of. My assessment is that there’s a problem with the Samsung login. I’ve chatted with Samsung support by opening a ticket. They have been LESS THAN USELESS. Does anyone here have any suggestions? Please help!

are you selecting New to SmartThings when trying to login to the Classic app?

I’ve tried both options. I get presented with the same screens.

Attached are the screenshots of the two logins I get!

can you login to https://account.smartthings.com and your hub and all devices show there?

1 Like

Yes. There is no issue with normal Samsung account logins. I have been able to log in and see my SmartThings account and devices on an iPhone. It’s just my personal Android device isn’t working. I can even log in to Action Tiles using my credentials and reauthorize things though there. Works great. But, the SmartThings login just won’t work.

Try uninstalling the App(s) and reinstall.

Might also help to clear browser cache.

If you read my original post, you can see all of the things I’ve tried, including what you suggested. I’m just at a loss.

So, if you go to the following URL on any browser - even on a computer - it DOESN’T work! URL: https://us.account.samsung.com/accounts/ANDROIDSDK/signInGate?locale=en_US&svcParam= + some unique identifier stuff after that… It clearly is a different screen than the normal samsung login, and it just plain doesn’t work…

This is understandably frustrating!

Do you have any shared users? If so, does this login issue impact them?

If you go to Settings --> Accounts on your Pixel, do you see a Samsung or SmartThings account listed? If so, are you able to remove that account?

When you get the “Continue with Applicable service: SmartThings (Non Samsung Android).” screen, are you able to tap “Use a different account”?

Hi Brad -

My wife’s phone is connected, but I hesitate on signing out because I don’t want her to be logged out either. If I go to the Accounts area on my phone, neither Samsung nor SmartThings shows up. When I try to add SmartThings, it just tries the same login process that does not work. When I try clicking on “Use a different account” and put in my credentials, the input boxes just clear out. It doesn’t take me anywhere new. I even tried to create a new Samsung account with a brand new email address and that doesn’t have any effect.

As I’ve stated before, I tried on an iPhone and it works fine. I’ve tried on my Samsung Galaxy Tab A…works fine. I’m truly at a loss.

Thanks,
Josh

Thanks, that information is good to know and I can pass it along.

My guess is that it will fail as well since a new account doesn’t seem to work either but can you try having your wife sign into her account on your Pixel?

What version of Android and SmartThings are the Pixel running?

I just tried her account and it’s not working either. I am running Android 9 with the July security update.

I’m in. I reset app preferences, disabled developer options and then shut my phone down rather than restart. Not sure which one of those did it. Thanks for the help.

1 Like