SmartThings Android App (18th October '22)

It’s definitely an app issue. I rolled back to the previous app version on one of devices and I can change drivers at will.

Thanks. That’s the most helpful thing anyone has said so far. Seems like installing an older apk might be a good temporary solution until Samsung stumbles upon the real fix.

Lets not be too judgemental of the development team on this.

No developers deliberately break things and everyone can make mistakes.

In my (long) experience of working in IT the team(s) behind this will be working non-stop to get a suitably production ready fix out and deployed. To both the app and the hub - and I am sure they are not stumbling around :blush:


Just to provide some clarification about this, the iOS app had other issues that affected the discovery of devices and automation creations that other users were waiting for. Those were solved in this new version and it was important to provide them with this solution.

I don’t understand why this comment was removed.
The rush is not good and it seems that now we are going against the clock and many mistakes are being made, nobody says they are voluntary or in bad faith, but every few days we have a surprise, when it is not the app it is the firmware or undocumented changes.

Nobody wants or wants it to happen, but it would not be the first time that all the routines disappear, it happened to me the 2021 year 2 times along with other users, irretrievably according to the response received and it was a… annoyance

We are simply asking for more reliability when you release updates and quick fixes when something goes wrong.


I had a comment removed today that was critical of SmartThings for not providing hub users with a backup and restore option. It wasn’t a rant, just a few words, and had no objectionable language. And it had more likes than any comment I’ve ever made. :wink:

Feels right to me.


You can send this request to Customer Support. They could guide you better in case there’s already a way for you to do this.

Just as a reference, here are the guidelines of the Community forum:

Since this issue affects the community at large, it’s probably best discussed in the community. Perhaps not in this thread, but in the community.

Edit: Typo

Then, you can create a separate thread for others to chime in and share that post with them so everyone sees this is a big request. I mentioned you need to contact them because they’re not around the Community and they should have more info.

Just curious if anyone else is noticing that devices status are not updating in the app? This is most prominent in the last 24 hrs.

Example, my hub was offline but showed online in the app. When I opened the hub details then it showed offline.

I’ve had one device drop off and not rejoin, another one i had to re-pair but no longer works.

My automations are all local but seem a bit sluggish in the last day.

Yes, got some device with wrong status in app

Ditto on devices in the app showing the wrong setting or saying offline when they are not.

Hello everyone, the hotfix for the change driver tool was released some hours ago, please let me know if this works for you. I just made a test and the menu appears correctly, in my case, I had to reinstall the app (Android only) but you can check if it works by deleting the cache first (Android). Here’s the evidence:


@nayelyz driver change is working on Android without uninstalling app or clearing cache.

1 Like

About the issue with devices showing an “offline” status, does someone have any Sonos device Hub-Connected?
There’s an issue reported with these devices causing the Hub to restart:

I didn’t do anything and all of my Android devices are working. If fact, my iOS device on the latest SmartThings app is working now as well.

1 Like

I have Sonos connected and had a delayed off request fail last evening but others have been fine since.

I will keep an eye on the hub but oherwise have not noticed anything out of the ordinary.

1 Like

Worked for me (on Android 10 and 12 devices) after re-install. Clearing cache alone wasn’t enough. Thanks for the fix!

1 Like

Deleting the cache was all i needed to do on my S20+ 5G for it to work again.

1 Like