SmartThings Android App (18th October '22)

Hi, everyone!
I just wanted to let you know that I already reported the issue changing the driver of a device. We’ll keep you updated


Same blank screen issue with me as well while trying to change edge driver for a device.

On a Pixel XL if I select a device the app crashes, but I’m able to edit routines.

After update can not change driver any more. In last step just black screen

It’s a mode issue.

I see the same thing when using Dark Mode on my phone.
Works fine with Light Mode.

Hi. No its not matter in my case. Here is with light mode. Same result

Samsung is aware and working on it.

1 Like

I don’t know if it was also a problem on earlier releases as I haven’t looked for a while, but in the UK at least the ‘Contact Us’ link now just presents a number of options that point you at sparse Samsung UK support web pages of no real relevance to SmartThings.

The ‘Report a problem’ option offers to create an app log, and indeed silently places one in your downloads folder, but then just directs you to a vague Samsung UK web page that is of no help in reporting a problem. This one …

I am not currently trying to report a specific problem. I was just exploring.

1 Like

Any update on this? It is kinda a big deal not being able to assign the correct Edge driver.

How does an App update brake the ability to change Edge drivers?

I have several old and new devices that are not functioning, because I cannot change to a working edge driver.

1 Like

One of the links at the bottom of the directed page is ‘email the CEO’ Graham, no doubt that individual would know what to do with a CLI log because creating a log in the app might or might not happen

Considering ST is Samsungs big thing, there are areas that need much work still

Hopefully this will be corrected soon. It is definitely affecting my testing.

Is there any way to make a driver change with a CLI command?

smartthings edge:drivers:switch


How frustrating this is, and there seems to be minimal response from Samsung. In the last version of the Android app drivers didn’t even show in the three dot menu, now they are present but cannot be switched.

The team keeps working on this.
There’s an alternative as mentioned here: SmartThings Android App (19th October '22) - #34 by orangebucket

CLI command: smartthings edge:drivers:switch and follow the prompts.

I just tested the command and it works correctly, just be careful assigning the correct driver.


If you don’t enter any device id, it shows you all devices with edge driver, with their name.

you type the device number and then it shows you the compatible drivers installed, just like the app.
Just choose one of the proposed and there will be no problem.


CLI is not a viable solution for the average user. SAMSUNG needs to fix what they broke.


Yeah, this was only a suggestion for people to continue their work. This is considered a critical issue and the team is working to have this fixed ASAP.


5 days spent to fix a “critical“ issue and still no resolution? I can only imagine how hopeless a non critical issue resolution would be. Sigh.

What is worse than 5 days to fix a “critical issues” is Samsung knew the Android update broke change edge drivers then seemed to know it was broken and rolled it out to Apple users, anyway. Why not stop the apple roll out until the issue was fixed?

Was it an app update the broke it or was it the hub update?