New version ( ) of smart things app for android won't load

Does anyone have such problems, with the newest version for android?

1 Like

No, but i noticed that offline devices show up differently now:

Strange. As soon as app would finish loading, it closes again. The only thing I see is the log in logo, …after few attempts phone notify me about frequent crashes…no shit :slight_smile:

1 Like

I have found this error on my Smoke/co devices running my own Edge driver:

It will go away eventually, but this is a new issue that wasn’t there before.

@nayelyz ,fyi

EDIT : Figured it out. ST finally got around to adding the atmospheric pressure measurement capability, which the Halo Smoke/CO detectors have as a capability. This capability wasn’t presented in the old ST provided DTH, but I added that capability to my Edge driver but I hadn’t yet developed that part of the code. I removed that for now until I have tie to get back to this Edge driver and update it.

That happens with my devices from time to time as well. Usually, rebooting the hub solves that problem.

1 Like

Have you tried doing a force stop then clearing the cache? Or deleting and reinstalling the app?

Unless you’re on the beta version, the app hasn’t been updated since December 8th.

I did all of that, multiple times :slight_smile:
Version is

What is your version?

On google play I see last updated date 1.jan 2023.

I am running installed on 12/8 and I am not having that problem.

I have a Google Pixel 6a, running Android 13.

Had update to this version on Android sometime over the last day or so.

I have not noticed any issues to date or changes not notified in app notices but, for unrelated reasons, I had subjected my entire IT estate (sounds grander than it is…) including hubs, phones and router/switches to a complete shutdown and reboot before I noticed the app had updated. That ‘may’ have resolved issues with the app that I did not yet know I had :rofl:

I’m also on as of just after midnight.

Strange that i am the only one with this kind of problem. I can revert back and then everything works again :slight_smile:

Yeah that is odd. I meant to also say I’m on a Samsung Note 20 (on Android 13), but I have no idea if that makes a difference. I did get the latest phone update back in mid-December, which also brought along Samsung’s latest One UI version (5.0 I believe).

Same. I guess Google hasn’t propagated the newer one to either of my devices. Samsung S5e tablet, Android 11. Google Pixel 4a-5g phone, Android 13.

1 Like

brand/model of your mobile device? Android version installed?

S20FE, android 13 is on the device - more or less freshly installed :slight_smile:

How it looks like…

92.24 had the BSOD when returning to device pages, hopefully the new version resolves this


Just updated to version and the app does not load. I get the same error as you.

I tried clearing the cache and rebooted the phone, but still not working.

Samsung galaxy s21, android 13

1 Like

Well, at least I am not alone :grin: sorry. :confused:

I will observe how fast they can prepare a fix :blush: