Android app update 23 February 2020 - v1.7.44-21

Android app update 23 February 2020 - v1.7.44-21 has been released.

I haven’t found any difference yet. Please post here if you do.


Nope me neither

Just got this update. Haven’t had much time with it, but the first changes I’m seeing are:

  1. temp/humidty graphs have been fixed for devices with both capabilities
  2. a graph was added for UV index on the weather tile (but it doesn’t display properly)
  3. my Echo Speaks devices now have controls that work (volume, play/pause, and next/previous track).
  4. STHM now displays a warning message on the home screen if any of the monitored sensors are offline (message is “Some sensors not ready”)
  5. the custom abbreviated names for my automations have been replaced with really long names detailing all of the steps/logic/devices

I also have a strange issue that started with the previous app version that’s gotten worse with this one. I have several Aqara temp/humidity sensors, and a while back I was playing with the code in the DTH adding various capabilities in order to see if the temperature could be queried by Alexa (Alexa doesn’t recognize temp/humidity sensors). When I was all done tinkering I assigned the original DTH back to all the devices, and then deleted the edited DTH’s I had been using. For some reason some of the devices were still showing capabilities that are no longer in the DTH being used. I’ve tried changing the DTH to something else, saving, opening the device in the app, changing back, saving, and opening in the app again. The strange thing is that each sensor seems to be using a different historical version of the DTH, none of which are assigned (or even exist). One worked as usual, one showed all of the capabilities of a thermostat, one showed contact sensor capabilities, etc. With the newest version of the app, the sensors that had additional capabilities from previous DTH versions now don’t show anything other than “Connected” with an error message at the bottom of the screen that reads “[uri} empty href”. Two of them however work just fine, and they’re all assigned the same DTH.

1 Like

1-3 are done via plugins, and are showing in iOS too without an app update. 4 has been around for a while. 5 could be new. Do you have a screen shot? the last update added the icons to the Automation tile, but i didn’t see any update to the names.

The name length change and icon changes came with the previous release. I haven’t reveived the update yet, and this is how mine look. I already changed my automation names to fit an even earlier release, but they will “word wrap” if I remember right. @MinerJason, is this how yours look now?

Can you elaborate? My Echo Speaks devices do not show proper controls (just show Connected).

That’s how mine looked several days ago. Looks like this now:

Adding the plugins (on Android 10) showed the graphs previously for me, but until this update they didn’t display the data properly. It displays properly now. The UV index graph may have been there with the previous update and I just now noticed it.

Screenshot attached. I was able to edit them back to the abbreviated names, but after the update all of my custom names were overwritten with the original longer auto generated names.

Edit: for example, the one that reads “Love Temperature Humidity: Equal to or below 50” previously said “Love Humidifier”

Mine looks similar on Android now after the update.

Where/how do I install the needed plugin?

That is a good question. I am really hoping that @blake.arnold can give us some instructions how to force the new app to update the UX pluggin when the DH changed.
In your case @Nezmo, it should have picked up automatically. But I have a few devices which hasn’t picked up the new UX, like the combined temperature and humidity graphs.

Well, it seems a force close of the app resolved it this time for me at least.

Was just going to suggest force closing and seeing if the prompt to install the plugins pops up when you reopen the app. I ignored the prompt the first time after the previous update, and had to do that to get it to show up again so that I could accept/install.

1 Like

I didn’t get any prompt about any plugin upon restart but my Echo devices do now show as players. I am on iOS though.

1 Like

The version on my Android phone is and it says it’s the latest version?

Legen, WAIT FOR IT, dary. - Legendary…

It is updated in sequences, you will get the new app in a few days time.

It seems that some of the ux changes in the app are pushed to the cloud separate from the app updates (and may not be rolled out to everyone at the same time).

If you want it now you could check the play store and see if the update is available there.

I received it this morning on my Galaxy S7 (Android 8.0.0) & my Galaxy Tab A (Android 9.0.0). So far I can’t find anything that seems different.

I also got the update this morning & haven’t noticed anything different.