Samsung tv has lost Smartthings connection ( Resolved 17/05/18 )


(Mike) #1

My Samsung tv has been connected to smartthings for the last few months with no issues. Today it dropped off smartthings and is no longer discoverable???
Using 1203.6 firmware

Oddly we did also have new terms and conditions appear when the tv was turned on and sign in was triggered which had issues. The software shown on screen was missing a tick box to agree to the t and c’s. A live chat and remote connection to reset the tv smart hub corrected that problem and I was able to tick the missing box. No idea if all these issues are linked but something is defo not right at the mo with my samy tv, we definately miss the ability to voice control via echo

Right now i have pulled the batteries and un plugged my St hub to see if that helps


Samsung TV - Can't Turn On
Samsung Connects, Smart Things and Samsung TV Integration (Dec 2017)--What works together?
Please help! Can't connect Samsung TV ks8000 to SmartThings hub
BE AWARE what you are getting into
Samsung TV UN65KU6300 Issue
Samsung 2017 series 6 tv on/off virtual switch in IDE?
Working Samsung TV FEV18
(Joe) #2

I am in the US and I had the same problem. I opened a ticket with Support and they told me this:

Sep 21, 1:14 PM MST

Dear Joe,

Thank you for reaching out to SmartThings Support!

I am sorry that you are having trouble with your TVs within SmartThings! We are currently running into a known issue. There seems to be a firmware update that has been applied to the TVs, so we are currently in communication with the television side of Samsung to resolve this as quickly as possible! Or engineers are aware of it and I will make sure that you are informed when the fix is made.

Thank you for your patience in the matter.

The part I don’t understand is I have 2 TVs and one is still on SmartThings, but the other isn’t.


(Mike) #3

Even more confusing. I have a Galaxy s7 which has the latest Samsung connect software. Although I don’t use connect the tv works fine from the connect software, connects perfectly and has new ui. So why isn’t St connecting? I thought St and Samsung connect worked in similar ways, all the blurb about connect and St has them side by side in help files and q&a’s
Unless connect is a direct connection and St cloud based
I even tried adding the Samsung tv 2016 option from the ide. It added fine and then I did a add a thing search, St accepted the added ide of the tv but still no connection, it’s almost as though the tv lacks the (allow) this device option


#4

That’s exactly it :slight_smile: The SmartThings hub uses a different means of connecting with the TV. That method was broken in the last TV firmware update.


(Mike) #5

Trouble is it sort off worked and then didn’t again Tyler which is weird. Wednesday no connection from St, tried adding it no go
Thursday morning for no reason and from no interaction with software… The tv appeared in St? Didn’t work though, went to work came home tv still in St, tested on off worked fine but with new ui which is different from Samsung tv 2016 ui, 10mins later stopped working. Removed device tried to reinstall and nothing, St Just sits looking but can’t find tv again and I have no idea what combination of swear words and software button mashing made it work for 10mins… Very frustrating

Tbh I’m taking some comfort from the fact I’m not alone as joe has same issue

Didn’t help initially I was thinking it was an amazon echo smart home issue, that software is a real ugly mess at the mo

Thinking out loud Tyler, what if I reset my St hub back to factory and added it to connect with the welcome code, would that then give St direct connection? Or would St still use cloud regardless
Tbh I would rather not as I have a lot of custom St settings but is the principal correct


#6

Definitely don’t reset your hub. The SmartThings Hubs currently have a single way to communicate with Samsung televisions, and that way seems to have broken with this previous TV firmware update. Resetting your hub won’t solve this unfortunately.


#7

Samsung TV support said I needed to update to the latest FW (1206.1), I did but it hasnt fixed ST integration for me.


(Mike) #8

Really glad u said that Tyler :grin:


(Mike) #9

I was never going to let this alone. As said above I had the tv appear and work in smartthings with a different ui to the usual Samsung 2016 ui but I couldn’t figure out how or why so some testing was needed
My findings are confusing considering what Tyler said above. Samsung connect uses a different connection method to the tv from that of Smartthings, my understanding is smartthings is cloud connection, Samsung connect is a direct local connection to some things
With that said I unplugged my St v2 hub completely, uninstalled Samsung connect from my phone and reinstalled, reset my tv to factory making sure notifications were on for new connections, echo app smartthings was disconnected from echo smart home
St is unplugged and as expected all devices are off line and no tv added by any method
Using Samsung connect I searched for devices and found among other things my tv which I am still assuming is a direct connection as the tv is not in the st app and not in the ide, back into the St software and behold my Samsung tv has appeared in the list of devices without adding it and everything else showing as off line as the Hub is not plugged in. Not only has it appeared it has a similar ui to that off Samsung connect and works fine, so my St software appears to be connecting with the Samsung connect software and connecting directly - as the hub is completely un plugged
How long this remains usable is as yet unknown, next I need to plug back in my St hub and reconnect echo smart home to smartthings

*next day update
Plugging in my St hub everything is as it should be, all devices are normal and the Samsung Tv is still there, Amazon echo smart home is re connected to smartthings BUT the Tv is not connecting to echo. There are now 4 different Tv entries in echo smart home i am guessing legacy tiles from previous attempts to get it all working again but non of them appear to work with samsung connect or smartthings and due to the poor UI and options in echo smart home the user cannot delete or reset the echo list of devices.
Interestingly or not in echo smart hub each Tv entry is listed as ( connected Via ) Smartthings and non of them say ( connected Via ) Samsung connect, which would really help troubleshoot and trace what is connected to what
The Smartthings echo skill is listed as Smartthings /Samsung Connect, if Samsung are tagging there own version of Home automation to Smartthings it would be kind of polite to add there own name to conneced devices !
having found all this and nearly made everything work again it appears that the only real option for new users of Samsung Tvs and ST hubs is to start with Samsung connect, get everything discovered and THEN plug in and add the ST hub which should populate with its own discovered devices AND local devices which no longer use the cloud ( samsung modern Tvs )
idealy i would need to reset again and wipe my hub but honestly i really dont want too

And then i discover that the Tv has an ident with OCF in the IDE which then made me check the ide connection which said cloud and everything else in the ide says hub… give up my brain just melted OCF is supposed to help not confuse


(Ricci Hoffer) #10

I am seeing similar results. I am on the account migration beta and now have 2 home locations. The new location, I am assuming it is samsung connect since it does not have a hub listed. My KS8000 with a different UI and my phone is on that side. The TV is usable. I have deleted it and it reappears just like the phone when I delete it. Everything else, senors, automations, smart apps, another version of my phone are on the other one, now with a Samsung Log in. Waiting to see if they get the locations mergered or for them to provide guidance to delete one. My wife’s phone (presence sensor) keeps disappearing, I am assuming it is a Samsung connect issue also.


(Mike) #11

one of the reasons i didnt join the beta was exactly what you mention Rhoffer, i just knew if there were future connection issues and new back end stuff was being developed on the fly issues would occur, the nature of Beta really but not good if you want to keep a smartthing home…wife friendly !


(Jim) #12

I have had the same issues recently and managed to get my Samsung TV back under control in SmartThings and Alexa. I assume it broke after the upgrade of firmware on the TV. Here is what I did to get it working again, if t helps anyone else.

  • In the SmartThings app under My Home remove the TV.
  • In Automation remove Samsung Smart TV (Connect).
  • Go and make a cuppa to allow things to settle down.:sunglasses:
  • In the Marketplace select Televisions -> Samsung Smart TV -> Connect Now.
  • Follow the wizard to add the TV back in.

If you have Alexa integration with Smartthings, once the TV is back go to Marketplace and select Amazon Alexa (UK), select the new TV under switches.
In a browser go to https://alexa.amazon.co.uk and sign in with the same account that controls your alexa.
Select Smart Home -> Devices and Forget the old instance of the TV (It should be marked as offline). You can forget any other instances offline instances of the TV.
At the foot of the screen, run a Discover to find the TV through Smartthings. You could also do the discover part in the Alexa App on your smartphone (Cant find out how to deleted things in there though).

That should be it, my TV is back in Smartthings and I can turn it on and off via Alexa (Would be fun if it allowed volume and channel control in there as well).


(Mike) #13

nuttersrest, when did your issues start ?? the way you have added sounds like the standard way of adding a Samy Tv which used to work before the new firmware
If your issues were about a week ago and with Alexa failing to control the Tv on/off it was prolly because of an issue that was resolved by ST not long after, just removing and re adding for alot of us fails to work and it does seem to point at the Tv firmware being screwed up
I also notice on my Samsung Tv settings, in the section for allow devices always, once, never on the right hand side it now says direct connection not available, not sure if it has always said that tbh

The link to the Echo web page was very helpfull ty for that, i had no idea that page existed, its like the old version of echo which used to have the remove devices option which has lately been missing leaving users with a right mess, good call on that and a big help so thank you


(Jim) #14

I think it was Thursday or Friday, not 100% sure to be honest. Smarrthings was showing as off whilst the TV was on and could not be controlled. Alexa understandably at that point could not control it. Had a look at the Smartthings Forum yestrday and came across this thread so decided to remove and re add which brought it back up.

The TV is setup to auto upgrade so should be on the latest version, just to be sure I ran a manually check and it returned that no update was available. Current Firmware on the TV is repported as 1201.


(Mike) #15

Sounds right Jim for the St alexa issue and you aren’t affected by the latest update
DO NOT APPLY 1203.6 via USB which is available, it Will break everything tv, St, echo related and leave you with a degraded picture just to add insult to injury. I would also switch off auto update incase 1203.6 accidentally gets pushed to users
Wish I could go back but to your fw version but evidently it’s not possible


(Jim) #16

Thanks MJ

I have now turned off Auto Updates, thanks for the warning. To be honest I am not sure the auto update feature works, everytime I have done a firmware update it was via USB, thankfully I did not do that this time.

Have you raised it with Samsung TV support?
Happy to help prove to them that it is the TV firmware update that has borked things, unless Smartthings are going to tweak things on the DTH side?


(terence peace) #17

I had the 1203.6 firmware update on my KS9500 UK version.
The SmartThings app will turn it on, but won’t turn it off. Not even Alexa will turn it off.

But luckily for me I have a Homey Hub and that still turns the TV on\off :wink:


(Jim) #18

Hi @Tyler as both SmartThings and the TV are produced by Samsung, are you guys working on fixing this in the background?

From the above posts, it would suggest that the 1203.6 firmware has broken the integrations between SmartThings and TV as such I have not updates it and my KS8000 TV is still on the 1201 firmware. This does mean there is the potential that I wont be applying any security fixes in new firmware releases, not a good position to be in.

If you need any testing done then happy to help out.


(Mike) #19

I sent a mail off to the Smartthings peeps and as expected they can’t help much, Samsung is made of many many separate companies all under the Samsung umbrella, no one knows anyone in different companies so St are waiting for the TV arm to do something. What surprises me is 1203.6 is still available, would have thought by now it would have been pulled
Not only does the update break St connections it introduces judder to panning images like a inverse telecine it’s horrible


(terence peace) #20

“I just received this from communication with people at Samsung support via their Twitter account:
Hello Michael, Product Support recommends use of Samsung Connect instead as the Smart Things app is no longer supported and is being removed from all TV’s. You should be able to do most of the same things with Samsung Connect. ^Gill”

I hope it’s not true or the fan better start turning now ready for it.