Smartthings not working on new Samsung TV "no registered scenes and devices"

I have a SmartThings Ver 3 hub with many devices and scenes. Works for about2 years with no issues. It was time to buy a new TV with all the holiday sales going on. Looked at a lot of different models and really wanted something with an Android interface so I could load all the Apps I wanted. My son also has SmartThings and he purchased a Samsung Qled and when he hooked it up it just worked with his ver 3 hub with no issues. I ended up going with the Samsung TV as well just for the SmartThings integration. I purchased a QN65Q60TAFXZA on sale at Best Buy and when I hooked it up, the TV added into SmartThings just fine and I can control the TV from the SmartThings App on my phone. The problem is that when you open the SmartThings Ap on the TV it just comes up with a screen that says
“no registered scenes and devices”. Worked on this issue for over a day and can not get it to work. I spent several hours on the phone with Samsung support as they transferred me from department to department trying to resolve the issue. I see a few older posts on this with no resolution. Was anyone able to resolve this on their TV or should I just return it to Best Buy and get the Vizio or Sony model that I originally wanted. I only went with the Samsung TV because of the integration with my SmartThings hub!! If Samsung TV’s no longer work with SmartThings then Samsung should not be advertising that they do!!

4 Likes

Same thing here. However, when I scroll over to the ST app (on home screen of tv), but before pressing the button on the remote to select the app, all of my devices are listed in a row, above the ST app thumbnail, along with the status of each. I can cursor-up (on remote) from there and then scoll sideways to each device. I can then click on any of them, get a swirly symbol - like its trying to affect the change (i.e. on or off), but nothing happens after that. No on or off.
Like you, if I click on the thumbnail for the ST app instead, I get the “no devices” message. I have the q90t tv.

My Son has the Q90T and it works fine. He gets alerts from his sensors and can also see his Ring cameras Etc… Samsung support was not able to tell me which TV models that it works on. They would only say that they know about the issue but have no ETA of when it would be fixed. Its deceptive marketing for them to be advertising that their TV’s work with SmartThings when they don’t. I returned the TV to BestBuy and had to argue with the store manager that it was advertised that way and didn’t really work before they agreed to give me a full refund. I ended up buying a Sony TV with Android. I have always had brand loyalty with Samsung with their, appliances, Tv’s, Note cell phones but now I have changed my mind and will look elsewhere for my electronics. Why they cant or wont get two Samsung branded devices to work together is just amazing. lol

1 Like

I bought a 2020 TU8000 which was supposed to have the Smartthings preinstalled…it wasn’t nor is it in the app store. It is even in the TV documentation and in the e-manual and Samsung customer service told me that indeed, it should have been there even had a couple of Smartthings personnel look into it with no resolve. I’ve got a feeling they’re about to remove Smartthings from TVs as there have been a few people on here say it was on their TV when they bought it and disappeared after a firmware update…totally unacceptable. Needless to say, I have purchased my last Samsung product, phones included.

Same issue with a brand new Q90T.

I advised samsung tv for a disabled friend who struggles to use a remote control and after 4 or 5 hours I cannot get the TVs to be controlled by Alexa nor download the App onto 3 android devices. All I managed to do was load the Smart Things Skill into Alexa, but not got much further.

I would love to give up on Samsung, but I have ÂŁ1500 invested in their kit.

If the TV is a 2020 model and a TU8000 or better Alexa is built in to the TV and doesn’t have to go through Smartthings. It is accessible through settings> general> voice

Did you ever find a solution? I have experienced the same things. I have had devices show up in the ribbon but none in the app. I spent several days working with support until they escalated to their dev team who said they were aware and it would be addressed in the next firmware update. Well I just received the latest update today and it didn’t change the behavior :frowning: It really urks me since I have my whole house running on smartthings and I can’t get this darn tv to work. My refrigerator is 20 feet away and it is running smartthings fine.

I ended up taking the TV back to Bestbuy and getting a Vizio. Samsung replied that they had no time estimate on when this would be fixed. I’m surprised they told you the next firmware release.

1 Like

I wish I wouldn’t have bought mine direct from Samsung only because of the little employee discount they offer. I would’ve definitely swapped it with LG OLED if it was from Costco. Smartthings was the only selling point for me, and yet it doesn’t work. SMH

1 Like

+1 to that as the comparable LG had a far superior picture

That’s exactly why I originally purchased the Samsung, I wanted it to work with SmartThings. Samsung told me if I returned it for another Samsung TV that it probably wouldn’t work on that model either. My son has a Q90 that he purchased in the summer of 2020 and it works perfectly on it. Someone else purchased the same exact model and it doesn’t work. Samsung told me that the problem is with the SmartThings firmware and not the firmware on the TV. m not sure if I believe that or not.

2 Likes

No, I did not. I’ll wait for Samsung to fix, or not. I primarily bought the tv for the tv and I love it (Q90t). The ST control was icing on the cake, but the cake itself is pretty darn good. :slight_smile:

… and, oddly enough, I can control the tv through the ST app, so at least part of the connection is there.

Rest assured, this is directly on the heads of Samsung TV division, not Smartthings. There IS NO seperate firmware for the TV and Smartthings…its all baked into one.

Just to share some of the steps I have tried. I have been troubleshooting this issue since I purchased my TV in October last year. I tried all the different ideas that they suggested as well as some of my own ideas:

  • Disconnected power from tv for 20 minutes
  • Factory reset TV
  • Removed and reconnected samsung account
  • Put all smartthings devices on their own dedicated WIFI/Ethernet network.
  • Removed the TV from smartthings and registered again.
  • Uninstalled and reinstalled smartthings app on TV.
  • Reset the Smarthings app on the TV
  • Confirmed that the location I wanted to show up on the TV was set to default.

After completing these steps with Samsung support, I was told that the dev team is aware of the issue and it will be addressed in the next firmware update.

  • Recently received new firmware and updated about a week ago.
  • Repeated all the steps above.
  • Still no luck.

I have witnessed the ghosting of devices above the menu ribbon, and I have even had my devices show up under the smartthings app on the tv for a minute and then revert back to the “No Registered scenes and devices”. I can control my TV through the smartthings app and can share my phone screen via smartview to the TV. I cannot see any of my devices nor can I see the TV as an available smartview “source” from other smartview enabled devices, i.e. refrigerator. Smartthings works fine and devices show up on my refrigerator which is on the same network and about 20 feet away from the tv .

My opinion is that the issue is account related. Maybe something is either cached, authentication issues or something else that is keeping the smarthings app from reliably connecting to the cloud account. It just doesn’t make sense that it shows up randomly and then disappears.

Hi, I think i found something interesting that could help someone.
I bought 43q65t QLED TV few days ago. I logged in TV with my Samsung account and Smartthings app on TV showed my 5 scenes and all devices, and everything was working fine until yesterday when i noticed message no registered scenes and devices. Smartthings was working fine on all my devices (Garmin watch, Android auto, phones, tablets, Alexa… ) and my new TV was still controllable from all of them, but I lost possibility to control deviced and scenes from Smartthings app on TV. While i was investigating what happened i’ve noticed that voice commands (“run scene”) were still working. Bixby offered me my scenes, although they were not available in Smartthings app, and I could choose which one to run, all except the last one that I made yesterday. Then i tried to erease that last scene that i made yesterday, that was missing in voice activation, and after that all scenes and devices came back. I was playing a little after that with making and erasing scenes in Smartthings app on mobile phone and noticed that aftet every new scene that i make i lose all my Scenes and devices from Smartthings app on TV, even when i was making again old scene after deleting it, so I ended up eith just 3 scenes and without possibility of making new one without losing everything from Smartthings app on TV.

Hi, the same problem here.
If I create a scene all my devices disappear from the TV’s Smartthings application (Q95T), when I delete the scene they come back.

hi, yesterday there was an update of the app on Android and it was resolved, at this moment I can create scenes without the devices disappearing from the app on tv.

Well the problem is even without doing any of that none of my devices are showing up on TV