Please help! Can't connect Samsung TV ks8000 to SmartThings hub


(Junior Brown) #1

Hello, I purchased the Smartthings hub and I am trying to connect it to my Samsung TV. I followed the instructions in the SmartThings app, it found the tv but when it gets to the part where I click allow on my TV it says I have approved the request on the TV but the app will not link and it keeps prompting the Allow prompt on my tv over and over.

Am I doing something wrong?


Problem Adding Samsung Smart TV
Unable to connect to KS8000
(Ricci Hoffer) #2

Is has to be a US market model. Make sure the tv is on the network and signed in to samsung. It must be the same network as the hub. Try unpluging the TV for a little bit and then replug it in and try again. This seems to help some to get it to connect up. The prompt will be in the black notification bar at the top of the TV when it connects.


(Stephan H.) #3

Unfortunately the first thing to do when troubleshooting any new samsung tv’s connectivity is to inplug it from the wall for 30 seconds and retry. Solves 98.5% of issues with these very “special” devices. I’ve had to do this at least 5 times since christmas.

PS. And yes, 98.5% is a statistical fact :wink:


(Junior Brown) #4

Ok, thanks. I never signed into samsung from the tv. Should I use the same smartthings email? Or create a new samsung account?


(fightingmajor) #5

There are at least 5 current topics on this. Search is your friend.


(Junior Brown) #6

I did and found nothing. If you are not going to help. Don’t post.


(fightingmajor) #7

Quick links from using the search function.


(Junior Brown) #8

None of these were helpful or relate to my issue. Searching was the first thing I did before asking.


(Junior Brown) #9

The helpful answers I did receive prior to yours I will try.


(fightingmajor) #10

You obviously did not bother reading the entire threads as you would not have had time in the 3 minutes you responded after I posted them. Good luck.


(Ricci Hoffer) #11

The email adress I used for both the Samsung Account and ST was the same. I am not sure if it is required though.


(Junior Brown) #12

Thank you rhoffer, I will try that.


(Junior Brown) #13

Uh, I read each of those "threads"BEFORE I raised the original question and the answer to MY problem is not there. But you are too busy being a snarky poster instead of actually assisting.


(Stephan H.) #14

I don’t think it matters what account you TV or smartthings is signed in with, as long as they are on the same network it should be detected.


(Jake) #15

I’m guessing signing into Samsung on the TV will be necessary as many of the network functions seem to be dependent on being logged in.

Let us know if that does the trick.

The guide doesn’t list that as being required, but if it is, would be nice if they add a note.


#16

Did you ever find a solution?

My phone acts like it is going to connect, the allow message pops up on my TV, but the cycle just keeps continuing.

And as suggested, I read the linked posts but did not see anyone with this problem of it being stuck in an allow/deny loop.

I


(Daniel Grant) #17

Same problem for me. Anyone figure outhat how to solve it.


(Junior Brown) #18

I did a chat with Samsung and gave them my samsung login email and they fixed it on their end


#19

This is what you have to do.

Log into the IDE. Go to My Locations>List SmartApps> (then while the TV is showing the 'Allow/Deny message on the screen) You will see the Samsung TV Connect SmartApp listed in the IDE, hit ‘Update’ while the message is on the TV. The app will still seem stuck with the same message. Back out to “Things” list on your phone, and you should see the TV listed there now.


(Guy) #20

I have the Samsung KS8000 2016 TV and the Smartthings Hub v2. I just got word from support today on how to set it up so you can at least turn off/on the TV from the Smartthings app (turns out you can adjust volume, mute, change picture mode, audio mode as well). You can now add the TV as a ‘thing’.

See this post for how to setup: https://support.smartthings.com/hc/en-us/articles/210766566

And proof that I have it working: