Please help! Can't connect Samsung TV ks8000 to SmartThings hub

So the question is does Samsung Connect only support Mu?

I currently have my KS TV linked to Samsung Connect. It has been for a while now…since about January. Not sure if anything has changed that would affect that now.

I also think I did many months ago but since had cleaned up and removed that. Now I got nothing. Can’t win around here with TVs apparently

I bought a KS8000 about 1 month ago. It showed up in the Smartthings app in its own location (TV). Then the firmware updated and it was no longer around although the TV location was was still there. I checked that location today and the TV was back as a device. I can turn it off, (can’t turn it on for some reason), change the volume and I see notifications for the last 7 days in the app. My TV firmware version is 1207.

So, how can I get the TV connected to my Home hub so I can include it in my routines? Do I need to add my hub to the TV location? When I try to add the TV to the hub, it can’t find it.

i’ve been using harmony for that purpose, which doesn’t answer your questions i realize. But we use an audio receiver and cable box etc so turning all of those things on is pertinent.

Integration is broke at the present time if you have anything over 1201 firmware on the tv. Tyler, from ST, chimed in on another thread with some additional information other than “they are working on it”

See the last couple post in this thread.

So my TV now appears in smartthings and I can control it in smart things but it does not show in Alexa even after I install the smart things skill etc it is not a device. I tried using scenes in smart things to then do stuff in Alexa but the TV does not turn off the scene doesn’t seem to activate when commanded to on Alexa.

I also now can’t use the add device manually button in the app it just opens and closes then goes back to the main page.

I also tried IFTT but the TV device that shows on smartthings on the app does not show as a switchable item on the iftt on and off after you connect it to smartthings.

Overall not really working still!

Hi @Johnny_Hilderbrands. Do you mind (re)sharing TV model, TV firmware version, Smartthings Hub firmware version?

you cannot turn ON ks tv’s but you can turn them OFF, even with alexa. you have to add the device to samsung connect, and then log into smartthings as your samsung account. once the hub/device are on your samsung account instead of your legacy smartthings account, you can control it.

the device stops working when you turn it off, so obviously this method uses bluetooth or something that powers off with the tv. i found another device controller that uses LAN called samsungctl on github and it does work, but i cannot find anyone that is available to help me with the project. that honestly is the best method for the tv’s until samsung/st fixes ocf.

This is wrong. Before the last update I could
1-Turn on\off Volume up\down
2-Get notification’s on my KS TV using WebCore(a popup notice telling me a sensor has been triggered)
Now it’s broken. Even people in the beta account merge have this problem.

1 Like

what makes you think this is wrong? i’m talking about SINCE THE UPDATE. of course its broken, this whole thread is about that, i’m saying what you CAN DO NOW.

I see.
Agree we can’t do anything now and #SmartThings are saying nothing.

Yep, another month goes by with no fix for this. It’s pathetic! No one from smartthings or samsung wants to do anything about it because why bother? We are stuck. Now I know how those people feel who bought a samsung TV with the promise of a smartthings extend adaptor for their TV that never even came out. This is likely the last samsung product I buy and I’ll tell all who will listen to avoid their stuff as well do to poor support and false promises.

2 Likes

yes its terrible, i spent thousands on a tv and all so i could manage it from ST. hell i can load a python script and communicate with it in a few minutes, but no, not ST.

2 Likes

I did ask nick stevens

“Are you going to fix the Samsung TV problem of not being seen by the Hub anytime soon?”

“Unfortunately it’s not a problem I can fix :slightly_frowning_face: The problems are not related to Hub v2 firmware, so today’s update won’t have any effect on Samsung TV issues. I did confirm that there is a team aware of the issue.”

I wonder who this team is.
But we do know that samsung drop things very often…so!

1 Like

Samsung did the firmware update to the TV that broke the integration but they obviously don’t care or they would have rolled back the update or fixed the issue in the 4 subsequent firmware updates that have been uploaded to our tvs. Smartthings probably doesn’t have the power or authority to address this issue which is why they aren’t saying anything about it.

1 Like

I’ve talked to Samsung UK and they say it’s not possible to down grade.
We all know this is a lie.

1 Like

How about you people that have this problem and post on the Samsung forum?

The more people who ask might make Samsung site up and listen.

Has anyone managed to get a warranty extension or partial refund for their TV since this is an advertised feature that doesn’t work.

No but I did get a free SmartThings hub.