Routines not triggering and/or are partially executing


#1

my I’m Back! routine used to work, but the last week or so it just stopped working even though nothing was changed.

my goodbye routine works fine… any idea what i can do to fix this? i have rebooted the hub, restarted my phone/app, deleted the routine and re-added it… it uses my phone as a presence sensor to trigger when i get home but never works. the other smart lighting stuff i have to turn on when i get home works fine though. please help, so frustrating!


Does Anyone Still Use SmartThings?
Routine Director forcing me to put in a phone number
Away when everyone leaves didn't work this morning
IDE Issues - Feb 22, 2018
#2

My “Good evening” routine did not trigger today and other routines have been hit or miss this past week. I just have to grin and bear it and chalk it up to the instability of the SmartThings environment…although maybe my ISP and Internet connection could’ve been spotty today.


#3

i mean, it says “Jay Has Arrived” whenever i get home, so it knows i’m there … just the I’m Back! routine doesn’t trigger…


(Convinced ST will never be unbroken…) #4

Same here…

And I just deleted and recreated them all a couple of days ago (support had no clue and suggested this to see IF it would address the issue).


(Stephen) #5

Same here. I keep opening the door and getting greeted by sirens.


(Bob) #6

For those with Routines failing, do those Routines also contain Mode changes? If so, I believe that is the problem. I’ve had this issue for the last month, and an open Support ticket almost as long.

The temporary, though cumbersome, workaround is to remove all mode changes/restrictions from Routines and Smartapps, delete the Mode (ensuring first that you’re not in the failing mode), and then putting everything back. I’ve had this restore service for anywhere from one occurrence to a full 3 days. A more permanent “solution” (though still a workaround) is to just forget about Routines, and migrate everything over to the Rule Machine and Trigger Happy smartapps. Unfortunately, neither has the ability at this time to set or change Smart Home Monitor status, so depending on your Routine configuration, you may not be able to move everything over.

Hope this info helps someone, and by all means, if you have a similar issue, report it to ‘support at smartthings.com’ and reference my open ticket (# 54180). The squeaky wheel gets the grease; If enough people complain, maybe they’ll get around to fixing it.


(Tim Slagle) #7

Definitely reach out to support so they can look at your logs and digest the info to give to engineering. We are in the info collecting stage. As we can find one cause.

I can’t reproduce this so we need your help to get the info we need for a resolution.


#8

yes, my I’m Back! routine changes the mode to home. i’m not going to delete the mode and then re-add it, that is fucking ridiculous. they need to fix this serious issue on their end. i tried rule machine and it’s really buggy and doesn’t trigger sometimes.

i emailed customer support but they take over a week to ever get back to me if they even do reply.


(Brianh) #9

I noticed the same issue. I can’t go from away to home. I’m just not going to use away until a fix is found. I’m not interested in work aroundss.


#10

My “Good Night” routine partially failed tonight. It turned off a few lights but, did nothing to my locks and thermostat and failed to change modes.


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #13

I have experienced similar issues lately as well. Opening a tocket with support. Meanwhile I am using Rule Machine which works lot better.


(Andy Rawson) #14

I have had that happen a couple of times on my Good Night routine which runs at a scheduled time. In the IDE I went to My Locations then to the Installed SmartApps for my location and found the “At a certain time” app under Hello Home and Good Night. In that listing it shows the Job History and most of the entries had an execution time of 3000 - 30,000 Msec. The night that failed had an execution time of 43,104 which means the routine hit the 40 second max execution time for a SmartApp and was killed. You may check there and see if you have the same thing happening.


(Tim Slagle) #15

Do any of your routines that are failing have Cloud/Lan connected devices in them?

Also renamed this thread so we can have one place for these conversations.


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #16

No. My routines only have zwave switches and zwave thermostats. Some have virtual switches ( not sure how those are treated)


(Tim Slagle) #17

Ok,

Are your execution times going above 40 seconds?


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #18

No, they are not (20 chars)


#19

All Z-Wave and Zigbee devices for me.


(Bruce) #20

Anyone having these failures and NOT using Smart Home Monitor in their routines?


(Herbert Carroll) #21

I’m having this problem too. Routines such as goodnight and good morning which execute at a set time do not fully execute. Good morning for instance still leaves me in night mode at times or doesn’t do a thing other than declare its performing in notifications.

I’m not using smart home monitor in my routines.

I discovered just a few minutes ago my goodnight scene last night turned off some lights but didn’t change one of my thermostats. Incidentally my other thermostat was set, but is configured via a smart app I wrote and triggered through a virtual switch which did execute by the routine. I do this because I want to set different temperatures for different thermostats.

I tried dealing with support but I get irritated by the long delay in response combined with feeling as if my emails aren’t fully read judging from the replies I get.


#22

I went to check the above, but as usual, the absolute disaster of UK authentication prevented me from doing so:

My timed routines (which do NOT change mode,just flip a few switches) seem to work for a few days then stop. If I change the time I want them to run, re save them they’ll work again. Hitting the routine manually works fine.