Routines not working consistantly

I have about 20 items connected to my Smart Hub including Zwave and Zigbee devices. It generally works well. I have created a routine that turns all lights on and all lights off. Sporatically, this routine says it executed but the action does not occurr. I am able to turn off each light individually though. Then some time later it all starts working again. Anybody else seeing this. Not sure why it comes back. Any thoughts?

Par for the course. They’ve been flaky since the get go. You might try deleting them all and recreating them if you the time.

1 Like

This should be the #1 issue ST should be working on…

can i ask if the recent platform update has improved mode switching for you? it has for me, although the larger routines which turn on & off lights are failing at more regular intervals missing a device out etc… but i have noticed a distinct improvement in the important stuff like mode switching from away and especially SHM switching is working a lot better…touch wood

1 Like

My routines seem to work but routine director on the other hand has only worked once and I have no idea why. It says I’m home and it’s sunset but it doesn’t turn on my evening routine.

Oh and my brand-new D-Link WebCam smart things can’t find it even though it’s a supported device where to go Smartthings! Sigh…

I’m also having problems with routines which are necessary triggers for all my mode changes and smartapps. However, I have narrowed the issue down to time-based routines. Half the time, the notifications area will state that the routine ran but with no detail in the notification. If the notification runs successfully the notification will outline the charges like mode, thermostat temperature, lights on/off etc. When the routine doesn’t run successfully, the notification will just state that the routine ran and that’s it, no detail. My routines that are not time based seem to run just fine, for instance “winding down” seems to work consistently. But my “Good Morning” routine at 5:00am fails as does my “Goodnight” routine at 11:00pm fire consistently. I’ve tried deleting and rebuilding the rules with no luck and support has become incommunicado. Smartapps seem to be running fine; presence-based routine triggers seem to be fine; just trying to figure out how to fix this.

I have been having an issue last couple weeks where two of my routines fired but did not take action. It’s exactly as stated above where the routine reports it ran but no details show up about what it did. These are not time trigger. One failure was triggered by presence and the other with a virtual switch.

How can troubleshoot a routine? They work 95% of time so it doesn’t make any sense.

Would I have more control by making smart apps to replace the routines?

Anyone else having this issue?

Yes mine too! My good morning routine is running but about 50% of the devices in that routine aren’t running their commands, most annoyingly is the thermostats not changing.

Same here. Have had a ticket open for about a month now. I was having a lot of zigbee misfires but those have improved on their own and don’t happen as frequently. Z-Wave is completely unreliable. My system is having severe issues with z-wave locks and thermostats as of late. I’ve rebuilt the network a dozen times without luck.
It’s not just routines, any SmartApp using those devices is having issues. Very frustrating.

It might be related to the following known issue, which is a database problem where commands are timing out. It’s only affecting some people some of the time, and engineering is aware of it, but it could be causing the problems you’re seeing. You should definitely report it to support if you haven’t already.

That sounds like exactly what I’m experiencing. I noticed my two CT100 thermostats were not updating and I couldn’t control them anymore. And my routines that turn on/off my exterior lights are no longer working. Very frustrating as I just migrated from openHab that had been running for around 2 years. Will figure out how to open support ticket.

My “Goodbye!” and “I’m back!” routines haven’t fired properly for the past two days. SHM didn’t arm when the last presence sensor departed yesterday morning so I armed it manually. Of course, it also didn’t disarm properly when my wife got home, so she was greeted by an alarm. The presence sensor was properly detected leaving and returning, it just didn’t fire the routine.

“Goodbye!” failed to run again this morning, so I’m leaving SHM disabled so I don’t get grounded by my wife. :slight_smile:

Is there an update to this? I had numerous routine failures this weekend. Things are getting very bad here. After walking into the house, despite some of the I’m Back routine running, we were greeted by lights and sirens. This is starting to feel like the Lowe’s Iris days and have reached the point where I am once again being asked why we even have to have any automation or security.

Seriously, why can’t problems here ever be fixed quickly and permanently?


@Plantwebguy and others seeing this thread,
Please check out the thread below and see if your symptoms match. We’ve been having trouble with switches, particularly and any action that requires cloud processing (local processing still works, which makes it look sporadic). You can do a search in the forums to find out how to tell if your action requires the could or not, but anything between your Phone App and the Hub is cloud based.

ST denies a widespread outage and says its just a few of us. In our thread, we’re now up to about 15 users who have non-responsive hubs and have been cold (no Thermostats!!!) and dead since early December.

Please take a look at this thread and add yourself to the TWO tickets that are tracking these problems if your symptoms match. Thanks!


This is becoming highly unacceptable. Routines almost never fully execute. It’s tiring and more importantly it is leaving my home unprotected because of random failures to make sure doors lock.

A simple Goodbye routine to shut off about a half dozen lights, lock 4 doors, and change mode failed with near perfect consistency. I’m back fails on a regular basis too, often not disarming SHM causing the alarm to trigger.

Goodnight fails to perform its actions 100% of the time causing me to spend 5 minutes every night scrolling through the app locking doors and turning lights off that failed to switch. Manual device control is 100% reliable. This all started with the December update.

Support either doesn’t care, is severely under-staffed, or is unable to identify the issue. What I find personally insulting is that there are a couple ST staffers here telling how committed ST is, how great the world is, and that we should be excited about the future.

It’s hard to be excited about the future when the present sucks. I truly regret my decision to switch to ST and the thousands I spent to do so.

1 Like

You know, local processing would fix literally all the issues here…just saying.

1 Like

I moved a lot of my routines to CORE and have had much better results.

Ill have to look into that. I disabled my security for a bit so the rest of my routines I can wait for.

I have a similar issue RN. Routines do run, almost 100% of the time, and do complete what they are supposed to do (Switch off lights, check doors, turn off alarms… stuff like that) BUT, SmartApps cannot interact with them in any way, either by a Handler listening for a routineExecuted (to location) or running one with the execute(“Routine”) command. The fact is, my house runs completely via those SmartApps i mentioned (I have a really complex system) and all of the automated functions do not work. I am forced to either turn on the routine manually (and pray to whatever your divinity is) that it works, or do things manually.

I refuse to connect door locks or garage door- the system is way too rickety for mission critical. It mainly remains as a fun hobby for now- lights generally work, but go through periods of either not turning on with a trigger, or not turning off with a time-out that is part of the routine (such as “turn off in 5 minutes”). It’s very selective- works with one light reliably while other lights routinely don’t’ work for large swaths of time. Very weird- seems like devices I installed first work OK, but later additions are flakier.

For mission critical applications- it needs 99.999% reliability or better- the hallowed “5 nines”. About the time I think things are working better, there’s another period of glitchiness.