Anyone having issues with routines not running?

Hey Everyone,

Just curious if anyone else is having issues with the smarthings routines not working. Recently I have been noticing that my goodbye and I’m back routines are not working. The smartthings app shows that my iPhone set up as a proximity sensor is registering when I leave and arrive although it is not triggering the routines to turn on or off lights in the house. Not sure if there is a fix for this or if a recent update or outage caused this issue. If anyone has suggestions or insight on this issue it would be greatly appreciated.



yup my morning routine did not run at sunrise today

My morning routine did not run either.

Both my sunset triggered Morning Routine and Smart Water Heater SmartApp did not trigger this morning.

I usually have to make some change to the routine and then save when this happens. Sometimes I have to delete it and recreate it to get things working again.

Welcome to SmartThings.

Thanks for the suggestion. I tried to alter one the other day with no luck. I will try and delete and recreate it see if that works.

Yup. I had routines and rules not function this morning, outside of the outage window posted by ST.

I noticed it at about 4 am central time… I only use routines to change modes and all of them were dead at that time.

1 Like

I had the same issue this morning with the good morning routine. I got the push notification that good morning ran, but it didn’t and I’m glad I checked. After I ran good morning manually, I heard and saw the switches change. But the mode was still night - so I got some intruder alerts. I flipped through a few routines until mode changed. :sob:

At what time were you routines set to fire? There were some platform issues this morning that could’ve caused this - see:

My routines that turn off a few lights did not run last night (10:30pmCST). I have been noticing that problem for the past few days actually. The morning routine did not run either (6:30amCST).

Overall I would say the platform is not running well at all over the last week or two with lots of things not firing properly.

Something is definitely not functioning correctly. The past couple of days my lighting schedule for aquarium and porch lights are skipping/dropping schedules or the device not receiving the ON/OFF command at all.

HI Vlad,

I do not have a set time for the routines. I have these routines set with an iPhone set as a proximity sensor. But it looks like from the responses that others are having issues with routines set on a specific time.


My sunset to sunrise issues occurred before the 7:30 AM CDT time posted on the status page. .
It started last night @ ~ 6 pm CDT until i left this morning @ ~6 am CDT

5:45am Eastern - it fired. I just didn’t actually do what it was supposed to do. Which is a long standing issue.

My “Home-Daytime” which should fire after I arrive back home didnt fire at 1:15PM today. Instead,“Home-Night” fired turning on my outside lamps and setting the mode to “Night”…

Same issue here. Came home during the daytime and it fired my welcome back nighttime routine for some reason. Bummer since I haven’t had one issue in months.

I am able to run routines through the SmartThings app, but not with SmartTiles or SharpTools. Things work in both third party apps, but routines do nothing.

Several third party SmartApps are having this issue. I’ve submitted a bug report #232741 - it would help get some visibility if others would submit support tickets as well.

Josh Today at 10:29
It looks like the execution of Routines/Phrases is failing for many community SmartApps including SharpTools, SmartTiles, CoRE, Routine Director, etc.

Looking into the logs when the failure occurs, the following error message is shown under the filter for the ROUTINE that was attempted to be executed:

10:09:24 AM: error groovy.lang.MissingMethodException: No signature of method: script1234567890987654321.execute() is applicable for argument types: (null, null, null) values: [null, null, null]
Possible solutions: execute(), autoExecute()

**Routine Director**:
1 Like

I’ve submitted a ticket for it as well. #232755