[Release] Zooz Zen21 switch v2

This is the new version of the switch that has the new parameter to completely disable the LED as well as the capability to work with existing 3-way switches.

Update: 10-14-17 - Fix for event log issue, combined LED parameters into one for UI

4 Likes

Just need to install the ZEN21 switches, LOL.

BTW, github integration works for the ZEN21 v2 DTH, but not for the ZEN22 v2 — I get some sort of error when trying to create and publish. Not very informative:

I’ll have to try and figure that out. Sorry about that. If I knew what was wrong I’d fix it straight away

1 Like

Is anybody else running into issues with the Zen21 DTH?

Issue:

  • smartthings shows state as ‘ON’ when light is actually off. device seems to revert to this state
  • recent activity does not include any commands sent to the device
  • Notifications -> Activity also does not include any commands sent to device

The device does handle all commands (on and off) perfectly. Just the smartthings UI doesn’t reflect what’s going on.

I swtiched to Zwave Relay device handle and the problem is not there. Of course, I loose the config capabilities-- not sure what else.

Someone just asked the same question in another topic. I had the same problem but solved it by using the dth to the zen 23. You lose the led control, but it otherwise works just fine.

I was unaware anyone was having issues - thanks for tagging me in the other thread @fraineal. I’ll look into it. At one point I had some issues with one of the other handlers and completely tore it down and redid it. I never saw a thing wrong with the original code, but the teardown seemed to help. Now that I know people are having issues with this one, I’ll see what I can figure out.

2 Likes

Updated the DTH and also combined the LED parameters into one so they operate like the GE switches. It just kinda made more sense once I started looking at it. Please give it a try and let me know if you see any issues.

@aakhter, @elf and @fraineal - please check it out

1 Like

I just swapped the light out to the new DTH. So far so good. It’s reporting accurately, and logging correctly. Will monitor and update if anything changes. Thanks, @doncaruana!

@doncaruana, My Zooz Zen21 v2 switch no longer takes commands (On/Off or LED State and Invert Sw state) with your device handler (via SmartThings Classic Android App). It reads On/Off status just fine. After quite a bit of troubleshooting and removing/excluding the switch and re-adding several times (also tried removing power from switch and doing a full reset on it)…it only wants to work properly now if its device handler is the generic “Z-Wave Relay”. I’m wondering if something Samsung has updated recently broke your device handler (but would think others would be complaining as well). I had been running the switch with your D.H. for a year with no issues until just recently…now I have to use the “Z-Wave Relay” D.H. to operate the switch properly.

Anyone having any issues with this D.H. right now?

Don’s Device Handler Version: 2017-10-14

Hub firmware: 000.022.00013. SmartThings Classic Android App: 2.16.1(Build 219306).

Here’s the IDE details on the Zooz Zen21 v2 switch:

Data:
Product Type: B111
applicationVersion: 20
Manufacturer: Zooz
zWaveLibraryType: 6
Product Code: 1E1C
applicationSubVersion: 15
zWaveProtocolSubVersion: 5
zWaveProtocolVersion: 4
MSR: 027A-B111-1E1C
Manufacturer ID: 027A

RAW Description: zw:L type:1001 mfr:027A prod:B111 model:1E1C ver:20.15 zwv:4.05 lib:06 cc:5E,86,72,5A,73,85,59,25,27,20,70 role:05 ff:9D00 ui:9D00

I’ve got a bunch of irons in the fire…give me a few days and I’ll see if I can duplicate or figure out what’s going on.

1 Like

@SatcomEng - Did you ever get this figured it out? I tested with mine and had no issues. I even excluded and re-included without any problems. Maybe it was one of those infamous smartthings platform temporary glitches?

@doncaruana, No I have not. I can get it to work just fine with the generic Z-Wave Switch or the Z-Wave Relay DTH’s but not the Zooz Zen21 v2 DTH. I’ve tried removing and repairing, but no luck. Always works fine on the generic ones. Next step I guess is to kill the AC breaker and see if that helps any.

I added in the mmnm and vid to this so it will work with the new SmartThings Connect app. All it does for now is allow you to see and turn it on/off in new SmartThings Connect app. Device settings are unavailable until they finish baking this stuff and actually publish something.

1 Like

Hi has anyone tested this DTH with the ZEN26 (aka v3) switches?

@doncaruana is working on new dedicated handlers for ZEN26 and ZEN27 so we should see them ready in the next few days. They have a different fingerprint than ZEN21 and ZEN22 so it’s best to use the new handlers here.

1 Like

@aniceberg - New handler here for the Zen26 here…

2 Likes

Today after years of being installed my zen 21 switch on a three way circuit won’t allow me to turn the lights off from either switch. What’s wrong how do I fix it

If the switch doesn’t work manually, we recommend cutting power to the breaker to power cycle the device and if that doesn’t help, please get in touch with the Zooz support with your order number for more in-depth troubleshooting: http://www.support.getzooz.com/new

I know this is a year later, but I recently had the same issue after resetting my hub to factory default. The hub wasn’t using the custom handler to identify the switch during the pairing process. I looked at the code and it appears that the Manufacturer ID 027A and Product Type B111 are different from doncaruana code of 015D and 0111. I changed those values and the hub picked it up right away and now it works fine. Here is how mine looks. Hope it helps!

//zw:L type:1001 mfr:027A prod:B111 model:1E1C ver:20.15 zwv:4.05 lib:06 cc:5E,86,72,5A,73,85,59,25,27,20,70 role:05 ff:9D00 ui:9D00

fingerprint mfr:"027A", prod:"B111", model:"1E1C", deviceJoinName: "Zooz Zen21 Switch v2"
fingerprint deviceId:"0x1001", inClusters: "0x5E,0x59,0x85,0x70,0x5A,0x72,0x73,0x27,0x25,0x86,0x20"
fingerprint cc: "0x5E,0x59,0x85,0x70,0x5A,0x72,0x73,0x27,0x25,0x86,0x20", mfr:"027A", prod:"B111", model:"1E1C", deviceJoinName: "Zooz Zen21 Switch v2"
}

That’s because you’re using the wrong version of the handler. You have switch version 3 and you were using handler version 2. The id and type are correct in the version 3 handler. The version 3 release is here: Zooz Zen21 Switch v3

There are separate versions of the handlers because the switches have very different functions available to them by hardware version and, unfortunately, SmartThings doesn’t allow for dynamic handling of that sort of situation. I’d love to be able to have one handler for any version, but parameter handling is set in stone by the platform, hence the different versions.

Don

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.