[Release] Zooz Zen27 Dimmer v2.x

So, I just realized I never actually published this handler! Sorry about that everyone! This one has a bunch of scene control and some other new features as well. I tried to document everything in the readme as well.

Update 7/11/2019: Apparently SmartThings doesn’t honor any defaultValue setting in preferences, so I had to make an update to the handler for local control. This only affects the initial settings for the device because once you explicitly run through the settings, it would correct itself.


Thank you. Just got 2 of them, not installed yet.
Would this handler also work for V1.x?

It won’t work with v1 - too many differences and too little control over things in the handler (I’d love to be able to make a handler that would span firmware/hardware changes!!). But the v1 handler is here:

I’ve had it for a while, thank you. I also requested the updated firmware (2.03 currently) so I’ll update my dimmers when I get it. I just didn’t want to have multiple versions.

I’m using this Device Handler for my two Zooz ZEN27 v2 dimmers and it doesn’t seem to control the LED as expected. I have set “3-LED is always on” and the LED is only on when the switch is off. Any ideas? Thanks

I would check to make sure that you do have a V2 dimmer. If you do, reinstall the DTH. If not, either use the V1 DTH or upgrade your dimmer firmware to V2.
Just checked mine and they work properly.

Pretty sure it’s v2. I’m using it for a 3-way without a slave switch. Device Type shows v2 in My Devices. How do you suggest to reinstall, remove the DTH and create a new one?

What line in the code do I change the LED setting? I think I was changing it in the wrong place perhaps.

The code should work fine for the LED. I’m testing with one right now and the always on setting is working. You should change it in the device preferences in the app, not in code.

Did you try changing the handler before or after the LED wasn’t working as you expected?

The LED works currently at the default setting when the light is off. Where do I make the change in the code to change it to always on? Thanks!

You don’t change the code to make it always on. You go into the preferences in the app.

OK - are you using the new app or the classic app? If you are using classic, use the gear in the upper right on the device page and you will see a list of all the preferences. You can set the LED to always on there.

If you are using the new app, it doesn’t support advanced device settings. At that point, there’s kind of no point to use this handler as it won’t allow you to do anything with the switch. There isn’t really a “line” you change as the handler doesn’t really control behavior - it just changes device configuration so the switch will follow it’s own internal software. The LED setting will operate like you see until a parameter change is pushed to it - and that gets done via the app preferences.

1 Like

Thanks @doncaruana! That was it, I was WAY overthinking it.


Happens to the best of us! :slight_smile: Glad it’s working!

1 Like

@doncaruana I have updated to latest version of the handler and now I can’t turn it off or on Zen27 V2 via google home. I can dim it to any number like 100% or 0% but on or off is not working
Any idea?
Thanks a bunch

Update: It wasn’t just via google home also via SmartThings App. I had to remove and re add every ZEN27 to get it working correctly again :frowning:

Tagging @thesmartesthouse

@georgino - Do you know if you have firmware version 2 or higher in your switches? The firmware differences can really affect how the handler works, although I’m not quite sure I can resolve what you were seeing . However, I’m wondering if you tried to put the v2 handler on a v1 switch and that’s what caused your issue. When you re-added them, what handler did smartthings pick for them?

FWIW, the Zen27s are fully firmware upgradeable, so you can always upgrade the firmware to the latest if you have a zwave stick.

This is the RAW Data: zw:L type:1101 mfr:027A prod:A000 model:A002 ver:2.01 zwv:5.03 lib:03
Name & Type is: Zooz Zen27 Dimmer v2 - So I am assuming it picked up your handler


  • MSR: 027A-A000-A002
  • Manufacturer: Zooz
  • Manufacturer ID: 027A
  • Product Code: A002
  • Product Type: A000
  • applicationSubVersion: 1
  • applicationVersion: 2
  • networkSecurityLevel: ZWAVE_S2_FAILED
  • zWaveLibraryType: 3
  • zWaveProtocolSubVersion: 3
  • zWaveProtocolVersion: 5

I am not sure if my switch/dimmer has the latest firmware but should be pretty close to latest
I know that probably there is nothing you can do with handler but it is more SmartThing bug?
I never seen this problem before. And what is interesting that after removing it and putting it back every dimmer works perfectly
And even before I could dimm it just ON/OFF via smartthings app (new or classic) did not work

Pain with the removing and reading it is that I had to add every dimmer back to proper room then same with google home and same with ActionTiles - It is a lot of work when you have 20+ dimmers :slight_smile:


1 Like

Yeah, that should have worked ok. There’s a few minor differences but nothing that would have done what you saw. FYI, here’s the change log for that switch: http://www.support.getzooz.com/kb/article/299-zen27-s2-dimmer-change-log/

Might be some odd junk SmartThings is pulling. Really sorry you had to go through that. :frowning:

Thanks for the info and reply. No need to be sorry it is not your fault :slight_smile:
I appreciate you took time to reply. At the beginning I wasn’t sure if there is mismatch with my firmware and handler and how to resolve it. Once I tried to remove the device and re-add and it worked I was relief even if it was bit a work
Cheers and keep up the good work

We haven’t seen anything like that either but will try to replicate the issue in-house to see what might have caused this behavior. SmartThings has been introducing a lot of changes between the 2 apps recently so it may be related to that as well but we’ll check how the dimmers behave in similar situations on other platforms as well just in case.