[OBSOLETE] Zooz Zen27 Dimmer

Finally, here’s the handler for the new Zooz paddle dimmer from @TheSmartestHouse. Too many new features to try and list here! Check it out here: Zooz Z-Wave Plus S2 Dimmer Switch ZEN27 VER. 3.0 (White) with Simple D - The Smartest House

And the source is here…

Updated 11/19/2018 for parameter fixes
Updated 02/16/2019 to add association


Had to update the handler here as SmartThings is suddenly handling my parameter set function differently. Nonetheless - it’s working now, so if you have been using it, please update.

1 Like

I wasn’t paying close enough attention and didn’t notice the LED parameter was changed from the previous generation! Updated this DTH and the one for the Zen26

1 Like

For all interested, updated the handler to add association.

1 Like

I tried creating this new Device Handler today, but I get this error from SmartThings when I click “create”:

Org.hibernate.exception.SQLGrammarException: could not insert: [physicalgraph.device.JoinFingerprint]

I’m not sure how exactly you are creating it but this exact handler is in my IDE. And I just went to my github source and copied and pasted it in to create a new handler and didn’t have any issues.

Is it possible you got a bad copy/paste of the source or there were some smartthings issues at the time?

Thanks. For some reason it worked when I logged into the IDE this morning. One of those transient errors, I guess.

1 Like

Could be a silly question, but I am primarily using the new app. Is there any benefit for me to log into idea to load this handler into IDE?

Until the new app supports advanced device configuration there’s not much point. It

New app is Ultimate Fail. It supports a limited subset of what the old app supports. Even new DTHs’s have more function under the old app, than under the new app. It bites hardcore. Stick with the old for now until the new supports all.

1 Like

I’m using this Device Handler for my two Zooz ZEN27 v2 dimmers and it doesn’t seem to control the LED as expected. I have set “3-LED is always on” and the LED is only on when the switch is off. Any ideas? Thanks

Did you check this?

You can also just tap the upper paddle of the dimmer 6 times quickly to go to the next LED indicator mode, each time you tap the paddle 6 times quickly it will change the LED mode so just keep repeating the sequence until you arrive at “always on”.

Suggestion on how, when using an Iris motion sensor, I can have this switch turn on at 10% with motion? Smart lighting doesn’t allow me to set the dim level on motion. Thanks!

My guess is webcore would be your best bet…