SmartThings Community

[RELEASE] Fibaro RGBW Controller (FGRGBWM-441) - Advanced DTH

fibaro
dth_lighting
lights
communitydevices
rgbw

(codersaur) #1

#Fibaro RGBW Controller (FGRGBWM-441) - Advanced DTH
Version: 0.03 (2016-11-14)
Source: https://github.com/codersaur/SmartThings/tree/master/devices/fibaro-rgbw-controller

Woops! It appears I forgot to create a thread for this, so here it is: An advanced device handler for the Fibaro RGBW Controller, with support for changing all parameters and use of channels as inputs.

Key features in v0.03:

  • Z-Wave parameters can be configured using the SmartThings GUI.
  • Device associations can be configured using the SmartThings GUI.
  • Support for using the channels in a mixture of IN/OUT modes (i.e. support for analog input sensors)!
  • No more glitches (as sending commands and receiving reports is done properly!) :wink:
  • “Energy Meter”, “Power Meter”, and “Polling” capabilities fully implemented.
  • Level attributes and sliders now have a have range of 0-100%, instead of 0-99%.
  • Channels can be mapped to different colours without needing to physically rewire the device.
  • Improved compliance with the ‘Color Control’ capability definition, as discussed here.

Screenshots:

Full installation instructions and a user guide can be found on github: https://github.com/codersaur/SmartThings/tree/master/devices/fibaro-rgbw-controller

All feedback welcome!

Z


Starting from zero - SmartThings and Fibaro RGBW
Fibaro RGBW Controller (DTH link in post 32, police light smartapp link in post 79)
Fibaro RGBW Controller (DTH link in post 32, police light smartapp link in post 79)
[RELEASE] Fibaro Dimmer 2 (FGD-212) - Advanced DTH (V2)
Wifi Light Strip (Link Given in Post)
Status LEDs at Front Door
Simulated RGBW Device crashes the smartthings app
RGB Light Connect App
How can I set custom color sequence with ST using Fibaro RGBW controller
Fibaro RGBW sets off lights everywhere, but only when physically activated
Best way forward (new U.K. user)
Realtime state updates from Fibaro switches or the RGBW Controller?
Controlling Fibaro RGBW with Smartthings without a Fibaro hub
RGBW light strip and Fibaro RGBW module help
Soffit rgbw strip lighting advice (UK)
(Dale C) #2

I love the layout that @erocm1231 uses on his H801 device handler so I am you modeled after it. It makes the UI more consistent between my RGBW devices. :grinning: …installing now.


(Zimi Van Ende) #3

Hello, the fire place looks very green. Is this fixable? Can I make more programs? And finally how can I make virtual buttons of switches for these programs so that alexa or google home can turn them on?

In general VERY VERY VERY good job you did here!


(Hendre) #4

Hi @zcapr17. I intend using this controller for a completely different purpose - to monitor the condition of my backup generator (which has auto and unattended transfer from mains to generator power and has outputs which can be configured to report on info like errors / running / starting etc. The idea is to connect these outputs to the inputs of the RGBW Controller and then use that in webCore to run pistons according to what the generator is doing. Nothing will be connected to the RGBW Controller’s outputs - the controller will simply be used as a means to determine the condition/state of various parameters of the backup generator)
I was wondering if the controller also reports the main input voltage to it and if that info is available in your DH to be used in webCore. My plan is to use that info to monitor the condition of the starter battery of the generator (the RGBW Controller will get its power from the generator 12V starter battery.) Our should I rather use one of the controller’s inputs to get that information? If so, will I have to connect some sort of a dummy load to the output to get the Voltage reading?
Thanks


(Hendre) #5

I’m trying to setup the Controller with this DH. I’m 110% sure I have selected an option which each of the settings (using the ST mobile app on my mobile), yet, when I click “Done”, I get a “Please fill out all required fields” error.
I can’t figure out what the issue is. Any help would be appreciated.


(Robin) #6

You’re obviously using android, so you need to go into the DTH code and remove all the defaults from the preferences section.


(Robin) #7

Or if you know someone with an iPhone all you need to do is open the preferences section once and then click done, from there on out it will work nicely on android


(Hendre) #8

Thanks, I’ll have to look for my old iPad it seems.


(Hendre) #9

Thank you @RobinWinbourne - as always you came to the rescue.

Does anyone know off-hand how I should set up the controller to act as a simple relay? I should be able to configure it so act as a 4 channel relay with 4 inputs and 4 outputs, should I not?

The manual is not clear as to how the setup should be.

Currently, I get 12V out on all the inputs but no voltage on the outputs.


(codersaur) #10

No, the FGRGBWM-441 doesn’t appear to report voltage on the main input. As you say, you could connect a signal to one of the inputs, but be aware the analog inputs are 0-10V (not 12V), so you might want to use some kind of step-down circuitry.

You’ll want to set parameter #14 to either 9, 12, or 14 for all channels, depending if your switches are momentary or toggle (I am not sure how the Toggle with Memory feature actually works).

HTH

.


(Hendre) #11

Thanks you, I will play with it again tomorrow and let you know how far I got…


(Rick W) #13

I have 432 watts of led strips and need to use 2 fibaro rgbw controllers - Is there a way to control both of them with just one app?

I want to be able to tell alexa to turn bedroom lights off or on and have both fibaro’s do the exact same thing instead of having to tell alexa to turn two different modules off. I also want to be able to control both fibaro’s with just one app on my android if that makes sense.

Can I do that somehow or is there a better controller out there that could handle the higher wattage? fibaro’s can only handle 288w@24V.


(Rick W) #14

Would it be possible to get rid of one fibaro module and use an LED strip amplifier in place of the fibaro?

Like this one? https://www.amazon.com/12V-24V-288W-RGBW-Amplifier-Protection/dp/B00M0FPV4I


(Mark) #15

If you have both the Fibaros in the same Group (Bedroom Lights) in Alexa itself does it not turn them both off anyway?

Probably the easiest way is to create a Virtual or Simulated Switch in the IDE, go to My Devices, Add Device,Type in a Name (the Name will be in ST as a switch), enter a unique Network ID (make something up that will not be replicated anywhere), select a Type of “Simulated Switch” (You could try “Simulated Colour Control” but do not think it will work with Smart Lighting so experiment once you have the ON/OFF working). Set the Location and Hub, click “Create” This will then give you a Virtual or Simulated Switch in ST. Then use Smart Lighting or similar App with this new switch to Turn both the Fibaro RGBW’s on/off, again not sure how the colour will work here but play around with the Simulated Types and different Apps.

Can also take a look at the Trend Setter App, you should be able to switch them ON/OFF under one switch with this and possibly even change colours although the scenes will obviously not work. Add the Switch and Colourful Device, the app and child app first and try to Colourful DH on the Virtual switch first and see if that works, if not then try the simple Switch to just turn them ON/OFF together. I assume this app does pretty much what I detailed above but the DH’s may be better than the delivered ones and give you colour control on the Firaros as well but remember this is not the Fibaro DH so it will be basic controls of course, if it does work. Have not tried it myself but it may work.

https://community.smartthings.com/t/release-trend-setter/31286

I would also take a look at CoRE and/or webCoRE, steep learning curve but you can pretty much achieve anything with those.

Saying all this cannot see why the amplifier would not work as at the end of the day it is just a normal RGBW powered strip and the controller is irrelevant. This will probably solve all the issues leaving you with just one Fibaro so if you have no need to control them separately I would take this route to save you messing about with Virtual switches and or CoRE etc…

Let us know how you get on!

Best of luck!


(Mark) #16

I just tried Trend Setter and it works fine as an ON/OFF switch for multiple lights, including the Fibaro RGBW. It also works fine for other Colour Bulbs (Hue, LIFX etc.) using the Colour DH however for some reason the Fibaro goes all over the place when changing colour using this App’s Color DH. There is a mention of Fibaro RGBW in the thread so will investigate further and post there. However if you install this Apps and DH’s via the IDE then this is a much simpler solution than creating Simulated Switches manually and you may find the app useful elsewhere also. I know I will use it now. Just remember for now to use the normal Switch rather than Colourful for the Fibaros when running the app and setting it up.


#17

Everything works. The polling of the power and correct status of light channels are magical.
Thanks zcapr17!


(EinarS) #18

Hm I have some issues using this on in WebCoRE.
If i set colors it turns on white no matter what.
I found out i need to do a “refresh” in DH or WebCore to se changes in live log also.
I dont have a physical switch on this dimmer btw.
There is a delay and even sometimes mismatch in real status and what i se in the device in the ST app.
Any clues anyone?


(David Montoya) #19

I’ve got a question more on the wiring aspect and less on the handler, so move this if necessary I have the Fibaro wired as such:

I’ve also uploaded the Device Handler to my hub, and I can’t seem to find the device. Will it not show up until I have the RGBW strip connected?

Anyone want to point me in a possible direction as to what I may be doing wrong, or where to troubleshoot further?


(Robin) #20

It doesent need a load connected to be added to ST.

With the power turned on to the module, and the ST app in the ‘add a device’ mode, triple click the ‘b’ button.

It should then pop up on your screen.


(David Montoya) #21

I’m only connecting V+ and GRD ? Noting on the V- ?