[OBSOLETE] Tado (Connect)

I have released v2.7 of my Tado (Connect) SmartApp

Full Install instructions and links to the Device Handlers are available on the link below.

I have now moved the Tado SmartApps And Device types to a new Tado Repository to make things easier for those with Github Integration in the IDE. you now need to enter my repository details to install or update the app

Namespace: fuzzysb
Repository: Tado
Branch: master

Change Log
v2.7 For anyone experiencing issues of not being able to control AC devices, please update to the latest Smartapp and device handler code as this should now fix your issues.
v2.6 Fixed Commands for those with Heat Cool that do not support Fan Modes
v2.5 Amended bug where Hot water type was set to WATER, Instead or HOT_WATER, with thanks to @invisiblemountain
v2.4 Added Device name to DNI, trying to avoid issue with multiple devices in a single Zone
v2.3 fixed bugs with Swing Command and added support for swing in all modes
v2.0 Added support for Air Condiioners which have a mandatory swing field in the heating & cool Commands, thanks again to @Jnick
v1.9 General Bugfix for some thermostat functions for those users using Fahrenheit, with thanks again to @Jnick
v1.8 General Bugfix for scheduling bug re-introduced in v1.7, with thanks to @Jnick
v1.7 General Bugfixes around Tado user presence with thanks to @sipuncher
v1.6 fixed defects in user presence device polling
v1.5 scheduled refresh of tado user status every minute (Thanks to @sipuncher for pointing out my mistake)
v1.4 Added ability to have your Tado Users created as Smarthings Virtual Presence Sensors for use in routines etc…
v1.3 Corrected Cooling Commands and Set Points issue with incorrect DNI statement with thanks to @Odgregg
v1.2 Corrected bug with changing set points in the Heating and Hot Water Device Types (you need need to update those device types also) if you still experience problems with your set points after this please go into your device settings and then hit Done, after which you should be able to set the set point.
v1.1 Updated to Support Multiple Hubs (with thanks to @Mike_Maxwell), and fixed bug in device discovery and creation, however all device types need updated also.
v1.0 Initial Release (Supports all Tado Device, Heating, Extension Kit, Cooling & Radiator Valves)

Important Note if updating from an earlier version of my device handlers, you will unfortunately need to remove all devices and device types, and re-install using the new versions, this SmartApp resolves previous issues with the device type updates not being scheduled, and also fixes all crashes when using an apple device when first setting up.

countless hours have been dedicated to updating this smartapp and associated device types, if you use these and find them useful, please consider donating, this aids in further development and support. and any and all donations would be very much appreciated.

Full install instructions are provided on the github page


Hi. I don’t yet have a SmartThings hub, but do have a Tado Smart AC and a Google Home. Does this make the Tado appear as a thermostat in SmartThings so that Google Home would respond as though it’s a normal thermostat/AC? ie. Can you set temperature, or ask what it’s currently set to?

It does indeed. I currently do the same but with alexa. These device types conform to the Thermostat capability in Smartthings

1 Like

Excellent! SmartThings hub ordered. Look forward to trying this out in a few weeks.

Unfortunately I can’t get it to work.
The smart app is running stock at line 241

java.lang.NullPointerException: Cannot invoke method sort() on null object @ line 241

@Menno_Bakker That implies the is no zones under your account. I have all the different Tado products and this works fine against all. What tado device/s do you have under your account?

Do me a favour and DM me the full log of your install attempt and I will be able to diagnose for you

1 Like

Dear Fuzzyligic,

I managed to get everything working now.
Somehow I must have been doing something wrong in my first attempts.

Thanks for your help!
A small donate is on his way.

1 Like

Good to hear. Many thanks for the donation much appreciated.

I was just reading about these Tado systems to controlled my split acs, but I got to say the reviews were not great.

Can you guys attest to these things actually working well with split ac units?

The Tado Cooling product works with split AC’s I am using it myself with one.

Of you have one of the main brands of AC like Daikin, Toshiba, Samsung etc then the setup is extremely easy. However if you have an obscure make like mine then it’s nowhere near as easy as the setup takes a long time. But it does work and once setup there is very little maintenance needed.

The device just emulates your IR remote control so there is no actual feedback that the device was sent and recived by the AC. But I can honestly say that that has not been an issue at all for me when using it.

But simply if you have an AC that does not have a way to schedule and only works with with an IR remote only. Then the Tado Cooling device is one of the better solutions around. I tried a number of cheaper options first and had no success with them.

Yes I have two obsure ones… I don’t mind if it takes long to set up, as long as it sets up and I can use it with Core.

well it should work fine for your purpose, the only important thing is positioning the device so the Infrared signal can be received my the air conditioner without obstruction. the setup of selecting the IR codes will drive you insane though, it should be easier but its not and is extremely time consuming, took me about 3 hours total (its been a while and i dont know if anything has improved recently) but as i said once it has been set up it works without issue,

Okay, I’ve got the hub, and have this installed. However it only appears to go into heating mode (even though it appears to have added the device as supporting heating and cooling).

I’m not exactly sure what is meant to respond on the screen or not. It seems impossible to switch it on manually, but once on some of tiles do respond (eg. the heat set points etc).

If I change the mode to cooling through Tado, the tiles do update correctly.

I can press heat to switch it on, but not cool.

Okay, found the log output. I’m getting the following even time I click “cool”

error groovy.lang.MissingPropertyException: No such property: dni for class: physicalgraph.device.cache.DeviceDTO Possible solutions: id, hub, data @ line 1355

Okay, I’ve fixed it myself. There were some references to childDevice.device.dni which doesn’t appear to exist.

Changed them to:


Which was working in the heatCommand.

I think there were 3 places I had to change it.

Could you do me a favour can you do a pull request in GitHub so I can check your code against my setup and release a new version

Sure, if I can work out how to do that :slight_smile:

(I’m a Team Foundation Server user, not Github)

Okay, think I’ve submitted it successfully.

Yes thanks once I finally get out of bed today I will review and do a new release with credit. Thanks

@Odgregg you pull request has been merged with the main branch with credit, many thanks for your assistance in testing.