[DEPRECATED] Tado Hot Water Integration

dth_plumbing
tado
dth_hvac
dth_waterheater

(Stuart Buchanan) #1

Please see the Tado (Connect) SmartApp for using your Tado Extension Kit with Smartthings for controlling your hot water


#2

Thanks @Fuzzyligic, looking good - nice work!

Sorry, no temp on my hot water either so can’t test that aspect.


(Stuart Buchanan) #3

Just pushed an updated version which will allow better integration with Rule Machine etc…


#4

i’ve decided to get tado later in the year (autumn) and will get a valve too. my boiler is supposed to support temperature, so I will prob get the extension controller and throw out the basic timer I have for the extra control. So I will come back and do all the testing for you then!

looks good and is the bit that makes me go… ok tado it!

thanks


(Jill stanton) #5

Hi,

I’ve just installed your latest code as seperate device handlers and then setup 3 separate devices with each of them linked to once o the device handlers and they appeared under “things” ok.
then configured my tado account details via the things config screen.

had to wait a minute it or so for it to connect.using but now the tado heating control is showing the temperate in my house which matches the tado app itself :slight_smile:

hot water control is showing outside temp but no water temp and therefore doesn’t match tado app. so will look at that and see if I can see anything as I know you’ve not been able to test that.

user presence control doesn’t seem to be doing match either, so going to look in that code as well. maybe I need to install against my phone rather than the new device I created… makes sense in my mind anyway.


(Stuart Buchanan) #6

hi @Jds_uk glad to see part is working for you. does your tado app show the water Temp? the reason i ask is that my boiler doesn’t have this support and it isn’t shown in the app. but if yours is, i can very quickly fix it, but to do so i would need to run a query and capture the output from tado. if you would be willing to assist and are available now could you set a temporary password on your account, pm it to me, let me log on and capture the output from the water, then you can change your password again… promise i wont change your heating mode :slight_smile:

as for the User Presence, its completely broken as tado dropped the old API, its on my list to fix next. wasn’t aware many people were using it.


(Stuart Buchanan) #7

just pushed new Version of Hot Water v1.4 that i believe now correctly shows the water temps with thanks to @Jds_uk


(Stuart Buchanan) #8

@Jds_uk did the last update work for you now to get your water temp readings?


(Jill stanton) #9

Afraid not


(Stuart Buchanan) #10

ok any chance you can again PM me your logs for both this app and also the Tado presence to look into further


(Jill stanton) #11

6e279038-0cef-4945-8f47-707503a28fe6 16:55:19: debug Temperature Unit is C

6e279038-0cef-4945-8f47-707503a28fe6 16:55:20: debug Send Outside Temperature Event Fired

6e279038-0cef-4945-8f47-707503a28fe6 16:55:19: debug Output status: 200

6e279038-0cef-4945-8f47-707503a28fe6 16:55:19: debug Read outside temperature: 13.55

6e279038-0cef-4945-8f47-707503a28fe6 16:55:19: debug calling weatherStatus Method

6e279038-0cef-4945-8f47-707503a28fe6 16:55:19: debug Executing ‘sendCommand’

6e279038-0cef-4945-8f47-707503a28fe6 16:55:19: debug Http Params ([uri:https://my.tado.com, path:/api/v2/homes/14136/weather, requestContentType:application/json, query:[username:XXXX@yahoo.co.uk, password:XXXXXX]])

6e279038-0cef-4945-8f47-707503a28fe6 16:55:19: debug Executing parseResponse.successTrue

6e279038-0cef-4945-8f47-707503a28fe6 16:55:19: debug Temperature Unit is C

6e279038-0cef-4945-8f47-707503a28fe6 16:55:19: debug Executing ‘sendCommand.weatherStatusCommand’

6e279038-0cef-4945-8f47-707503a28fe6 16:55:19: debug Output status: 200

6e279038-0cef-4945-8f47-707503a28fe6 16:55:19: debug ___exception: java.lang.NullPointerException: Cannot get property ‘celsius’ on null object

6e279038-0cef-4945-8f47-707503a28fe6 16:55:19: debug Executing ‘sendCommand’

6e279038-0cef-4945-8f47-707503a28fe6 16:55:19: debug Executing parseResponse: [setting:[power:OFF, type:HOT_WATER, temperature:null], preparation:null, overlay:null, link:[state:ONLINE], activityDataPoints:[:], overlayType:null, tadoMode:SLEEP, geolocationOverride:false, sensorDataPoints:[:], geolocationOverrideDisableTime:null]


(Jill stanton) #12

This is what I am seeing for hot water control


(Stuart Buchanan) #13

@Jds_uk

First of all i can see that you copied from Github using the Raw page, unfortunately the raw page does not work for device types that have the degrees symbol in them, can you please copy the code again from my github, but don’t use the Raw page.

also i have come to the realisation from your log that Tado only returns the current set point value and not the current water temp. I have changed the code to remove the point where an exception is hit when the device power is Off. this should sort out your issues.

so in v1.4 the temp will display the setpoint value which is exactly what the Tado App does when the power is On. sorry for the confusion. once you have installed the new code and published, plese go into the device pereferences and hit the done button, this will update the various state variables.

Thankyou for assisting with this.


(Jill stanton) #14

hi,

have just done the updates and not when I try and go into the settings to set my account details, ST is crashing for both hot water and heating control.
are you getting the same? wonder if related to the recent app update or hub update.

Regards,

Jill


(Stuart Buchanan) #15

It’s seems in the latest app update for IOS everyone’s is doing the same thing. Just wait for 20 mins or so before you go into the app so it gets its first update then it works for everyone who has tried. I am presuming by now if you load it in the app it now works OK?


(Jill stanton) #16

nope, still crashing.
:frowning:


(Jill stanton) #17

fuzzyligic - my heating control and water control are still crashing and have set tado username and password via IDE (edit preferences on the device).
do you know how long it takes to do the first conncetion and download from tado?
also what is your “Device Network Id”, I have mine as just some text e.g. Tado_Heating_Control but wondering if it needs to be a real id number, if so what is it or how do I find it.


(Jill stanton) #18

Hi,

I checked this morning and heating control is working again and not crashing and has downloaded data from Tado.

Hot water control is still crashing so will have a look at that later

Regards,

Jill


(Stuart Buchanan) #19

updated to a new version for those with newly merged accounts for multiple zones, but it is a quick dirty workaround until i get more time


(Jill stanton) #20

Hi @Fuzzyligic - my hot water control is still crashing months on. any ideas?
i’ve updated to the latest code but still the same. heating control is still working lovely though.