SmartThings Community

New hub v3 owner. When adding hub to app, it gets stuck on update page


(Jimmy) #83

any word on how the new firmware is working out for the beta testers?


#84

They seem to have figured it out. Waiting on the official firmware release now. Not sure what that process is, but I’m sure they’re speeding it up as much as they can.


(AM) #85

Facing the same issue. My experience with ST has been nothing short of frustrating! Seems like ST released a not so ready product to the market. Glad i got to this forum and saved myself hours of pain and agony. Waiting for an update.


#86

Hi. Another new hub V3 owner here. Just wanted to add my “me too” to the conversation. Extremely frustrating to find the first, basic interaction with the device to be so painful. Count me among those hoping that a new update with a fix for this WiFi issue is released any time now.


#87

I am having the exact same issue and eager to see the results of the Beta test. I am also looking to upgrade my Wi-fi router which gives me wired connection option.


(Spearb12) #88

I am having the exact same issue with WIFI set up. Just got the device for Christmas and already hit a brick wall. The interesting thing for me is that the ethernet functionality isn’t working for me either, so that isn’t even an alternative. I have a Netgear Orbi router system. Wondering if this is a common theme for netgear users or not?


(Sean Hoess) #89

Same issue here. I was able to get the hub installed via wired connection, but that connection is in the far corner of the house and thus is non-optimal for most devices (ones on other side of house don’t even get the signal). Please let us know as soon as this is fixed, thanks. Not a functional product as it is…


(Sean Hoess) #90

I have a Netgear Orbi too, by the way, and it’s not working for me either. However, it seems that other people have different routers but are experiencing the same problem.


(Tony Fleisher) #91

If you haven’t already, please make sure to contact SmartThings supportc so they can track the issues and help troubleshoot.


(MK Edler) #92

I’m having the same issue as well (tried setup numerous times using iPhone XS and an old SE). If any openings for the beta firmware become available - I’m interested.


(Paul Osborne) #93

Hey all, we got a good build that our beta testers confirmed late on Friday that resolves the issue experienced by our testers that matches what has been reported in this thread. We will be having our release go/no-go meeting in the next couple of hours and likely be targeting a release of updated firmware for Thursday (I believe the plan for this one will be to announce in advance [today] on the community forums).

In order to receive the update, the hub will need to be online and talking to the servers. This could take the form of:

  1. If claimed, plugging the hub into ethernet until the update is completed. At that point if the hub was originally setup with Wi-Fi you should be able to move it and have it connect on next power on.
  2. In not claimed or if Wi-Fi is unavailable, going through the setup process again should allow the device to connect and download the latest updates.

Thank you all for your help in diagnosing this issue and your patience in waiting for a resolution. This particular issue required specific timing on startup (influenced by a confluence of factors) resulting in the failure that resulted in it not being hit by a majority of customers as well as anyone in our internal alpha/beta/rc test pools as well as QA testing. With info from the beta testers, we feel confident that we were able to isolate the root cause (and source of nondeterminism) and have the right fix for this issue.


Smartthings Hub V3 (2018) wifi setup
(MK Edler) #94

@posborne Thanks for the informative response! If Samsung’s smartphone division is this responsive to issues - I may migrate from iOS.


(Paul Osborne) #95

(Lance Gwennap) #96

I got hung up at 99%. I unplugged the hub and plugged it back in several times. I waited a few minutes each time and on the 3rd or so time, the light went green and I finished the setup. It works now. I am sure if I lose power it might not come back the first time. However it beats having to plug in to the network to get the update tomorrow.

Lance


(Paul Osborne) #97

@lgwennap Is the behavior any better after receiving the update today?


(Mark Johnson) #98

I think I have a fix, and it was to disable IPv6 on my router. I initially set it up as WiFi, but had the Ethernet cable connected during setup (as directed by support). It worked only if the Ethernet cable was plugged in. I ran into a similar issue configuring an Echo for my parents, and disabling IPv6 helped on that as well. I came home, disabled IPv6 on my router, disconnected the power and Ethernet on my Smartthings v3 hub, plugged it in without the Ethernet, and so far it is all working fine! I hope this helps someone!


(Paul Osborne) #99

Interesting, we do not support IPv6 at present but things should generally fall back to IPv4 so just having IPv6 enabled shouldn’t be a problem on its own. There may be something suspect with your router firmware or configuration if other devices also fail under the same conditions.

At my home, for instance, I have a DHCP V6 Server enabled on my pfsense router. Most devices do not even try to acquire a V6 address but one will be provided if requested. If the option on your router is disabling the DHCP (v4) server than it is not surprising that the hub and other devices might fail to get on the network.


(MK Edler) #100

Fix seems to work for me - thanks to @posborne and co. - much appreciation!


(Mark Johnson) #101

DHCP on IPv4 works just fine. It is just interesting that I tried multiple times to no avail, but 1st time after disabling IPv6 it works perfectly. It could be something with AT&T routers, or it could be coincidence. It would be interesting to see if others have the same results.


(MK Edler) #102

AT&T routers are problematic - I have found that AT&T shunts a lot of features in their modems… in-turn that seems to break the enabled (allowed) features making the device perform erratically.

Before the firmware update my modem and router had IPv6 active while I experienced wi-fi connection issues during setup the wired setup always worked fine.