SmartThings Community

New hub v3 owner. When adding hub to app, it gets stuck on update page


(Daniel Cassat) #61

This is my opinion based on years of troubleshooting experience and dealing with various vendors in the industry.

I believe Samsung has an issue with their firmware they are trying to resolve still. Any effort to remedy this situation yourself is in vain. My hub works fine if it’s hardwired and I stopped trying to get it to work on the wireless after the 4th try because I think it needs to be fixed by Samsung.

They are likely going to lose a number of customers with this issue and that is to be expected based on the inability for the device to work as expected, even with many who have decided to fight it until the end.

I say call it a day until Samsung gets it fixed.

It would be really helpful to get an update from them now on this issue!

Dan


(Bikash S) #62

I am experiencing the same issue. This is brand new second hub, I am trying to setup. It is stuck at 99% and does not get completed. The whole point of upgrading to newer version was to bring hub to central location of house. But, it seems that Samsung still needs to figure out this issue.

Please let me know if anybody has found solution to it.


#63

I hate to do a me-too post, yet here I am. I relocated my perfectly functional hub, but it never connected back to wifi after plugging the power back in.
I’ve been trying resets ever since, and I’m stuck at the same spot as all of you. The update never completes.
My entire ST setup is dead in the water. Not cool.

@Brad_ST, anything?


#64

Don’t think a fix has been completed yet, but for what it’s worth, I’m keeping mine connected via ethernet for now, so that I still have functionality. At least it works via ethernet at the moment.


#65

Okay, call me crazy, but I’ve been through a bunch of the above and I found a solution that worked for me…

My history:
-Bought a v3 hub (first of anything like this in my house, yes, I’m a noob)
-Tried WiFi setup (along with factory resets) a number of times with no luck
-Tried it wired, and it worked fine for a couple week, but…
-I intended to run it using WiFi
-On Christmas vacation now, so more time on my hands
-Tried the factory reset and WiFi setup a couple times again, but still no luck
–I typically get through 50%+ of setup, usually up to 99%, but hang…
–Hub looks to reboot
–Comes back to blue blinking LED (which I understand mean that it didn’t get a DHCP address)
-I read through a bunch of posts, including the one above.
-Someone mentioned that the problem was the WiFi radio having issues and overheating…

So, I got to thinking… This might explain why at least one person had success after unplugging it for 3 minutes; Maybe it cooled down enough and their house was cool enough, or whatever, that the radio was cool enough to not overheat.

Here’s what I did (after at least 8-10 previously failed attempts), following the notion that “maybe it’s a heat problem.” I told my Samsung Galaxy S8 to forget my normal WiFi connection (in case it was automatically switching over to a stronger signal or something). I plugged in an extension cord and ran it over by my refrigerator. I then put my SmartHub v3 in my freezer for a minute or two to cool it down. Next, I did a factory reset and started the setup process again, leaving it in the freezer the entire time, except when I had to scan the QR code on the bottom, but then I put it right back in the freezer and close the door again. I then ran through the rest of the setup, selecting 5GHz WiFi (I heard the SmartThing Hub v3 prefers it, but not sure), it actually remembered my password from a previous attempt (surprise), and then it did its 50+MB update… It seemed slower than any previous attempt (and definitely slower than what my WiFi/internet is capable of), maybe due to not the greatest signal strength from inside my stainless steel friedge, but it actually worked. I took it out of the freezer after it said setup was complete, and I had a solid green LED.

Been online via WiFi for about 15 minutes now and the LED is still green and shows up in SmartHub.


(Jimmy) #66

That may be the craziest IoT work around I’ve ever heard of :joy: glad it worked!


(Paul Osborne) #67

We think we have a fix and we are verifying it now thanks to feedback from @Texmurphy4 and @General_KAOS . Most likely if you just reboot the hub a number of times it would have connected eventually. With some network configurations, the agent that configures the Wi-Fi connection with the network management software ends up retrying network configuration at too fast a rate if the connection is not made successfully on the first attempt (or within the period of time anticipated). This results in the network manager not actually making progress toward the goal of connecting to the Wi-Fi access point.

I’m not saying to not put your hub in the freezer, but I’ll look at you a bit funny like everyone else ;).


(Chris) #68

I’m a new SmartThings Hub (v3) owner and I encountered the hanging during update issues as well. I was able to slog through it and get connected to the wifi after a series of factory resets. I did several different things but I believe the following steps are the ones that led to resolution:

-The first update of ~117MB hung at 99%
-Tried several things but could never get the LED to change to Magenta, it would just keep blinking blue
-Performed a factory reset suggested here:
https://www.samsung.com/us/support/troubleshooting/TSG01109547/#factory-reset-a-smartthings-hub-2018
–However, I did not get a solid yellow. I held the reset in when powering on and got a flashing yellow light for 20-30 seconds. Next the light briefly went blank and I let go of the reset. After that, the Magenta LED showed up! After a few minutes the LED went back to blinking blue (I think) and from there, I attempted to register the hub again.
-When the lights went blinking green/red I went through the registration again and now had a 57MB update that needed to be applied
-Update gets to 99% and just hangs
-Wait 10 minutes at 99% and then do the factory reset again
–Again, after 20-30 seconds of flashing yellow I let go of reset and the LED changes to Magenta shortly after
-Eventually the hub goes blinking blue and then solid green
-Holy crap, it actually finished and I could see the hub in the SmartThings app!
-I powered off the hub, relocated it, powered it back on, and whew, it still worked!

My hub is in an open area and I didn’t observe any heating issues. Here are my setup details:

App: SmartThings (not the classic version)
Phone: Nextbit Robin
OS: Lineage OS 15.1 (Oreo 8.1)
Wifi Router: Google Wifi with both 2.4 and 5ghz using the same SSID

I should add that I did multiple power cycles and also briefly pressing the reset button and did not get any progress. Only the factory reset method allowed me to move forward, but never got a solid yellow light strange enough.

Hope this helps!


#69

Is there a timeline for this proposed fix?

I tried it two more times in the past hour, and the second time while I was watching a tcpdump of the hub traffic on my router, it successfully popped online. I was trying to look for abnormalities, but naturally I’m not going to touch my hub anymore now that it is online.


(Paul Osborne) #70

The difference probably would not show up in tcpdump at all as it relates to the actual establishment of a connection with the Wi-Fi Router itself and not TCP/IP traffic after that point.

I don’t have a release date to share; there is a final part of the changes that are being validated and things get a little dicey around the holidays for a few different reasons (users are away, engineering support is decreased as people go on holiday, etc.). When there’s a problem it’s a damned if you do, damned if you don’t situation sometimes (and, yes, user applied update as an option would help).


(Tadd Young) #71

I am also stuck at 99%. I am not a happy camper. I have wasted a ton of time resetting and re-trying to connect a device to my network that should not be that difficult. The installation process is clunky having downloaded 57Mb around 15 times. Unless I read some resolution soon, I will be returning this hub and not have a very pleasant opinion of Samsung products.

Observations and results:
-During the install, I see the hub obtaining an IP address on my router.
-Connecting direct to ethernet results in immediate green
-Was able to finally see a solid green light in WiFi. Did some minor testing. Moved the hub to where I wanted it permanently. Blue blinkies again. Tried installing two more times with same results. I have absolutely no confidence of the integrity of this hub and WiFi (the WiFi was the reason for purchasing).

Can anyone please give me a reason to hang on and not return this thing?


#72

I get everything you say. Release management can be a painfully slow process, but this should go out asap. I’m okay for now, but many others aren’t.
Next week many more new first time customers will try to configure their new hubs they got (themselves) for Christmas. They’ll all be left hanging.
This can be a huge PR nightmare similar to what happened to Sony and Microsoft during prior release cycles over Christmas.
I realize I’m probably preaching to the choir. Thanks for being a voice on these forums so at least we know that a fix is in the works.


#73

I’m an idiot. I installed a new dimmer switch this morning, and as soon as I flipped the breaker on the circuit I realized I just powered off my hub too.
:sob:


(jkp) #74

You should consider getting a UPS backup for the hub :slight_smile:


(Labs) #75

Just got hub v3 today, first of all, it doesn’t even let me select SSID with broadcast turned off!!!. Does that happen to you as well? Can’t believe it does not support this. Even cheap smart plugs support that

Then notorious 99% issue got me nowhere. Had to plug the wire in. So what’s the point paying more than V2!!!

Hope to see the fix soon


(Patrick) #76

@openlabs, hidden networks are supported. When you see the list of available networks there’s a “+ Add Network” (that’s on android, I don’t have an iOS device to verify what it says there, but I know it’s there too) option at the bottom that will let you connect to your network.

Now, there’s still the other wifi issue mentioned in this thread that could give you issues, but hidden networks are supported. If you’re having an issue that seems different from what has been mentioned up-thread, let me know some details about what exactly is happening.


(Paul Osborne) #77

The caveat to this is Samsung phones at present. I’m guessing that is the case for you @openlabs. We are continuing to talk with mobile to communicate that we do not believe the current implementation there is acceptable.


(Paul Osborne) #78

Looking for Beta Volunteers

We are planning to put together a very brief beta for people experiencing this issue. This would be released later today (in a few hours probably around ~4PM CST) and we would be looking for feedback later tonight. This would, for now, be just for this release and not part of the more permanent beta process we run through Centercode (but we will be expanding that to V3 now that there is a customer base on that product).

For this beta, I will have a DM thread going with the participants to gather feedback from the update. If you would like to participate please send me a DM with:

  1. Your V3 Hub Serial Number (if you don’t have this handy, I can look it up for you based on account email).
  2. The email associated with your SmartThings account.

If you are unable to DM me, ping me on this thread and I will follow up. CC @General_KAOS, @Texmurphy4, @NGDSkier, @StephenB, @Tony_Glass

For any of you that missed this, we expect for the full release to follow shortly assuming no major problems have found and the key problems are resolved.


(Labs) #79

thanks for response. I’m using iOS. Ended up calling 800 support number, and was told that hidden network was NOT supported. Was very skeptical about the answer I got. Simply created a new SSID with broadcast turned on, and then hit the issue not able to update firmware discussed in this thread.

Appreciate the attention and effort to fix from you and others at SmartThings, hope this can be quickly resolved before havign to return the new purchase.


(Greg) #82

Found this on Samsung website - https://www.samsung.com/us/support/troubleshooting/TSG01109706/
In step 1 … It may be necessary to disable carrier data
Under what conditions should one disable carrier data?
Step 5 same question… It may be necessary to reboot router /modem
Under what conditions?

Thanks very much

Not your problem, I know… but I would ask these ??s of TechSupport but my email support request from Saturday is still unanswered. Imagine this issue is generating a tidal wave of TS requests. Every v3 hub sold and attempting to use WiFi (the only plus to v3) is affected.