Linear Garage Door Opener Stopped Working

Hey folks. Long time reader, first time poster. Before you think I’m beating a dead horse, yes I have searched far and wide about this thing. No one had my issue, so I figured I’d bounce it off you guys. My GD00Z-4 was working perfectly for about a year. It was set up to open when I got close to the house, close if I forgot and left it up when I left, and could generally control it from the iOS app. One day it didn’t open when I got home. I thought there was a power outage until I used the remote in my vehicle and it worked. Odd, but didn’t think much of it. Later tried to open it in the app, it said “opening”, but I didn’t hear it opening. Had to close the app as it was “stuck” on “opening”. Restarted the app and it came back normal, "closed"as it was. Tried to open again- it beeps, did NOT flash the LED, and did not open. Same issue for closing. It’s on a Chamberlain opener with a normal wall push-button (the one that looks like a doorbell), not the fancy one with motion detection and temp sensing nonsense that have been giving people trouble. I have reset the darn thing any way I could think of up to and including removing it from Smartthings and re-adding it. I’m at a loss. Is it toast? Do i need a new one?
IN SUMMARY IF YOU DON’T WANT TO READ THE ABOVE:

  1. used to work for about a year-now it doesn’t
  2. beeps but NO LED flash and no operation from iOS app (sticks as either “opening” or “closing” in app-have to close app to reset status
  3. visible in app as open/closed-so it is communicating
  4. tried all ways to reset including removing from Smartthings and re- adding it like it was a new device
  5. on a Chamberlain opener with basic hard-wired push-button wall switch

Is the controller itself toast?

2 Likes

hmm, if its beeping but no flashing or sending the button press then it sounds like toast. I’m assuming you also power cycled it?

Have you checked the leads going to the opener motor to verify that you a) have a good connection, and; b) are getting an impluse out of the Linear?

  • Nate

Sure did. A few times to be sure.

a) 3 different times b) used a cheap harbor freight with an LCD and didn’t get a reading-but depending on how long the impulse is it may not have registered

Jeremy8404, I have exactly the same issue. It was working for almost a year and stopped working about a month ago (I guess around the same time as yours). It exhibits similar symptoms - beeps on opening/closing (doesn’t actually open/close the door), is able to read open/close status via the sensor (when operating manually via remote) and the wires seem to be connected properly.
This is way too close to be a coincidence. Maybe there was a firmware or other update which broke it?

Question: Do you have a custom device handler setup in your IDE for this device?

Let’s see if we can put our heads together and come up with a solution.

I’m glad I’m not the only one anymore. After all the searching I had done online, absolutely no one had my exact issues. The only thing you neglected to mention is if the LED flashes or not (mine does not).

To me it seems more electrical than firmware as the LED does not flash and I don’t get a current (that I know of) through the wires upon activation, but this is speculation.

I have absolutely no custom device handlers whatsoever for anything. It all worked just fine as is.

At this point it seems so unknown and there seems to be no solutions, so I’m about to just order a new one. I can’t think of anything new to try. Have you done anything else to try and diagnose other than what I have done?

Visiting Vera user here. I have the same issue. Installed in Jan 2016. Stopped working Dec 2016.

I have another one on my other door installed Dec 2014 and is still going strong.

I agree that is seems like an internal electrical issue. Mine is reporting status fine (open and close). When used from app, beeps and very lightly flashes LED. Beep is not as loud as working one.

I’m going to try and contact Linear… but don’t expect much help based upon other posts I’ve read they charge $50 for support call. If that is so; I’m going to open it up and take a look inside. I’ll come back here if I find anything.

I just called 855-546-3351 and they told me to send receipt to returns@nortek.com. Within an hour they gave me an RMA. Looks like I will have to cover shipping back to them cost. Will update here.

Any one figure out this problem. I’ve two of them for about a year now. One stopped about 3 weeks ago and the other one just stopped today. I don’t think two both would go bad within 3 weeks of each other. It beeps but the light is not as bright.

Thanks

Reporting a similar issue - seemed to stop working about the same time.

Same thing here. Worked fine for about a year. Went on vacation a few days ago and when I came home, it was toast. Same symptoms as described here - beeps, reports status correctly, no flash, no door action (open or close).

I am sure this has been tried, but I had the same issue as mentioned above. But in my case, I had just installed is a couple of months ago and it stopped working about two weeks ago.

I put a new battery in the door position sensor and it started working just fine.

The battery I took out was not dead, it still powers a keyless remote or some other 2032 battery type devices. But I think the door sensor is touchy with a battery that may be low?

Anyway, worth a try. Worked for me.

It was a good idea, but I replaced the battery and still no luck. Thanks anyway!

I feel like mine stopped opening after the latest updates ST went through. worked fine for 5 months and now it beeps but no open or close… detects close or open if i manually do it. Anyone else had it working and it stopped. people are using a remote to attach to the zwave device but i dont think i should need to

Could these issues be caused by a power surge (maybe not that intense)? Before I purchased my Linear controller, I had to replace the control board on my opener because it stopped working. I made sure to purchase a cheap surge protector as a precaution. I don’t have surge protection on my Linear (yet), but it sounds like I may want to do that soon. Anyone know if it will interfere with the Z-wave communication? I can test it simple enough…I’m just lazy at the moment.

Just a passing comment, my issue was similar to @paulcusick3 Post #9 above. LED stopped flashing about 10 months after my original installation. I followed the RMA process (I was under warranty), and received my new device within a week. Everything has been good on the new device thus far. There was definitely an internal failure when it would beep, recognize the door status, and not blink the warning light.

Unfortunately, I purchased mine 13 months ago, so I am outside of the warranty and will have to buy another. Any recommendations for one that won’t bite the dust just after the warranty period ends?

Thanks!

It might be less expensive to bring the device to a TV or electronic repair as it might just be one component and easy to replace.

1 Like

My system just beeps but doesn’t open/close the door. Any solution to resolve this issue? My previous Evolve LFM-20 worked fine.

Could mine be incompatible or do I have a defective unity?

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.