Will the Leviton VRCZ4-M0Z zone controller work with SmartThings?


(J. Wilson) #1

I’ve read a lot of conflicting information about whether or not this kind of device will work with the Smartthings hub. It replaces a single gang switch and I feel like it would be the perfect switch to replace one of my switches that is currently used to turn an outlet on and off. (I’m going to hardwire it on soon since I’m using a SmartThings outlet controller on the plug at the moment and just leaving the switch on.) Since I will soon have an empty gang box I was hoping to install one of these to be able to easily control the lights in and around this room. I attempted to use a GE 45631 wireless scene controller but I’ve so far been unable to get it to work with the SmartThings hub and I’ve read a fair amount of information stating that the only way to get it to work is to buy another controller remote, program that one, then copy the data to it. The Leviton VRCZ4-M0Z is hardwired and claims to be compatible with standard z wave. Anyone know if this device will work out of the box or would I need to do just as much work as with the GE 45631? Thanks in advance.


Connecting VRCZ4-MRZ - not to be confused with VRCS
Can I join a Vizia RF+ network with z-wave utilities - Join/Leave another network?
(Brian) #2

So far I haven’t heard anyone saying its supported yet, but everything is squeaking about Vizia controllers so I could expect them to come down the pipe pretty soon.


(Brian Smith) #3

I’ve also asked for scene controllers to be added. I know they are on the list, but I have not heard a timeframe yet. I made some compelling arguments for them to be bumped up. :slight_smile: We’ll see.


(Brian Dahlem) #4

Does anyone have a VRCZ4?

I got my VRCS2 working, and wrote a device type that uses the scene commands from pressing its buttons to act like a standard switch. I’m wondering if the VRCZ4 can be used in a similar manner.


(J. Wilson) #5

I would be willing to pick one up if you think that the same device type could be applied. I was hoping to using it like a standard switch anyway.


(Brian Dahlem) #6

I doubt if the same device type would work as is, so I wouldn’t run out and purchase it just yet.

I just read the installation guide and it looks like it associates differently than the VRCS2, you don’t get individual buttons. Instead, it probably shows up as a single ZWave remote. I’m going to have to look at the remote that the VRCS2 creates to see how it communicates.


(Patrick) #7

I had picked up a few VRCZ4 Monster branded version a few years ago when they went on deep discount, but I ended up never using them because I didn’t have a scene controller to program them. After I got SmartThings, I thought I’d give one of them a try. It can be included into the network, but again, unless you have a controller that can program the scenes on its 4 scene buttons, it won’t be useable.
The monster version has an IR window on the bottom between the dimming controls that appears to have been meant to work with a separate handheld IR controller. I looked up that controller a while ago but it doesn’t look like it was used in any way to program scenes.
I had an old HomePro ZTW100 that I was able to use instead of this VRCZ4. It is an in-wall transmitter with a decora-style rocker. It doesn’t have a registered device type in SmartThings so I changed it to type: “Z-Wave Switch” and used the SmartApp called “The Big Switch” to monitor its status and switch on and off lights in that room based on whether it has been pressed on or off. Basically, it acts like a virtual light switch and has now replaced the HA07 controller I had mounted on the wall for switching on and off the lights in that room.


(Brian Dahlem) #8

I just got a VRCS4-MRZ and have it associated with Smartthings.

Here’s what I have so far:

Buttons are numbered 1-4 and dim, with dim at the bottom.

To associate, press and hold buttons 1 and 3 on the VRCS4 for 5 seconds, the LEDs will start to flash amber. Hold the SmartThings Hub near to the device tell the SmartThings app to connect a new device. Note: you tell the device to connect before the hub. The hub should find a ZWave Remote. This will eventually be your scene controller. Give it a name.

If you have a load connected to the VRCS4 (hardwired):
Go back to the SmartThings app dashboard. Press and hold buttons 2 and 4 on the VRCS4 for 5 seconds. The led on Button 1 will start to flash amber. Now tell SmartThings to connect a new device. It will find a ZWave switch. Smartthings will not be able to control the load yet, but button 1 will. To get SmartThings to control the load, you need to go into the api, and reassign it from ZWave Switch to my VRCS2 Button device type (The device type is available here: https://github.com/bdahlem/device-type.VRCS2).

That’s where I am at so far, its a fancy 4 button switch with only the top button working.


(Brian Dahlem) #9

I have a working configuration with the VRCS4-MRZ. I described it in a new topic here . It turns out the VRCZ4 and VRCS4 work rather differently, so I don’t know how well my solution will work for the VRCZ. In my research, it seems that the VRCZ would be easier to program for, with its separate on/off buttons and since it uses zone control commands rather than scene commands. But I don’t have one to try, so it’s up to someone else.


Leviton VRCS4
(Patrick) #10

That HomePro ZTW100 I installed a couple weeks ago appears to have died. It no longer responds to button presses and the LED indicator shows no activity. I guess I’ll have to remove this switch through the IDE and use the network repair function to make sure there are no routes going through that broken device.


(Ian D) #11

Hi all! I would too much like to see the Leviton VRCZ4-M0Z supported. I have a couple of those and plan to buy a few more, they would be perfect for what I intend to do.


(Wil Schroter) #12

Is the situation then that we cannot make the VRCZ4-m0z work at all? I just want to be sure before I spend anymore time trying to program mine. I can get the Hub to recognize the controller (as a remote control like everyone else). But after that I can’t seem to find any way to receive commands from it.

Has anyone got any suggestions?


(Ian D) #13

I’m not sure what I did but I have been able to pair it and it appear as a “Z-Wave Remote”. I can’t seem to be able to do anything with it under that device type, but then I’ve set it as a “Z-Wave Switch” and I can at least use the top button as a light switch. The other 4 buttons are useless for now.


(Wil Schroter) #14

How did you turn it into a switch?


(Ian D) #15

You have to go in the Developers section of this site, log in and then click “My Devices”. Somewhere in the list you will see your remote. Click on it, then on the “edit” button at the bottom of the page. From there you should be able to select a different device type for it.


(Wil Schroter) #16

Ian how do you program the button on the Scene Controller (or the Dimmer Switch in this case) to specifically point to the device you’d like to turn on?


(Ian D) #17

I’ve only been able to use the top button. What I did is that I’ve first paired the device with the ST hub by simultaneously pushing both buttons 1 and 3 (from to top). The ST app discovered it automatically as a generic remote control. I’ve tried programming it just like an Aeon Minimote, but it didn’t work. So I’ve went into the Developers Tools and I’ve changed its device type to a Z-Wave Switch. From there the top button worked just like any Z-Wave wall switch. The other buttons don’t do anything at this time, but at least the device is not totally useless.


(Wil Schroter) #18

Ian how did you assign what that button actually does? I want mine to control a plug in module on/off.


(Ian D) #19

Once you change its device type to a “Z-Wave Switch”, it will work just like any other switch. You can, for example, use “The Big Switch” app to make it turn on/off your plug in module. To change the device type, if you have not done this before, you have to use the “Developers” section of this site. You can’t do this in the iOS/Android app as far as I know.


(Wil Schroter) #20

Can you point me to that app? I did a search and can’t seem to locate it.