Vizia rf+ VRCS2-MR 2-Button Controller

It would be great if the inclusion behavior was predictable and repeatable.
I’m sorry it didn’t work for you- you re-included the buttons again as well right?

I should mention that I had to do the old mains shut-off trick too at some point in this process (before 1st pairing) as it wouldn’t reset initially. Also typical.

Oh- and I factory reset each button before 2nd inclusion too. I’d try repeating the process but I’m afraid to touch it since it appears to be working…It will likely blow up in my face at some point in the future anyway and I’ll get to try it again! :smiley:

Thanks for the added info! Yeah, I added the buttons again. Did you delete the old devices before or after you re-included? Also, you said you reset each button – how did you do that? I’ve only been able to get blinking red by holding down both devices at once.

I’ve been wondering if there are different rev’s of the device in the wild, given the diversity of different people’s experiences.

If I hold down the individual buttons themselves they will also flash red. I don’t honestly know if it is any different from holding both down together- but when you are desperate…
I deleted the old buttons after I re-added the device. Didn’t affect anything as far as I can tell.

My VRCS2-MRZ was installed in 2011. And as far as I know it has not been firmware upgraded (if this is even possible), unless it happened behind the scenes at some point. I have a Leviton control stick that I used frequently when I couldn’t get Vera to program the Lev devices the way I wanted so, maybe?

That, however, is another really long story!

In case anyone else is reading this, and it’s helpful, here’s some additional corroborating evidence that there exists a mode where the VRCS2 loads are included, but the original “factory default” button->load association persists: here are the instructions for getting this behavior on a Vera: http://forum.micasaverde.com/index.php?topic=23497.0

The Vera also knows about scene controllers (SmartThings does not), so there is another method for getting things to work where you associate the scene controller buttons with the loads via the Vera controller (http://forum.micasaverde.com/index.php/topic,13251.0.html). The reason that even Vera people want the direct association is that it is faster to respond and works even if the Vera controller flakes out. For SmartThings, at least with the current level of software support, preserving the “factory” association would be the only way to get the buttons to do anything useful, and it sounds like @jensed did manage to get it to work this way… somehow.

It is unclear if SmartThings has the right degrees of freedom to accomplish this inclusion process in a deterministic way (even on Vera it appears to be partly stochastic). From the Vera forums, it seems that the critical thing is to not let the Vera “configure” the controller portion of the device. Interestingly, SmartThings shows an option to “tap to configure” the controller after you include it, and its possible to skip this step (at which point it shows up in a list of “Yet to Configure” devices). Unfortunately, for me at least, skipping this “configuration” step didn’t change anything, but I did go so far as to cut the circuit breaker (as in the Vera instructions) yet.

In general, I wish there was greater clarity about what happens during a “configuration” (and also, exactly what state changes during an exclusion, inclusion, etc.). I get the impression that the whole stack is full of leaky abstractions and weird corner cases where past configurations persist in spite of resets, exclusions, etc. I feel like I don’t have an accurate internal model of the Z-Wave stack that enables me to understand why tripping breakers at those stages would make a difference. If anyone knows about decent Z-Wave documentation, I’d love to understand it better.

After struggling a lot with the first of 4 VRCS2 i was installing yesterday, i noticed what worked for me so that both switches in the VRCS2 can be controlled with ST and with the physical buttons.

I don’t remember how many times i factory resetted the VRCS2, but I never excluded it from the network. I simply couldn’t do it. But i didn’t need to. I started the amber led process with both buttons simultaneously (pressing them for ~10 seconds, and kept them amber blinking) and then pressed the big + on ST app. It found two Z-Waves Remotes, which I added for the time being. Next, I started the amber blinking process with each button at a time (pressing each one for ~7 seconds and kept it blinking) and after a while it found a Z-Wave switch which I added and named accordingly. I repeated this last step with the other button and now I have the two remotes and the two switches added. After that I removed the remotes and everthing works fine.

The only funny thing is that the leds on the button turn green when the loads are ON, and turn off when the loads are OFF. But I can live with that.

I hope this helps anyone.

I’ve now gotten to the point where I can deterministically pair and repair the VRCS2 while retaining the association between the physical buttons and the loads. I wish I could guarantee that what I did will work for you, but it does work reproducibly for me. Your mileage may vary.

Steps:

(all of these steps done with the SmartThings hub only a few feet away from the device. this is important)

  1. Exclude the device if it has been previously included in any previous Z-wave network. To do this, press and hold one of the buttons until it blinks amber (~5 seconds). Then put the SmartThings app/hub into exclude mode (see other posts or above for details). It’s important that the button be blinking BEFORE you put the hub in exclude mode. In general, much weirdness can be avoided by always putting the device into amber blinking mode before setting the hub.

  2. Do the other button the same way, then do the “remote” / controller by pressing both buttons together until they blink amber and then exclude.

  3. Reset the VRCS2: hold both buttons until they blink red.

  4. At this point, it’s not really fully reset – you need to cut the power to the device by tripping the breaker. This step is essential. I did a Z-Wave network repair during this time and waited 10-15 minutes.

  5. When you put the breaker back on, the device should have it’s default association present (pressing the buttons will control the loads individually). I noticed that if the VRCS2 is fully reset, the button momentarily blinked red when I pressed the buttons.

  6. Associate the “controller” by pressing both buttons together until they turn amber, and then adding from the SmartThings app. Again, order matters here. DON’T press the “tap to configure” option – we don’t want this controller device to be configured, and we’ll delete it later. If you configure, it can break the association between the controller and the loads. We want this part to stay factory fresh.

  7. Associate the two buttons on at a time by holding them until it blinks amber and then adding in the ST app. DO tap to configure these.

  8. After you’re done adding the two buttons, verify that the physical buttons both still control their corresponding loads. If it works, you’re golden, if not, start over completely. It works deterministically for me, but YMMV.

  9. Delete the “remote” from the ST app by going into preferences and deleting it. ST doesn’t support scene controllers anyways, so this is a useless entry.

  10. If your setup is like mine, everything should be working nicely at this point. I found that I could repeat this process and get the same result.

1 Like

So glad you got your VRCS2 (big mouthful there) working- and figured out why. Great job!

Thanks, @jensed – your mention of cutting the power made the difference. It’s nice to be able to turn on and off the lights again. Good luck with your home automation adventures!

So reading through this, you guys ultimately got the 2 switch capability working, right? I don’t care about the scene ability, I just want 2 switches in the single gang spot.

As do I @bmmiller … but I am having a hard time finding the device when I search for it in SmartThings. I’m not picking a device type, just “Connect New Device” and it searches forever even with both lights blinking Amber on the Switches.

I would stick with only attempting 1 at a time. Did you try these instructions?

[quote]Some clarity on the pairing process after some trial and error:

Pairing:

  • Push and HOLD the top button for 5 seconds - The LED will go amber - Now you can pair it with your hub. It should show up as a “z-wave switch”
  • Push and HOLD the lower button to repeat the above pairing for it.

Push and HOLD BOTH buttons for 5 seconds and you can pair it for the “remote mode”. I haven’t found a use for this yet with Smartthings.
Reset:

  • Push and HOLD BOTH buttons for 15 seconds and both LEDs will blink red. That’s a factory / pairing reset.[/quote]

You might already be in a “bad” state that requires resetting. I don’t actually have the device so I’m not really much help. Mostly posted to see if it was okay if I purchased one.

I was thinking that, but it happened with (2) brand new units, right out of their sealed boxes. I did go through the procedure to reset one of them and confirmed that the lights flash when I hit the button to control the local load.

All of that works … they are just never found by the hub. And I have a Jasco 45609 switch 10’ away from the Vizia, so distance should not be an issue.

Usually when I pair a device, I set it to pair immediately after choosing Connect New Device from the app. This seems to have the best results. Since you have other paired devices, I assume you are just doing what works with those?

Another poster mentioned it having to be close to the hub, not just another switch. Maybe try moving the hub, temporarily, very close to it, assuming you can get ethernet there as well.

I usually set to pair and then hit the connect. I’ll try it the other way around.

Moving the hub is very … very … very inconvenient. But that brings up an interesting point … is the hub doing the pairing only directly? Why would it matter if it uses the entire zwave network to do the pairing?

I’ve certainly done pairings away from the hub, but it depends on the version of protocol that the device uses.

I believe I read something that @urman had mentioned about older protocol versions being required to be very close to the hub. He had said that it was previously seen as a security feature. Not knowing anything about these devices and what version they may have, I’m really just guessing at this point. If it were me, I wouldn’t go assuming that for these until all other options had failed.

So, there were enough positive results listed that I went for it. I used @david_daniel_cox most recently listed method first, not moving my hub. I had very bad results where it kind of connected once (the remote) but then nothing else ever really happened. I struggled for about an hour with this, trying to exclude it and readd it, and never even saw it again or had a successful unpairing of whatever ghost remote initially reported found.

I caved and moved my hub to about 5ft from the install site of the switch. I happen to have ran CAT6 in many of the rooms in my house so this wasn’t a huge issue for me. I didn’t attempt trying to find the range of this pairing as I had already wasted enough time and just went for right next to it basically. After doing this, I was able to get everything working based on his method. I did pair 2 remotes (didn’t configure) based on someone else’s suggestion though. One of the local buttons then failed to work, but worked remtoely. I then just removed the local button device only (maybe also excluded it) and then readded it and everything works fine for the most part now.

The only thing that’s a little wonky that I’ve found is a local press doesn’t seem to update the status in the app. Manually selecting refresh does update the status though. Might be worth making a customized device type that polls every couple minutes automatically. Anyone else see this?

(I did move the hub back to it’s home and the switch still works fine)

So to report back after a few days, this is still working pretty fine. I wish the LEDs were blue to match other switches in the area, but it’s not a huge deal.

The only thing that’s a little odd is the top button, only occationally, when off and locally pressed to on, enabling the LED, and then remotely turning it off via the app, doesn’t turn the LED off. The bottom button works fine. Going back and hitting the top button locally, JUST turns off the LED, and doesn’t turn off the load (since it is already off, it doesn’t toggle it back on). Then hitting it again, turns on the LED and turns on the load and it’s back in sync. I don’t really understand it, and it’s still not a huge deal as the only thing that is “broken” is the LED feedback at the device itself.

Just thought I’d mention that, and curious if anyone else has seen this? @david_daniel_cox ?

My LEDs do the right thing, though I do have lingering troubles where the hub gets out of sync with the state of the switches (i.e. it won’t turn on the light because it thinks the light is already on). Sort of frustrating that so much tinkering is required to enable even the most basic and obvious of interactions (e.g. motion detector -> light turns on). Overall, Z-Wave, SmartThings etc. are, and continue to be a giant bag-of-hurt. YMMV.

It’s ironic that Smart Things supposedly has a partnership with Leviton and yet these switches still don’t work flawlessly.
As an FYI, if the lights do get out of sync you can hit the refresh button in the app and that usually fixes things for the moment. It is a pain.

I am able to get the z-wave remote to join and the top button but am having a hard time getting the second button to be included. With just the top button added. I can see the states change when pressing the button. They are also indicating backwards from what is physically happening. The commands from the ST app do not control what I have connected to the top button. This is frustrating.