ZigBee HA Dual-Relay Controller vs. Leviton VRCS2-MRZ Vizia RF?

I just came across this ZigBee HA Dual-Relay Controller :


I’m looking for any alternative to my existing Leviton VRCS2-MRZ Vizia RF 2-button load controller because it is just not reliable. First it’s a PITA to include, and every few weeks it just stops responding to commands and I need to trip the circuit breaker to wake it back up again.

Based on what I’m reading, this device would be a good replacement, and it’s almost 1/2 the cost of the Leviton. It’s also a ZigBee router/ range extender.

Anyone have any experience with Smartenit stuff in terms of quality, or have any of their ZigBee devices in ST?

Should have done a search first:

@johnconstantelo, I realize your post about vrcs2 is years old at this point, but hoping maybe u can help… I’ve had this device working fairly well for a few years, but as you mentioned- it often stops responding. In the past, I nuked it completely, then fought like hell to add it back. That’s a torture. You mentioned that you trip the circuit breaker to wake it… can u give any more detail on that? Was it a simple trip the breaker, keep it off for a minute, then put it back on? Mine needs to be ‘woken’ now, and the circuit breaker didn’t help. Thanks for any assistance!

Hi @merrick777, yup these devices are a PITA for sure. I still have mine, but it will soon be replaced with Zooz’s new double switch device coming out in November (I hope).

So yes, all I do is trip the breaker in our main panel to get the device to start responding again; but to be honest I haven’t done that in quite some time. It’s been working very well ever since I moved over to primarily zigbee devices. I attribute that to having only 12 zwave devices left (mains powered and acting as repeaters) and having my zwave mesh healthy w/no devices hammering it with power messages, etc. In fact, the fewer zwave devices I kept getting to during my migration, the better and better my zwave devices and mesh performed.

Anyway, when your device woke back up, did you have any type of quick power drop or surge? I’ve had mine “recover” when those things also happened when road construction kept taking down power a few months ago.

Thanks @johnconstantelo. My problem is that I’m having trouble waking it right now… it stopped responding a few days ago, and shows in the IDE as Inactive. I tried cycling the circuit breaker (leaving it off for few mins) but device is still unresponsive. Usually when I play with this thing I need to bring the hub downstairs and place it real close… is that the case when doing a power cycle also?

That’s the other thing I hate about that device is that it needs to be a foot or two from the hub when joining. It doesn’t need to be that way when you power cycle it.

Do you have a v2/3 hub? If so, as painful as it sounds, I’d remove the 2 devices, and the scene controller created in the beginning, and re-add them. With all the firmware updates impacting zwave “stuff” on our hub, I recall doing this and gaining some stability

Yikes, I’d hate to have to remove and re-add. I would need to search around for which method works (as you know, most attempts fail). Do you have a semi-reliable method? Hub v 2.

Yeah I know, hence my wanting the new Zooz device (even though it’s zwave).

The last 2 times I’ve had to do this were successful, so here’s how I did it. I kept this post handy:

and this document starting at step 8:

I pretty much followed Leviton’s step by step directions, and it worked because I think my hub was literally touching the device. First I added the scene controller, and then the 2 switches. The light indicators are wonky, and they always have been since I don’t have a Leviton controller to screw with it, and/or a custom DTH for this device.

So yeah, it’s a PITA and first on my list to be replaced.

LOL, FYI while writing this reply our neighborhood just lost power again due to road construction and Duke just called my cell saying it will be 3 hours before restore! Thank goodness for my mobile hotspot, but sadly my hub will be down shortly…

1 Like

Ughhhh, 2 hours later- I’m finally back online. @johnconstantelo, thanks so much for the help!

1 Like