IKEA dimmer button edge driver

I’m in the process up reinstalling everything and have trouble with this IKEA button, it’s called a dimmer.
It’s 2 buttons, with a option of each button been pushed or held.
It finds and installs with a edge driver, but no buttons work, I’ve tried setting as a ZigBee button and IKEA button, but nothing works.
Is there a dedicated edge driver for it???
Care to share. :slight_smile:

There are, at least few of them. Have tried to delete and install device again? There might have been some error in the install process.

Multiple times on 4 switches.
Be alright if I could use a older groovy driver that I know works, but I can’t even do that…

Ok. There could be some deeper issue here. I’ve seen lately few other posts about not getting Ikea buttons to work. I have few for myself I could check if I can pair them again.

On the advice of Samsung, I’ve reset my hub as presence sensors were not polling, they’re still not…
First time dealing with edge drivers, IKEA devices work apart from these bloody dimmers, smartthings plugs not showing watt usage and god know what else I’ll find as I go on.
I some how suspect a hub issue, it’s a V3 and a few year old, a few week ago I had lock up, then 3 mobile phones refuse to work as presence sensors.

I have V3 hub also. I’ve been having loop of active/inactive states and that could last as long as I power cycle the hub. Otherwise no problems with Edge drivers. I’ve been using them since Beta was published year ago.

Is your IKEA button similar?
image

id: “IKEA of Sweden/TRADFRI on”
deviceLabel: IKEA Remote Control
manufacturer: IKEA of Sweden
model: TRADFRI on/off switch
deviceProfileName: two-buttons-battery

I’m using Edge driver from
SmartThingsEdgeDrivers/drivers/SmartThings/zigbee-button at main · SmartThingsCommunity/SmartThingsEdgeDrivers · GitHub

That is definitely the one.
Stupid question time.
How do we use that code?

You need to enroll to the Smartthings channel and install driver from there. Super simple.

If alll this is new to you then I recommend checking this out.

That’s exactly what I did, it didn’t want to play.
I’ve reverted the buttons back to a IKEA device handler and managed to get them working.
I’ll try set the other up as a edge driver again

Unfortunately that doesn’t work for me.
Doesn’t respond to button pushes.

I’m wondering if it cause I’ve never update the buttons firmware as I don’t have a IKEA hub.
That’s the only think I can think of

try to start the binding process on the button, it will put the button to another Zigbee group. see the manual for this, but I believe it’s just hold the linking button for 10s

Hello, i dont know if youve found the solution yet, but i had the same problem.

I had to remove the ikea dimmers off smartthings. Then i had to remove the official zigbee button edge driver through the channel. I installed the ikea dimmers with the old dth drivers. They worked with the old dth drivers. I then removed the dimmers again and reinstalled the edge zigbee button driver. Re-added the dimmers and the buttons are finally registering.

Maybe you can just get away with just reinstalling the edge zigbee button driver and readding the ikea dimmers.