Problems with my SmartThings button after switching to IKEA bulbs


I need the collective wisdom of you wise souls to help me figure out whats going on with my SmartThings button.

Background: I’ve had the SmartThings button working for a couple of months now. It was configured to switch on dumb floor lamps via 2 Meross smart plugs. 1 press for on, 2 presses for off. Simple and worked perfectly. I should note, this was configured via the button itself.

Changes: On Monday last, I (finally) managed to get into IKEA and got some of their kit. For the 2 lamps in question, I removed the Meross sockets and replaced the dumb bulbs with 2 x E27 IKEA bulbs. I also removed the button press configurations and replaced them with automations. Now, 1 press of the button switches the light state (off -> on and vice versa) while 2 presses of the button. (I have similar automations for my bedroom button coupled with 2 Innr bulbs working really well.)

Issues: Last night, I went to switch on the lights via the button as I normally would. Nothing, no response. Seemed a little odd cos I’d checked it yesterday morning and it was working fine. Played around with it a bit and I could get no reaction from the IKEA bulbs via the button. Neither single nor double press triggered any response.

Now today, I looked at the logs and dont see anything obvious in there however the button is working again perfectly without me doing anything. I did notice that battery reporting of the button seems to be all over the place but I know this isnt an exact science so I’m guessing this isnt the issue. (Battery % yesterday had 4 data points ranging from 94% to 83%. Today it started at 64% and is now up to 89%.)

Can anyone suggestion how I go about getting to the bottom of this? I dont want to blame the IKEA bulbs but the button worked perfectly up to this and the same automation is working perfectly in my bedroom.


Have you had any logged events for the button at that time? It could have been an issue with the button or with your Internet connection, maybe with the cloud.

Yeah, I have the logged events from the button but then nothing from the bulbs.

A not particularly useful update is that everything is now working again without me changing anything. Not sure why the odd behaviour started or stopped but all is good again now.


Be ready for the original battery in your button to fail spontaneously. I thought my button was totally busted because the battery level showed just fine until it suddenly stopped working and dropped from the network. The last thing I tried was a fresh battery, which to my surprise was the fix. Never suspected it since it never showed low.

1 Like