Hue connect requires hue hub update?


(Jason "The Enabler" as deemed so by @Smart) #1

Ok, for reasons I will not go into here I took my entire system down last night. I disconnected and deleted everything.

I’m trying to connect my Phillips veer one hub to ST and I keep getting the screen below.

The hue hub says it’s up to date. I reset it to factory settings and tried to force an update.

As you can see the bridge is working. It find and controls my Phillips lights.

What now?


(Mike) #2

The joy of the cloud is that they can break stuff without even updating your hub. This is a known issue and they are working on it. Send your issue to support and they will add you to the list and notify you when it’s fixed.

Basically all the connect apps check the firmware version in the same way and they did something on the server side to break that call


(Geko) #3

(Jason "The Enabler" as deemed so by @Smart) #4

St or Phillips support?


(Rudi Prunzel) #5

Yep, this has been discussed in several Topics already:




(Jason "The Enabler" as deemed so by @Smart) #6

Holy crap I hate the search engine here. You can do a hundred different searches and get different results each time!


(Mike) #7

ST support will do it. Use the support email link in your app


(Chris Johnson) #8

for what it’s worth… i found this (your) thread from google as the first result for this search term “community smartthings hue connected upgrade needed” :slightly_smiling:


(Jason "The Enabler" as deemed so by @Smart) #9

Awesome! I’m glad I could help… even though it probably hasn’t led to a resolution. I did file it with support and they gave me the same thing we’ve always heard… and to claim Tom Hanks in the Money Pit…

“When will it be fixed?”
“Two Weeks!”


(Chris Johnson) #10

Yeah, I’ve piled on another support request to them for this… not that it’ll be resolved more quickly!
I just built 2 more light strips but can only control them from my hue app. I hope they fix it before my remote control (z-wave) arrives! Two weeks isn’t bad… not like its a huge problem.


(Chris Johnson) #11

They contacted me saying it was fixed… I tried, wasn’t fixed. They’ve ‘re-opened’ the issue, so stay tuned…


(Jason "The Enabler" as deemed so by @Smart) #12

Yeah, I got that email too… Appropriately the day after I find the workaround, with some help.

I haven’t tried it since teen, mine is working flawlessly and I don’t see a reason to redo it.


(Chris Johnson) #13

Workaround? Please share!!


(Jason "The Enabler" as deemed so by @Smart) #14

Do you still have the hue connect app installed? Or are you needing to do a complete install?


(Chris Johnson) #15

Still installed. I’m just adding some custom built light strips (which I’ve done with ST before the issue came up)


(Jason "The Enabler" as deemed so by @Smart) #16

go here and it will fix it.


(Chris Johnson) #17

Thanks! Will look this over and give it a try after a code review :wink:


(Jason "The Enabler" as deemed so by @Smart) #18

no problem. i copy and pasted straight from api