Upgrade needed! but can't update


(Jesse Romero) #1

I am trying to add another device to my hub however I keep getting “Upgrade needed!” message when I go to upgrade hub there is no option to. Everything else seems to be working just fine. If anyone knows what to do please let me know.



RELEASE Generic Media Renderer (DLNA Speakers). Cheap Sonos Alternative (Update V2)
(Ryan) #2

I am having the same problem. Do you have the 14.99 hue white bulbs? I didn’t see the upgrade message until I added 4 white bulbs and a dimmer switch , not sure if that’s the problem or not.


(Jesse Romero) #3

Nope, I currently do not have any hue bulbs


(Jesse Romero) #4

I also get this error when trying to add Bose or Sonos Speakers, Philips Hue Bloom, Light Bulb and LightStrip, Belkin WeMo Motion, Switch and Light Switch.
I also seem to get a defferent error when trying to add a Samsung SmartCam HD Pro “HUB VERSION ERROR!” saying i need a V2 Hub, even though I have a V2 Hub.
Not sure if this is just an Andriod Moblie App issues or something, however I made sure to clear cache and reinstall the app… Still no luck.



(Ryan) #5

Sorry just noticed your first post was of wemo not hue . Well I get that same message in the hue app. And can’t add anything . This is obviously a another Smartthings cloud problem. Now how do we fix it


(sidjohn1) #6

Report it to support:
Support@smartthings.com


(Midhun) #7

I also got the same error. I got this while trying to install the custom app DLNA player. Looks like it is a ST standard error, nothing to do with the specific device or app.
Contacted Support. Here is what I got from Support. So, I wait…

Thanks for reaching out! I’m sorry to hear that the app is incorrectly asking you to update your Hub.

We’ve had other reports from users with similar issues. We’ve notified our developers that you’re experiencing this issue as well.

I’ve tagged you so once we get this fixed, we can notify you right away.

Kind regards,


(@rnel) #8

Same problem here for Wemo and Hue.


(Tony - SmartThings Unpublished Contributor ) #9

Same issue here. No matter what type of hue connect app I try, it gives me the same error.

This type of problem is ridiculous.


(Jesse Romero) #10

Ya its very annoying, just make sure to report it to Support@smartthings.com the more people that have an issue the more likely they would be to prioritize it. At least I would hope.


(Tony - SmartThings Unpublished Contributor ) #11

I’ve done that.

However, I have little hope that this will be fixed anytime soon. My feeling is based on the fact that this error reminds me of the dreaded 2014 “ghost” hub issue (for several reasons):

  1. Its a completely server-side problem;
  2. It affects a service that worked perfectly prior to the server changes;
  3. No reasoning was provided for the cause;
  4. No date is provided for the cure;
  5. No change to the hub hub occurred in between the changes…

I have consistently been a big supporter of the ST platform. But this is really, really frustrating.

Seriously, how hard is it to not F&$% with something that has worked perfectly for close to 2 years???

Oh, there’s one more similarity:

  1. I’m going to be very, very vocal about my displeasure about this problem until it is fixed (suggestion #1 - just go back to what you had 10 days ago…).

(Rory) #12

Same issue trying to add Sonos devices. Has anyone with an open case gotten any responses?


#13

I got a response from Tech Support yesterday saying it’s already fixed but they’re testing and expect a few days until it’s deployed for everyone.


(Lance) #14

Having same issue with Sonos (Connect)


#15

It should be fixed tonight or tomorrow.


(Lance) #16

Via app update or firmware update?


#17

Neither, via a magical cloud update.


#18

I got an email stating that its resolved already and it is not. Same error messages on Sonos Connect and Hue Connect apps.


(Bobby) #19

Happy fingers syndrome! They clicked send before they ran the all mighty cloud updates…


(Bobby) #20

So @Tyler is this part of the magic too? C’mon guys if this is not ready for public, why is it on my dashboard? Shouldn’t this be seen on an alternative magical universe called “cloud testing” server?