Removed Hue Bridge, now cannot re-add it (Also affects Sonos, Netatmo, Wemo, DLink Cameras)


(Jim) #1

Tonight I got 3 new hue bulbs, and added them to my bridge without issue, but they would not show up at all in smartthings. After playing around with it I ended up removing my Bridge, and now I cannot re-add the bridge. When I try to connect to a new philips bulb or open the Hue smartapp, it says that my Hub needs to be updated. As far as I can tell my hub is up to date, I have tried rebooting it several times and pressing the red button. Here is what it shows me…
http://imgur.com/pZk4OLZ
There is no option to update as described.


Hue connect requires hue hub update?
ST V2 Hub can't discover DCS-2330LB1 camera
(Cyril Peponnet) #2

Same here… I don’t have any hub update option as described.


(Cyril Peponnet) #3

Notet that I have the same behaviour with several other smartapss… Another smartthings quirk? @slagle ?


(Cyril Peponnet) #4

Looks like hasAllHubsOver("000.011.00603") is not working when version is 000.013.00013.

On my side, stopped working:

  • Hue Connect (even my fork)
  • Netatmo

I think your hasAllHubsOver function didn’t get through the QA correctly :stuck_out_tongue:


hasAllHubsOver is broken
(Mike) #5

Aha! I was hoping someone else would have this problem. I’m seeing this with the Sonos Connect app (does the same hasAllHubsOver call) which when you go through the code, it just does a string compare which does work “000.011.00603 <= 000.013.00013” IS true. The problem seems to be, at least on my system, is that the check for the hub FW version checks every hub attached to the location and for some reason lately now I have a “Virtual Hub” associated with my location with a FW version of 0.

The check doesn’t fail on the actual version, it fails because the “Virtual Hub” has a FW version of 0, so it will ALWAYS have a lower version than the check. Either the code needs to be changed to check for location.hub.isphysical or the virtual hubs need to be removed.

check and see if that is your problem too.


(Jim) #6

I sent an email to support as well, and got this as a reply. Does this sound like it fits with what you guys are seeing as well? I don’t think I have a virtual hub on my account. My hub is currently on 000.014.00026

"Thank you for replying. This is something that has just come up and is happening with other service managers as well (Hue, Wemo, D-Link cameras). It has to do with the way the service managers recognize the Hub when attempting to integrate, so resetting the Hub won’t affect anything.

This has been ticketed as a top priority, so we should have a it taken care of soon. I have tagged your account to the open ticket so I can follow up with you as soon as it’s been resolved. I appreciate your patience."


(Ryan) #7

Yup had this problem for over 2 days now . So your not alone


#8

This is now being tracked in the community-created wiki under known issues:

http://thingsthataresmart.wiki/index.php?title=Bug:Cannot_re-add_Third_Party_service_manager(Hue,_Wemo,_etc)


(Mike) #9

The only way I was able to see it was by creating a smartapp that prints out the hubs and their fw versions when a light switch is turned on


(Yazz) #10

I just check in on my Smartthing and all of my WeMo switches are offline, 4 total. I wonder if some update happened that caused this. I can use the Android WeMo app and control them just fine.


(Rudi Prunzel) #11

Same issue here since last Friday (1/29). I did open a support ticket yesterday and got the same response.


(Jim) #12

I suppose I am being naive since despite all the horror stories I read about ST, this is actually the first major issue I’ve run into, but I really don’t understand how they can just let an issue such as this go this long without being fixed.

This has really got me in a bind because of the way my lamps are set up, I was relying on ST to control them, and they are the main sources of light in my home. Now I’m having to juggle two apps to control them manually, and I’m not going to even bother trying to explain it to my family.

I really hope they fix this ASAP.


#13

I have the same issue with my Wemo switches. See post: Can't add Wemo App to Smartthings


#14

What surprises me most about the WeMo issues is that with all the complaints of flakiness and general instability, no enterprising dev has created a Device Handler for local control. Back in my WeMo only days, I used an iOS app called “QuickSwitch” that could autodiscover WeMo devices on the network and control them farm more quickly than the stock WeMo app. I suspected, and confirmed with the dev yesterday, that the reason responses were so quick is that he was just addressing the devices directly across the LAN instead of bouncing commands through the cloud.

A quick google tells me that other folks:
http://moderntoil.com/?p=839
https://github.com/issackelly/wemo/blob/master/

Have created local WeMo control methods.


(Jim) #15

I haven’t heard anything further from support on this issue. I’m just over my 30 days, but honestly if this isn’t fixed by tomorrow, I am going to ask them to allow me to return the device. I just can’t be reliant on a cloud service if it’s not going to work.


(Matt Habermehl) #16

I’ve run into exactly the same issue with my WeMo light switches. It’s disconcerting that an integration like this can just break and sit broken for over a week, considering that such integrations are SmartThings’ raison d’être.
Any update would be appreciated, SmartThings people!


(Jim) #17

I appreciate your patience while we get this worked on. Right now we have an update scheduled for early next week that should resolve the issue, so keep an eye out for it. You’ll be notified once it becomes available.

I feel the same way as you and was getting kinda antsy after not hearing anything for a few days, so I responded again to my support email and asked for an update, quoted above is the response I got from one of the ST engineers. I hope that it’s accurate, but I’m taking it with a grain of salt because I am pretty sure I read in another thread that someone else was told the end of last week.

One thing I am not clear on though, is if this issue is affecting everyone, or only people who have unpaired and need to re-pair their bridges. The other day I considered just going and buying a brand new hub and seeing if I could get it to work, then returning my current hub. I ultimately decided against it though, for now I will just try to not think about the several hundred dollars I have invested in the platform while it sits dormant awaiting their fix. Hopefully they will get us working again sooner than later next week.


(Matt Habermehl) #18

Yeah I had read the same thing about the end of last week. I’m in tech so I can appreciate the panic caused by unanticipated outages of various sorts. I suppose they have to go through their due process and do QA and testing prior to deployment. It’s a balancing act between wanting to fix quickly the things that people depend on in their daily lives and wanting that fix to be secure enough that it doesn’t do worse damage to consumers and SmartThings’ reputation.

I have a few integrations and I only noticed this problem when I uninstalled the WeMo integration in order to try to fix what seemed to be unreliable results with ST. I also have hue bulbs but I won’t be touching that until this gets resolved - they seem to work more or less ok still.


(Andrew ) #19

This isn’t only in issue with people who are trying to re-pair a bridge, I got some new philips hue’s and was trying to add the new one in and get the error when just going into hue(connect). Also was having issues with a couple of wemo’s and went into memo(connect) and get the same message. So as far as i can tell it is everybody. Hopefully the info you got from smart things holds true.


(Jim) #20

We are now approaching the end of the week,still nothing. There is also now a new SmartApp issue on Android that began yesterday and is still ongoing. I really hate to say it, but I am gonna start looking for another platform.