hasAllHubsOver is broken


(Cyril Peponnet) #1

Continuing the discussion from Removed Hue Bridge, now cannot re-add it:

Looks like hasAllHubsOver(“000.011.00603”) is not working when version is 000.013.00013.

On my side, stopped working:

  • Hue Connect (even my fork)
  • Netatmo

I think your hasAllHubsOver function didn’t get through the QA correctly :stuck_out_tongue:


Upgrade needed! but can't update
Hub version error
Hue connect requires hue hub update?
(Mike) #2

I’m having this issue with the Sonos Connect, check that location.hubs doesn’t contain a virtual hub with a FW version of 0. On my system that is what is making the check fail.


(Mike) #3

I’ve sent a support ticket in for this issue, but if past experience is a guide, I’ll hear back in a few weeks and by then something ELSE will be broken wierdly.


(Zpriddy) #4

Same

Maybe we can get some help with this @april


(April Wong) #5

probably the wrong person these days. :slight_smile: I work on Events. @slagle @jody.albritton are your two friends.

<3


(Jody) #6

PM me with the ticket numbers and I will track it down. This issue is currently being tracked by the engineering team so any more information I could provide them would be useful.


(Tim Slagle) #7

It’s on my radar. Sorry guys :frowning:


(Zpriddy) #8

Thanks @slagle & @jody.albritton ! I haven’t submitted a ticket yet… In my experience it has usually been faster and more informative to reach out here.

Thanks!


#9

I have already emailed support. Waiting. Support request #186431

Just bought Sonos Play1 and im getting same error. same screenshots. My hub upgraded to latest firmware 1-21-16!


(Jeffrey) #10

Any update on this? Seeing same problem adding Roomie connect


(Jody) #11

Reaching out here is fine, but submitting a support ticket allows us to gauge the severity of a given issue and prioritize support. Submit one if you can.


(Cyril Peponnet) #12

Well most of the smartapps using this function just refused to load anymore. Sounds enough severe to me. You have serious QA issue :slight_smile:


(Jeffrey) #13

I submitted a ticket. Said it will hopefully be fixed in 1-2 weeks which sounded a bit long too me but I just tweak the code to work around it so it’s not the end of the world.


(Brian Diehl) #14

I got a response, but didn’t even get word that it will be fixed in 1-2 weeks. Just said others have reported it so I am tagged for an update when they have one.


#15

Same response, i’m tagged to be notified as progress is made and that others have reported.


(A. Trent Foley) #16

I got an email today saying the issue was resolved, but I still get the same message about needing a hub upgrade when trying to run the Hue Connect smartapp


(Mike) #17

Same here, and I’ve started getting red banner errors in the app. So hooray


(Cyril Peponnet) #18

No luck for me. Still not working.


(Brian Diehl) #19

I also got the email stating it was fixed, but wasn’t about to break anything I got working just to see for myself.


(Cyril Peponnet) #20

Still not fixed for me… Pfff this is freaking long now…