Hub Firmware Release Notes - 20.17


(jkp) #122

Try rebooting it. When it starts back up, it should contact and check for updates. If that does not resolve it, you should contact ST support.

https://support.smartthings.com


(Simon Craddock) #123

What the heck is going on with Smartthings this evening, our 2 presence fobs are constantly being tagged ‘Away’ then ’ Home’ every minute. Driving me mad as I have lights on/off attached to routines.


(Joern) #124

With the new firmware I was able to re-connect my washer to ST again without any issues.

Thanks for that, nice work!


#125

Hi, I’m getting a lot of reports from members of our Facebook group that this upgrade broke the ST, we’re getting unexpected errors, have to reload device pages, sync incomplete on devices…

Tickets raised with Tanya at the UK support…


(Brad) #126

Those sound more like mobile issues than Hub firmware. There was also a mobile release this week.


#127

I highly doubt that, as a lot of people all over Europe are getting the same issue within 24hrs of a firmware update as reported otherwise here and all from our FB group are using the latest version from the Playstore.
I’ve removed and reinstalled mine without any change. This is either server och firmware issue not a app issue.
I’ve got two users (phones&pads) on my hub experiencing the same issue on 3 different WiFi’s and 3 different 4G subscriptions, which again points in a totally different direction than app/network/local issue.

The only common thing I know of at the moment is that we’re all on EU West 01 server and all got 20.17 the last 24hrs…


#128

Nope, had the same issues on two different devices, different brands, different OS versions and different app versions. Appeared today after the FW upgrade. Some DTHs (moved from cloud to local) has obviously changed, and none of the efforts from the support could resolve my issues


(Brad) #129

Which specific devices are showing the wrong state? And do you have an example timeframe when this happened?


#130

See the screenshots in the first post in this thread, I have the exact same issue. Android app errors February 1, 2018

On top of that the “Z-wave Plus Door/Window Sensor” DTH stopped working with my Door sensors, they now handle them as a motion device instead. I had to move to the Fibaro Door/window sensor DTH, which means I’m still in CLOUD execution for those


(Nathan Curtis) #131

I know this is a tad off-topic, but speaking from an IT management consultant’s perspective with over 20 years of experience… It’s a MUCH better practice to do an update during a window when there are likely to be fewer impacts to the end users, but when the support staff will be there to help is actually in the office. Otherwise, you need to pay a crap-ton in overtime to call them in afterhours OR go without the support. Soooo. The weekend is out, ESPECIALLY Superbowl Sunday weekend when everyone wants to show off the cool smart home stuff they have is out (at least in the US) and evenings are out.

Trust me, you cannot imagine the amount of screaming that would have happened if they did the update late Friday evening and not had engineering or escalation staff to pick it up until Monday.

Sounds like sometime midday when their typical customer is not in the house (probably confirmed by utilization reports off their cloud) and modified by the least possible impact to international customers is probably the best bet. So in other words, exactly when they did the update…


#132

I have same issues.
Thing list, automation screen, favourites all blank until refresh and the red banner at the top ‘unexpected error.’


(CopyCat73) #133

It’s the firmware. As a developer I would respectfully like to ask you guys to setup a stable and beta track which can be chosen, where the stable track only updates every 2 or 3 months or so. This gives the userbase peace of mind and you have more time to create more stable releases. I honestly dont see why you’d need to push beta like releases at this rate.


(Benji) #134

And you concluded this how?


(CopyCat73) #135

Because I had the new app version already, today my hub was upgraded and suddenly red popups all the time plus my things list not showing because something went wrong.


(Benji) #136

That’s not a very good conclusion.

Ultimately you might end up being right, I’m just saying that’s a terrible conclusion to come to with very little evidence to state as if it were factual and use as counter argument, against someone who actually works for SmartThings and knows a whole lot more about what’s going on than all of us.


(CopyCat73) #137

Lets agree to disagree then. Already pissed about the level of stability of this device.


(Benji) #138

OK. Enjoy!


(Steve White) #139

Respectfully, you have absolutely no scientific evidence the firmware update (the firmware itself, not the process of updating) is the reason for your issues. You simply do not have access to that level of diagnostic data. Your observations, while presented as factual, is truly just an observation based on anecdotal evidence.

20.x was in a community beta for about a month. Many here participated, myself included. These issues just didn’t come up. I’ve been running 20.x since right after New Years Day. I think the timeline is very reasonable and hardly think a 1 month test period is pushing.


#140

there is a reported platform outage right now


#141

Yup, and it also stated that it restored now and the issues seems to be gone. So it does look like something in the firmware affected the servers or vice versa…

Can the ST staff please share the RCA and lessons learned? It would be great to understand what went wrong and how we can avoid such things in the future.

TIA!