Help needed - Fibaro wall plug (old) won't send power reports

Hey,
I’m using the device with this handler.
Everything is working fine, except I’ve noticed that the device is not sending periodic power reports.
Only when I manually refresh it (using the ST app) does it refresh its power meter state.
How can I resolve it? I have a scene that should be triggered according to the device’s power state.
Any help would be much appreciated.

You may want to look at Edge drivers and ask your question in the following thread to see if your device is or can be supported…

tagging @Mariano_Colmenarejo

2 Likes

Install this driver Z-Wave Switch Mc in your hub, if you want to use new Edge drivers.

This device must works fine.

  - id: 010F/0600/1000
    deviceLabel: Fibaro Outlet
    manufacturerId: 0x010F
    productType: 0x0600
    productId: 0x1000
    deviceProfileName: fibaro-metering-old-plug
1 Like

Hi. You can use the gen 1 fibaro wall plug with the standard “z-wave metering switch” DTH

at this point, it is probably better for users to start thinking about Edge drivers over the groovy device handlers that are going to be phased out :slight_smile:

absolutely. I have not testet the old gen 1 fibaro wall plug with edge driver. Does it work? I do have 2 new fibaro wall plugs which are using edge

read 3 posts up - the one written by @Mariano_Colmenarejo

1 Like

can you please elaborate how can I install this driver in my ST?

I’ve enrolled and then in “list drivers” I don’t see any Fibaro driver

ok managed to understand, installed the Z-Wave Switch M driver. but what now? how can I link this driver to my device?
Thanks

The Name of the driver is Z-Wave Switch Mc.

  • Install the driver in your Hub
  • Exclude the fibaro device from app
  • Set the device in inclusion mode and in App add new device and click search nerby
  • New Fibaro device will appear in app after some time
1 Like

he would need to remove the custom groovy device handler after excluding the device :slight_smile:

1 Like

Thanks @Mariano_Colmenarejo and @jkp !
I’ve managed to change those 2 devices to work with the driver.
now all I need to do, is to check that power meter report works automatically.

BTW
what should I put in the “immediate power report” setting? I see the range of the value is 1-100… I don’t really understand this

1 Like

There is a problem, already reported to @nayelyz,in the preferences that does not show the description of the setting, which is this:
Maximum new reports put in 1% increments

  - name: "inmediatePowerReport"
    title: "Inmediate Power Report- 40"
    description: "This parameter 40 determines the minimum percentage change in active power that will result in sending power report.\n1-99 - power change in percent\n100 - reports are disabled"
    required: false
    preferenceType: number
    definition:
      minimum: 1
      maximum: 100
      default: 80

This is the link to fibaro manuals:

1 Like

awesome! thanks

1 Like

Hi, I made a test and I can see the description as follows:

@rotman, is it not appearing on your device? can you share a screen capture, please?

it is.
It was just difficult for me to understand… thanks.

@Mariano_Colmenarejo, I experience the same behavior with the driver… still power meter won’t update automatically… I have to go to the device and manually refresh it in order for the right power meter value to show up (and only then does my power meter routine triggered)
Any idea why?

The fibaro devices in smartthings are not normally configured during installation.

The manufacturesr default parameter settings or the last ones saved in the device are kept.

If you uninstall it and do a factory reset, you can look in the manual how to do it, it resets all parameters to default values and then pairs device again.

You can also go to settings and preference by preference by changing the values of parameters 40, 41, 42 and 43.
The value you see in preferences when the device is installed is the default value, but are not sent to device, nor does it have to match the value that is stored on the device.

I do not know if I explained well?

1 Like