Help needed - Fibaro wall plug (old) won't send power reports

Hi @Roddy_Duus,

I think I remember that you reinstalled the previous version of the app, right?

If so, that may be why it works for you.

Hi @Mariano_Colmenarejo. No actually this z-wave device was the only z-wave metering device that worked and still does work. I have 2 phones now.One with and one with This because I can’t edit most of the routines from the old app, so 2 phones is what’s working for me right now :slight_smile: I have quite a few devices. Amoung them 2 new fibaro wall plugs running on edge drivers and 1 old running on “Z-wave metering switch”. The two new ones reported incorrectly “out of range” on voltage, load etc, but the old fibaro wall plug running on DTH did in fact work. I don’t now why. The measuring does work again on all my z-wave units with metering capability. I remember @nayelyz said this was fixed due to a plug in? I still however have issues with my thermostats not working correctly. That’s why I have to use 2 phones. Here is a screenshot of my very old fibaro wall plug running on

1 Like

Ok. I have now factory reset my old fibaro wall plug gen 1 and re-joined it with @Mariano_Colmenarejo river “Z-wave switch Mc” edge driver. Power consumption does report correctly. @rotman, have you removed your old DH before joining the fibaro wall plug?

Eventually, have you tried the generic “z-wave metering plug” DTH?

1 Like

I think the best way to check what happens in @rotman’s case is by analyzing the driver logs, for the DTH, it’s hard to check the log events in the IDE because not all are listed.
It would be strange that @Roddy_Duus had the same device model and everything worked fine in both versions of the app.