[OBSOLETE] Fibaro Wall Plug (Old version, not zwave+)

I could not find a device handler with powermeter updates for the Fibaro Wall Plug.
So I put this together. Its based on the standard zwave meter switch and aeon outlet from @gpsmith
Its my first DTH so its not perfect, but its working for me.

Install the handler and remember to hit the configure button in the app

If you are looking for the Zwave+ version, this is the one to use:


Powermeter capability was missing from the published code, its now added and updated.

Awesome! Worked like a charm! Thanks a lot! :slight_smile:

1 Like

Is there a SmartApp that can go with this plug? Specifically if it draws energy above a watt then turn a light on?

I use CoRE for that:

I tried using core, just downloaded it, but it’s not working, or saving.
I tried when this smart plug goes above 1 watt then turn kitchen lights on, it saves within the app, core piston #1 saved, then I turn the plug on, nothing happens, I go back, and the piston isn’t there anymore, any ideas which error I’m doing?

After installing CoRe, do you access it from Automations > SmartApps (not via marketplace)?

1 Like

I only see it in marketplace, it doesn’t appear in Automations!
And clicking “create dashboard” force closes it.
I have android, galaxy S7

Have you enabled OAuth for CoRe in the IDE?

1 Like

Hey I just did it, thanks, I pressed “done”, then it appeared in the Automations! And I did my first piston. If Fibaro plug goes above 1 watt turn on lights. Is there a way I can also reverse it within the same piston easily? If the Fibaro plug goes below 1 watt turn off lights? Or do I need to do another piston? Thanks.

Switch Piston mode to Simple, and then maybe something like this:

1 Like

Wow that worked! It’s pretty amazing what it can do. Its a little complicated with all those variables, and all the different types of piston mode, hard to get my head around, but somehow I did it! Thanks very much!

@cscheiene do you think it’s possible to turn the light off on the plug at all? I need to put one in the bedroom, but the light is too strong.

If you mean the light on the unit, yes you can turn it off. Just hold the button the device, then you can toggle if the light should be on or off

1 Like

@Alwas I have uploaded a new version with the options to change/turn off the LED ring from the app

1 Like

There is a new version out with ZW5 that needs updating. I’ve been hacking a little bit to get power reports to work. I’m really new to this, so please give me some feedback. I’m especially not sure about the changes I did to the fingerprint part. :slight_smile:

Info on the new Device Handler is here: [ABANDONED] Fibaro Wall Plug ZW5

Hi there.

I just discovered your device here and as I have just bought this plug I wanted to try it. Unfortunately the logs says:

" groovy.lang.MissingMethodException: No signature of method: script1483717464911258119359.zwaveEvent() is applicable for argument types: (physicalgraph.zwave.commands.meterv1.MeterReport) values: [MeterReport(meterType: 33, meterValue: [0, 0], precision: 1, scale: 2, scaledMeterValue: 0.0, size: 2)]
Possible solutions: zwaveEvent(physicalgraph.zwave.commands.basicv1.BasicReport), zwaveEvent(physicalgraph.zwave.commands.crc16encapv1.Crc16Encap), zwaveEvent(physicalgraph.zwave.commands.meterv3.MeterReport), zwaveEvent(physicalgraph.zwave.commands.securityv1.SecurityMessageEncapsulation), zwaveEvent(physicalgraph.zwave.commands.sensormultilevelv2.SensorMultilevelReport), zwaveEvent(physicalgraph.zwave.commands.switchbinaryv1.SwitchBinaryReport) @ line 146"

Do you have any input on the error?



Hi Thomas,

It’s unclear if you used my handler (I’ve removed the code from above to avoid confusion) or @cscheiene 's handler? :slight_smile:

If you used mine, I suspect you don’t have the ZW5 version of the plug. Can you post the Raw description of the device from the web interface? Mine looks like this:

zw:Ls type:1001 mfr:010F prod:0602 model:1001 ver:3.02 zwv:4.05 lib:03 cc:5E,22,59,56,7A,32,71,73,98,31 sec:85,70,72,5A,8E,25,86 role:05 ff:8700 ui:8700


Mine is identical:

zw:Ls type:1001 mfr:010F prod:0602 model:1001 ver:3.02 zwv:4.05 lib:03 cc:5E,22,59,56,7A,32,71,73,98,31 sec:85,70,72,5A,8E,25,86 role:05 ff:8700 ui:8700

And I do believe Ive tried both version.

That’s weird. I don’t know enough about this to really say why you get those events. I only get physicalgraph.zwave.commands.meterv3.MeterReport reports.

Anyone here know how this is managed? Maybe @cscheiene has enough knowledge why this might happen?