[Edge Drivers] Cannot enter Driver Channel invitation

Cant seem to sign up for this driver. Just a constant loading screen, is it taken down?

Do I need to do anything special to enroll to your drivers Mariano? Because after I login using your link it just a forever loading spinning circle.

@Dixon

Thanks for advise.

@nayelyz Some users are reporting problems accessing the channel

@Dixon

You can try enter in app hub, driver menú
Search and click in my Channel and install driver Zigbee Thing Mc

This is what it displays and it gets stuck there for whatever reason, tried different webbrowser and also deleted cache and what not.
There is no zigbee thing mc driver on my hub unfortunately, I haven’t gotten to the page where I can enroll to your driver yet.

Hi, @Dixon.

Did you accept the invitation in the past and reset your Hub to the default configuration or something similar?

I am having the same issue trying to access this driver channel

Same result-- just the spinning loading symbol that never ends. Other channels load properly, I have made no changes to anything recently. The url is taken directly from the developers post announcing his driver by clicking the provided link. Tried other browsers etc etc, same results

Hi, @David2275!
Can you share where did you get the link from, please?

This can be because first, we need to accept the channel invitation and it has a different URL, the one you shared has /channels/channelID and this can cause the issue of the spinning icon:

https://callaway.smartthings.com/channels/6b6649e0-fa34-4dbd-af22-99736166aafc

For example, the Channel invitation of the SmartThings Beta Channel is:
https://api.smartthings.com/invitation-web/accept?id=450930c1-02a6-43d8-adaa-4cbc51027956

It doesn’t refer to the channel ID yet because the invitation acceptance and enrollment of the Hub goes first.

Thanks for your response.

The link was taken from this forum post:

I clicked the “Channel & Driver UI” but nothing loads to view enroll or view drivers. There was no other info listed in the post. Perhaps the developer needs to add further info?

I think so, let me reply there to see if he can provide the other URL.

1 Like

Hi there,
Yes thats what I did. I now made a new smartthings account and that fixed the issue.
Its not optimal but it is what it is.

Hi all,

In my case I wanted to connect my SmartThings network after some pause, starting from scratch.

I’ve reset my hub to factory settings, after adding to SmartThings app it downloads latest firmware 000.045.00011 and everything looks good.

But now I can not enter any of driver channel invitation. It’s just going to page and stays at never ending rotating circle.

I’ve tried to erase SmartThings account from app and start over, but it didn’t helped.

Any ideas what’s wrong?

Thanks in advance for help

Hi, @Tomash!
Can you help us by sharing a screenshot of the result of the steps below, please?

  1. Open the browser’s developer tools in a new tab (in Windows and Chrome it can be using the commands ctrl + shift + i) and go to the “Console” tab.
  2. Then, enter this URL in the search bar:
https://api.smartthings.com/invitation-web/accept?id=450930c1-02a6-43d8-adaa-4cbc51027956

You should see something like this:

If there’s an error, it will show up there.

Hi, @Dixon, have you had the chance to check my reply here?

Hi, answer your question, screen attached. In my case some time ago (different firmware probably), I was using Edge drivers, and they were working prefectly.

Now I can not.

Thank you, @Tomash.
I think this might be related to the issue reported here:

Could you provide support access to your account, please?

  1. Go to the SmartThings Web (my.smartthings.com)
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

Ok it is done, let me know about progress.

Thanks

1 Like

5 posts were merged into an existing topic: Unable to join channels (25 Jan 2023)

Hi, I’m facing the same issue after resetting my SmartThings hub.
When I try to join a channel with an invite link, only an infinite circle appears.
This issue only occurs with channels that I joined before resetting the hub.

For example, here is the channel I joined and registered before resetting the hub:

When I go to this link, I only see an infinite circle.
However, all of the other channels that I was never joined before are fully accessible and I am able to accept invitation and enroll.

It seems that this post is same case for me.

nayelyz did something for this case, but didn’t say what was the problem and how to solve. What should I do?

Hi, @ijoesj!

The engineering team fixed it for others, so, I’ll create a report for your case. Can you share the following, please?

  1. Confirm the email account registered in the forum is the same one you use for SmartThings. If not, please share it with me over DM
  2. Enable support access to your account:
  1. Go to the SmartThings Web (my.smartthings.com)
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.
  1. If you have more than one Hub, please share its name.
  2. Do you remember when you accepted the invitation and enrolled in those channels? An approximated date would be useful for the investigation of why this is happening.