Edge driver invitation links not working

Hi there,
Im trying to enroll to edge driver beta program? And add other edge drivers to my hub but all links I end up trying just ends up on a blank page with a spinning circle.

Tried different browsers and devices,removing cache and restarting both smartthings hub and internet router. what gives?
It doesnt seem to be anything on my end but I dont really know any better.
Anyone with insight?


Desktop or phone? If using one of those, try the other.

Thanks for your reply, ive tried several devices and browsers. None work.

You may want to report it to ST support. I just attempted and it worked.

I forgot to mention, It did work once but then I factory restored my hub thinking i would like to start fresh.
Now no links work.

yes, that is a big piece of the puzzle. contact ST support.

Do you happen to know how to reach them? Im abit clueless and now without dh my whole house is dead… haha

in the app, tap on Menu and select Contact us. If phone support is an option - you may want to go with that first.

Thank you, Ive contacted them via “ask a question” or similar. Ill try to call them tomorrow, its abit late my time now.

Hopefully someone replies while I sleep heh… this is sucj a mess

They’re just tossing me around, anyone here have any ideas what might be the cause since smartthings support apparently doesnt know.
Yikes this is getting frusturating haha…

Which hub do you have?

I wonder if it is related to the following topic which I believe started after they factory reset their hub also.