Devices offline, no fix in sight. Smartthings has acknowledged the bug


(Anders Heie) #1

About two weeks ago, some of my devides started going “offline” in the app, and in the developer console I see the same thing. Some of them would ‘recover’ when the switch was toggled. Some could even be controlled while being “offline” via Alexa voice controls that still seemed to work, although the app had lost all control of them. Still, they come and go, and I still have about 10 devices OFFLINE for now QUITE some time.

Smartthings support says they have a bug, and can’t provide any guidance as to time for a fix. They say I should go and remove then add them again (Takes LONG TIME, I have 10 smart apps on each device that would need to be setup again). Support also says other people have reported the same thing…

So what gives? I can’t run around the house and spend 4 hours fixing this. And how would I even know they just wouldn’t pop offline right away again.

Is Anyone at Smartthings working on this? What’s going on? Anyone else seeing this problem?


This device is unavailable at the moment
Battery, Unavailable, and Multipurpose and Motion Sensor Issues
More than a dozen Zigbee devices went Offline within an hour of each other
ZWave Plus dimmer shows "unavailable", yet still responds to all automations
Zwave Switch Shows Unavailable - But Somewhat Works - Help
Device is unavailable
Devices consistantly offline or on all the time
Smartthings devices keep dropping off
Multipurpose sensor going offline without any warning / notification?
Schlage Camelot: Worked for a year, then hub upgraded, now?
Hub Firmware Release Notes - 18.18
ZIGBEE Devices going Unavailable / Unable to add
Fortrezz Water Valve Unavailable
SmartThings Current Stability?
Zwave device/network issues starting in the last 2 weeks - just my hub, maybe?
Recent Platform Update Broke Parse Method Response/Result (April 2017)
(Jason Crosier) #2

I was having the same issues although they have dissappeard since the infrastructure update on or around the 12th of April. Only having issues with one osram bulb now. I will remove and add it when time allows.


(Brian) #3

I’ve experienced the same with Samsung water leak sensors, though over the last week they seem to be fine.

As you noted they would randomly show offline but when tested would always report and excite my routines.


(Zen) #4

My multisensor outlet are offline but after toggling device health to off seems are fine


#5

Yup, and I have a support incident emailed to them. I got the typical “did you do this?, that?, reboot?, yada yada yada”, and I said crapola like this just doesn’t happen for no reason, and in my experience with ST (it’s been since the beginning), it’s almost always related to something they did.

It has gotten better, like others have said, but it’s slowly been eroding my confidence in Health Check and any benefit it could provide.


(Alex) #6

Quite a few of my devices were showing up as offline and I got the impression it was devices that I did not use very often. To liven them up again I just had to cancel out the offline message and then toggle the device or even just “refresh” it. None of the devices were actually dead so removing, adding or any drastic alternative was not necessary… This is very annoying so in the end I simply turned off “Device Health” in the app. The devices may still go “OFFLINE” but it doesn’t seem to affect things (or am I missing something??) so I will just wait it out hoping they will fix it. Is my issue the same as what is being discussed here or are your devices actually totally dead?


(Anders Heie) #7

Through all this, I never realized until now that there even WAS a thing called “Device Health”. You would have imagine Smartthings support could have mentioned that. I turned if off, and the devices came back, at least in the app. Some of them don’t react to my commands, but at least I can try to repair the network, and play around a little more. Not a solution, but progress. Thanks Alex, and yes, that is the same issue.

Edit: While they don’t show “OFFLINE” anymore, the devices still don’t allow being controlled. The main difference is that now I can no longer easily see which devices are affected by the bug.


(JIm) #8

I found that if you turn off device health, devices show back up but they’re really not there. They just don’t show as not being connected.


(Anders Heie) #9

Yeah, seems that way. I sure would love Smartthings to comment on this asap…


(Oscar Calvo) #10

I have been hitting this bug with Water leak sensors or motion sensors (used as temperature sensors) in the ecoBeeSetTstatSchedule app.

When the sensor is used in the app as temperature sensor, it goes offline after 3~48 hours.
When the same sensors are not used in the app, they have been online for last 4 weeks.

Here is what I have observed:
2. I have 6 water sensors, here is the observed status:
a. Guest Bathroom Water Leak Sensor: Used by app , OFFLINE
b. Kitchen Fridge Water Leak Sensor: Not used by app, ONLINE
c. Kitchen Sink Water Leak Sensor: Not used by app, ONLINE
d. Laundry Room Water Leak Sensor: Used by app, OFFLINE
e. Master Bathroom Water Leak Sensor: Not used by app, ONLINE
f. Master Tub Water Leak Sensor: Used by app, OFFLINE
3. I have 8 motion sensors, here is the observed status:
a. Den Motion Sensor, Used by app, OFFLINE
b. Dinning Motion Sensor, Used by app, ONLINE
c. Hallway Motion Sensor, Not used by app, ONLINE
d. Kitchen Motion Sensor, Used by app, OFFLINE
e. Living Motion Sensor, Not used by app, ONLINE
f. Mud Room Motion Sensor, Not used by app, ONLINE
g. Stairs Motion Sensor, Not used by app, ONLINE
h. TV Room Motion Sensor, Used by app, OFFLINE


#11

The following all describe similar issues occurring in the same time period, but I don’t know if they’re all exactly the same problem:


Fortrezz Water Valve Unavailable
#12

It was announced in the release notes for the version of both the android mobile app and the iOS mobile app that first included the device health feature. It’s pretty recent.


(Alex) #13

As far as I have noticed, all my devices reporting as OFFLINE actually work if I try to control them via the ST app. In fact when I was seeing the “Unavailable” error caused by the device health feature, all I would do was toggle the device or simply pres refresh. Given the devices never appeared to actually be dead, I turned “Device Health” off because it was not adding any value, if anything it was just annoying me.

I have had a few cases where a device just dropped dead but it was before the implementation of device health.

When you say your devices are just dead, have you tried to interact with them locally (toggle the switch) or pressing refresh on the ST app? Or are they failing to do something on a schedule or failing to be controlled by Alexa, or…?


(John Roberts) #14

I have the same problem with a GE 12727 Z-Wave switch… I uninstalled and reinstalled… Status still shows “Offline”, but it passes Z-Wave Repair and works as it should… Just robbed me of any chance of sanity and trashed a lot of time … lol


(Anders Heie) #15

After some twitter messages to get Smartthings attention, they finally reached out to me again. Currently no solution, they are just asking me to remove/add the devices (which is a very painful process, that doesn’t really solve the WHY of the matter). I’ll let ya’ll know what happens, it could take a few days to figure out.

Edit: Two days later: I replied back with some followup questions and have yet to get a response. I am getting sorely disappointed with Smartthings support as the days wander by…


(Daniel Pena) #16

I found the same thing, The Device Health only reports as something being wrong because a device hasn’t reported in a specified time, I found this with my gun safe sensor which doesn’t change temp or any other activity very often, The device was actually functional regardless of what Device Health reported. I just think the formula they use to report problems need to be refined better.


(Ed) #17

I thought it was a problem with the Zigbee mesh as I did not have any powered devices. I went out and got a few Zigbee outlets to scatter around the house. Although not as many devices show unavailable now, I still get 2 or 3 per day. I’ve reset the device and usually that does it until the next time it goes unavailable, but it has been completely random and only my Zigbee battery devices.


#18

I had the same problem a few weeks ago. Many of my sensors would show as offline randomly. I refreshed them individually and they would come back only to find the same would happen hours later.

Support checked and couldn’t find an issue so I reset my hub (removed batteries) and switched device health to Off. So far my problem has been resolved and all sensors appear to function correctly - recent firmware update may have helped too.


(Squatting Hen) #19

I removed my GE Fan Switch and added it back…again. It worked for about two days then became unavailable…again. I contacted Smartthings by phone and they wanted me to remove it and add it. I explained that if I do that it will work for a day or so then stop working. They said to send an email or use the chat feature for higher tech support. I then tried the chat and the rep said he can see it falling off and suggested I get the switch replaced. He said it is probably a bad switch… Ugh. Guess I can try that.


(David H.) #20

I’ve also encountered this within the last 2 weeks. Spent hours today trying to fix it - not fun. I do hope ST fixes it soon.