SmartThings Community

Alexa works but she thinks she doesn't (November 2017)

alexa
echo
harmony

(Scott Alphonso) #1

I have searched a little and have not found anything on this so I do apologize if there is another topic out there. I am just starting out with ST and only have it integrated with Amazon Echo and Harmony at the moment. Currently, if I tell alexa to “turn on Netflix in Living Room” she will say, “sorry, I am having trouble connecting to smartthings” but then the Harmony activity will trigger and it works perfectly. There is not even but a 1 sec delay if that.

So, my questions are, has anyone else experienced this false response and if so is there a way to fix it?

thanks, Scott


Alexa is having trouble reaching smartthings (Nov 2017)
Alexa Integration with SmartThings Broken?
Google Home Crushes Alexa in Performance
ST trouble with 1 of my harmony hubs
Alexa displays device as unresponsive while ST shows the device is active
Alexa-controlled, S.T. security system stopped working after upgrading Apps last weekend
Alexa issues, App issues, Routine issues
Alexa Recently Says it Doesn't Support Harmony?
Alexa/Sengled Element BR30 Smart Bulb, No longer working
ST servers..... Are they down?
Fibaro 2 Dimmer (212 not 211)
(Ron Talley) #2

I have. I have no idea what the fix was. Rediscover devices? Restart Harmony? Restart ST Hub? I did them all.


(Scott Alphonso) #3

the good thing is the activity works. It’s really just an annoyance thing of Alexa misinforming me. But usually when she can’t connect to ST at all she gives a different response.


#4

I’m having this very issue atm. Commands working but Alexa’s saying she’s having problems. Would be interested if anyone’s found a fix!


#5

This has happened occasionally in the past and seems to be a timeout issue where smartthings is not responding quickly enough. So echo gets the request to turn on the light, passes it over to smartthings, smartthings receives it just fine and does turn on the light, but takes too long getting back to echo to say that the light has been turned on.

The best thing you can do is contact support and let them look at it from their side. I don’t think there’s really anything as an individual that you can do.

https://support.smartthings.com/hc/en-us


#6

For Shi ts and giggles try this just to see what happens. I know it’s working and this may not make sense, but its working and responding with an error makes no sense either.

Disable the SmartThings skill and Re-enable the skill. Then try again and see if the error message still occurs.


(Scott Alphonso) #7

Just tried that. Still same result. Thanks for the suggestion though.


(www.smartukhome.co.uk) #8

Im getting the same


(Dave) #9

Having the same problem. Alexa is now discovering Harmony activities through Smarthings as scenes instead of devices, and it just doesn’t work. Turn on will work with the error message from Alexa, but turn off doesn’t work at all. Just got off the phone with Amazon Echo support, and they said there are many reports of this issue and they are working on it.


(Michael Hussey) #10

Same thing with me, everything works but Alexa says it’s having problems with ST


(Kevin) #11

Check Live Logging because I’ve seen that happen when the method being executed was throwing an exception.

I’ve also seen it happen when the command accidentally returns a value that the hub can’t execute.


(Kalel) #12

I, too, have this problem. I ask Alexa to “turn on TV” (which triggers SmartThings to have Harmony Hub run the TV sequence.) After an extra unusual delay of a couple of seconds, the TV sequence starts, but then, Alexa says, “I’m having trouble reaching SmartThings.” This all started a day or so ago, around the time when SmartThings reported to the user community that there was degraded Alexa Voice Control. According to a SmartThings notificationI received via email, that problem was supposedly resolved, however, it continues for me. I haven’t submitted a trouble ticket to SmartThings before… where do I do that? Thanks! --Kal


#13

Anyone from @smartthings_support care to update? Many thanks


(João Cautela) #14

Still having the problem, but now, alexa turns on but doesn’t turn off!


(Scott Alphonso) #15

Looking at the Live Logging on ST, everything looks good. Does anyone know of a way to look at debugging on the Echo?


Alexa unable to connect to SmartThings
(Kalel) #16

I ended up opening a support ticket with SmartThings last night about the issue. I also included a link to this forum thread as a reference to the SmartThings support group that other users are having this issue. --Kal


#17

i do have the same issue since today morning, activity works with “sorry, I am having trouble reaching smartthings”


(Kalel) #18

So, for those of you experiencing the issue, please consider logging a support ticket with SmartThings. I assume the more trouble tickets they receive on an issue, the faster they will work on finding a solution. They have three support options: By phone, by email, and by Live Chat. Someone mentioned the support link earlier in this thread. I’m hoping SmartThings can fix this problem soon! --Kal


(Kalel) #19

Just heard back from SmartThings regarding my report of Alexa complaining, “I’m having trouble reaching SmartThings” even after completing the action. Here is the response from SmartThings Support:


Thank you for contacting SmartThings Support.

I’m sorry to hear that you are having trouble with your Alexa
integration, but I am happy to help.

There is a known issue with Alexa right now, but you can try following
the following steps for a potential workaround.

  1. Forget the device through the Amazon Alexa app
    • Tap the menu (three horizontal lines in the top left)
    • Tap Smart Home
    • Tap Devices
    • Tap the name of the device
    • Tap Edit
    • Tap Disable this device
    • Tap Disable to confirm
  2. Rename the device in the SmartThings app
    • Tap My Home>Things
    • Select the device
    • Tap the gear icon in the top right
    • Rename the device
    • Tap Done
  3. Add the device back to the Amazon Echo service manager in the
    SmartThings app
    • Tap Automations
    • Tap the SmartApps tab
    • Tap /Amazon Alexa/
    • You will see the devices Amazon Alexa currently has access to
    • Tap My Switches or My Thermostats or My Locks
    • Tap the checkbox for each device Amazon Alexa needs access to,
      and tap Done
    • Tap Next
    • Say: “Alexa, discover new devices”
    • Wait for Alexa to confirm discovery is complete
    • Tap Done

Thank you for your patience with this matter and please feel free to contact us with any further questions.


I responded back with some additional info and questions and asked if they have an ETA for resolution. --Kal


#20

Support doesn’t officially monitor the forums, although occasionally an individual employee does comment. The best thing is just to contact support through the link at the top of the forum page.