Alexa is having trouble reaching smartthings (Nov 2017)

That is the message i get, when ask to turn on the TV, but the TV turns on.

Anyone else having this problem?

Already disable/enable the skill, and find the devices again.

You’re Not the only one getting that error. Contact support.

Same thing here except TV wont turn on, I tried relinking in the settings still no luck

I’m also having the same problem, started after I had a power outage.

So far I have tried rebooting smartthings but still get the same message from Alexa

I too am having the same issue using Alexa to control my Logitech Harmony Remote via Smartthings. I have got Alexa to turn on the TV but I get Alexa saying “hum I am having trouble reaching smartthings”. I can also turn off the TV successfully but get the same reply from Alexa “hum I am having trouble reaching smartthings”. I have noticed that Amazon have updated the Alexa app (ios 2.2.364.1). The device version for my echo is 591448720. The Smart Home section of the app has had a dramatic redesign. Reading the update notes Amazon have performed a number of updates to the Smart Home section. I am sure the Amazon Alexa Cloud service that runs the Smart Home has also had a software update to go inline with the updated app. After the update I have noticed that the harmony settings in Alexa are now under the Scenes section. Rather than been under the Devices section. I think this is where the problem is. Smartthings and Amazon need to work together so Harmony Devices are seen as Devices rather than scenes.

Same here. I’ve also got all of my harmony activities listed twice in the scenes list after removing and re-connecting Alexa with my SmartThings account.

Now whenever I give her a command she says I have several devices named… Give them unique names or add them to a group to control them together.

I’ve tried disabling one of them but still the same message, and also if I rename one of them.

In the end I’ve added both scenes into a group and done the same for each harmony activity. Now she’s back to giving me the ‘having trouble reaching smartthings’ message but is actually performing the action I want.

I’ve got two of most of my devices in the devices section too, as well as the rooms listed as devices. This is a real mess.

alexa is getting confused
I don’t have the harmony skill has im in the UK and we never get the good stuff so I use smartthings to control my harmony activities. But alexa is seeing them as harmony activities

If you want to “forget” things in Alexa like you could previously, go to: alexa.amazon.com and manage your devices outside of the app.

FYI:
If you are accessing alexa.amazon.com via your mobile phone using Chrome Browser for example, it will try to redirect you to the app or to download the app. However, in your Browser if go-to to the Setting page, you can select Request Desktop Site and it will allow you to login and display the app as though you were logged in just like on a desktop/laptop. Within there, you have the ability to forget the devices.

2 Likes

this will not fix the issue, I just received an email from Support they claim they know its an issue and are working to resolve it. We will see how long that takes they still have not resolved the presence issue totally.

I ended up forgetting all of my groups and devices…When I went back to Discover New Devices, she would not find any. This is when I had the Select All Option checked in the Alexa App in SmartThings. I ended up having to select groups of no more than 20 in order for her to start recognizing new devices. However, she stopped at around 140 and will not include any more. Even after I started removing others, she will not find anymore devices.

Dang.

I’m having Similar Issues. I asked Alexa to turn on the TV and she responds with the wonderful “Hmmm. I’m having trouble reaching SmartThings.” Even though the TV does in fact turn on… She has no problem with any of the other ST devices just those linked to harmony. Also, I noticed that Alexa is grouping all of the Harmony Switches in SmartThings as “Activities” even though they are “On/Off” Switches in the SmarThings App.

No real value add from me here just sharing a similar issue.

I couldn’t even get her to discover all of my devices for days. Now all of them are back but the Harmony (Scenes) are not acting right for me either.

Turns on with the hmmm message. Will not turn off.

I have 3 Harmony Hubs and one of them I just do the native integration with and that one works. Still, even the native activities are seen as scenes but at least they turn on and off correctly…

Just wanted to mention that in addition to the two different Alexa/smart things bugs that have popped up recently, the one where echo says she can’t reach SmartThings and the one where SmartThings devices don’t show up correctly in Alexa routines, Logitech has also very recently deprecated the red skill and somewhat modified the blue skill.

This means that the native Alexa/Harmony integration now works a little differently than it used to. That part isn’t a bug, it’s a change, but it can be confusing and logitech doesn’t seem to put out any news bulletins or email blast about it. They just changed it and changed their own support page about the integration.

Since I had both the red skill and the blue skill enabled and have been using both, this really drove me crazy until I figured out what was going on, and that took talking to both Amazon and logitech support. :disappointed_relieved:

Anyway, just wanted to mention it in case anyone else was running into the same thing in the middle of trying to track down the bugs.

See the following thread for discussion on that specific change,

I was having the same issue, but not it changed from having trouble reaching smart things and working to now “TV doesn’t support that”

Even though from the Alexa app, the TV “scene” still functions, as well from the smart things app as well.

So my fix was too add the Harmony skill to alexa (do an update on harmony itself as well), and disable the smarthings skills for harmony in the aleax app and now everything is working.

1 Like

So I left my setup and waited for Smartthings and Amazon to resolve. For me it looks like they have resolved the issue. I can now use my harmony remote activities without Alexa complaining about not been able to connect to Smartthings. Thank you Smartthings and Amazon for sorting it out.

1 Like

Oh if I could only get back the hours I spent on this…

Should have followed your lead after the first 10 minutes of going crazy! Never realized how much our house has gotten use to using Alexa to turn on entertainment devices. Yeesh

1 Like

I was having this problem over the last couple of days and hoped it would be sorted by Alexa or SmartThings. Since it wasn’t, I went through the process of deleting and rediscovering 30+ scenes in the app one by one (as suggested) and that didn’t work. I then disabled/enabled all related skills. Still didn’t work.

Started from scratch
(1) delete all scenes, devices, and groups,
(2) disable/enable the Harmony and SmartThings skills (reducing the number of Harmony items linked)
(3) discover the scenes

It was a lot of work so I’m posting hoping there could be a way to resolve this faster in the future.

1 Like

I am as well having the same issue since Samsung had an update last weekend.

I lost all communication between the ST HUB and Alexa. I also have tried just about everything. In addition, I sent in a “ticket” to Samsung support…

Still have NOT heard back!

As a last resort, I am wondering if maybe (like a PC) if there is a way, to roll the firmware back to the previous version? Currently, Firmware Version 000.022.00013