Zwave implementation is just broken


(Stuart Buchanan) #1

So today I tried a concerted effort to resolve the multiple Err 116: Got CRC-16 encapsulated command with bad checksum errors I have been getting along with general zwave unreliability. I have come to the conclusion that none of my devices are broken, but rather the hub is.

There are multiple ID’s listed in the messages

I am now unable to perform a zave repair as I receive multiple errors for lots of Devices if it works, but I have for a period of maybe 6 hours today been unable to perform a repair as when I click on the utility the event logs displays absolutely nothing occurring. Likewise if I choose to disable zwave the event shows inactive, but yet my motion sensors trigger things. Some. Really strange oddities for sure. This makes me think it is the ST hub’s zwave module which is broken. @duncan I’m trying to pin the tail on the donkey here blindfolded with no clue as to which direction the donkey is. Any news on more verbose logging Or utilities as I’m just broken at the moment.


Err 116: Got CRC-16 encapsulated command with bad checksum
(Bruce) #2

Have you tried this:

https://graph.api.smartthings.com/hub/zwaveDebugOn/[your hub id]

and

https://graph.api.smartthings.com/hub/zwaveDebugOff/


(Stuart Buchanan) #3

@bravenel thanks for that, I wasn’t aware of it, but may have helped me. There was a device I made for monitoring my water butt that is using a Fibaro UBS that I forgot was mains powered I had popped everything else, I’ve just powered it off and on and now I’ve just got a clean repair.

I hope that is now right, but it doesn’t really explain the strange behaviour I experienced with the hub yesterday where I couldn’t run a repair for over 6 hours :confused: will continue to monitor.

Does really highlight how bad the zwave mesh is working with ST, this device is surrounded by 4 other mains powered devices within 5ft that repeat. So how that single device breaks the devices on the other side of the house is beyond me

Can I ask how you found out about the zwave debug?


(Stuart Buchanan) #4

ok so a bit of further feedback, after looking at the debug zwave logs they have not resolved the issue as the only item that looked inconspicuous was the fibaro UBS, this was not the cause of the issue as all-though i initially got a clean repair things started going awry again pretty soon after and was seeing the CRC errors.

so i have again reset and tried to replace my devices again. i did hit an issue with one of my devices (House Siren) after resetting when replacing it did not find the device but the house siren dissapeared from my devices list even though it was assigned to smartapps :angry: so i again have ensured the zwave node was unconfigured on my network (using secondary Controller) and rejoined, it rejoined with a new ID and i then had to delete all the affected smartapps and reset.

been monitoring all day and have not seen a CRC error yet. so i am not counting my chickens yet, but this has been a b**** to troubleshoot.


(Stuart Buchanan) #6

the CRC Errors came back after a while, and i have been getting my Zwave devices spontaneously switching on all evening and night. have excluded and included a lot of my devices which were causing CRC errors. i bit the bullet and sourced the GUID for each and every device manually and tallied this up with the GUID showing in every CRC error i had. I then had a total of 12 devices to repair by excluding / resetting and including back into the network.

I have done this and it seems the spontaneous switch-ons have ceased. I have also removed my Openhab Secondary controller just in case this was causing issues. now when i perform a Zwave repair it is coming back clean without issues. I cannot see any issues in the zwave debug logs. all the occasional missed ack messages have ceased also.

what i am left with is a Zwave network that is reliably switching things on/off but with huge delays. I have made a short video to highlight the issues i am experiencing.

in the video you will see me activate Zigbee hue spot with very little delay, but i then activate one of my Zwave lights with really really long delays.

I have removed my sonos’s from ST in case that is causing any issues. i have showed logs and everything in the logs and events show that everything was triggered when it was triggered but the delays are huge…

can anyone offer any ideas? these issues on the Zwave network have been plaguing me for a long time now with no end in sight. I have been having major oddities which make me believe the hub is just plain broken. sorry for me droning on in the video but its been a long day.


(Bruce) #7

One of the problems here is that there are multiple things going on. I too am seeing big lags today, new today. Others are reporting the same thing. So, that probably is not your z-wave network per se.

Sounds like openHab may have messed things up. If you got a clean repair, that at least should be ok. The whole lag thing is something else.

Big problems with the platform today…


(Stuart Buchanan) #8

but that i believed was only with US servers.

and i talked too soon, absolutely every zwave device just switched on, including some which are in absolutely rules or smartapps. there are no delays whatsoever with any other non zwave automations, they all work fine, it is just the zwave components that aren’t playing ball. it cant be cloud based delays can it? if the events are triggering at the correct time etc…


(Bruce) #9

Why not?

sensor -> hub -> cloud -> cloud-app -> cloud -> hub -> z-wave device

you don’t know what’s in the cloud->cloud-app->cloud part


(Stuart Buchanan) #10

true but the fact the hub is reporting that is sent the command to turn on the device i would have through the failure would be in the hub -> z-wave device part. or maybe i need to get some coffee power off the ST hub and sit in the dark when it comes shortly :slight_smile:


(Stuart Buchanan) #11

@bravenel Now i’m really trying to puzzle something. my hub is unplugged and off with the batteries out and the Raspberry Pi hosting Openhab is also off, the Zwave stick is not powered. I have no other controllers but again at the same time all my zwave devices powered on at the same time its now the moment where i want to say WTF!!!


(Stuart Buchanan) #12

@JDRoberts do you have any ideas for a phantom coordinated switch on of devices made by different manufacturers all at the same time when the hub is off and no other controllers?

are you aware that Zwave devices will switch on if they have no controller adter a period of time? if so then it must be part of the ZWave standard as they all went on at the same time


#13

There’s nothing in the standard that would cause that, that could be quite dangerous.

The only thing I can think of is a ghost “basic” message that went all devices. But if the controller was off-line, that’s just bizarre. Was the hub actually unplugged? And off battery?

Was there anything in the logs for the individual devices?


(Stuart Buchanan) #14

yup the batteries were out, the hub was unplugged on my desk, no light etc. aswell as the RPi i have been running openhab on was also unplugged next to it. lights turned on multiple times, and is still going so but less frequently since i plugged the hub back in.

the logs showed nothing for the duration with the exception of the cloud based stuff. the hub was definitely reporting offline.weird thing is its every device all from different manufacturers all powering on at the same time.i’m now baffled as to the cause of my zwave issues. i’m gonna have to start from scratch i think


#15

Do you have any secondary controllers? Aeon minimote, GE wallmount controller, anything that could send a basic command?

Do logs for sensors look different than logs for switches?

Any Sonos devices connected?


(Stuart Buchanan) #16

i have had sonos connected but i removed yesterday as my zwave issues have been going on a couple of weeks. i’ve spent so much time on trying to do it i might have been able to completely rebuild in that time


#17

If it was me, I would first remove everything from power (batteries out, etc). Pick one sensor and two switches or pocket sockets. Start a new network with just a minimote and those three devices. Don’t do anything but associate the sensor with one of the two lights. Don’t have the other light set up to do anything. If they show unusual activity over a two day period, there some kind of crazy interference in your environment. It’s not impossible, but it’s really rare that you would see the results you’re saying.

If the minimote network works fine, such at the sensor can trigger the light but nothing else happens unexpectedly, then the issue is either the smart things platform or some kind of conflict between your primary and secondary controllers.

I should note that I have tickets in on locally operated zwave devices that are going bananas. I’ve mentioned them in other threads. But in my case I’ve been able to show that there is smart lighting automation activity occurring when it shouldn’t be. It’s not the devices themselves.


#18

There is a known issue with Sonos and SmartThings, it’s completely bizarre. If you have more than one Sonos device connected to your SmartThings account, you can get crazy runaway polling which results in no zwave messages getting through. From a radiofrequency standpoint, that makes no sense, but it clearly happens. It has to be a platform issue of some kind.

Anyway, the fix is just to remove the Sonos devices from the account, and then magically the zwave starts working again. Without making any changes to it. This is been going on for a couple of months. Support is aware of it, but doesn’t have a fix. Zigbee devices don’t seem to be affected.

http://thingsthataresmart.wiki/index.php?title=Bug:_Sonos_integration_causes_network_failure


(Stuart Buchanan) #19

i was aware, but i had been working fine but a sudden change two weeks ago with reliability with no correlating change. I did do away with some of the sonos device to reduce, but it made no difference at all.

i’m wondering at this point if i could pick up another hub to just host the sonos players etc… have you got any experience how ST manages multiple hubs under a single account and if its possible to have them under a single location? or does it require a separate location?

but thats not my problem i dont think anyway as i was still having zwave problems with no Sonos device attached. and it doesn’t explain why my zwave devices were powering on when no controller was present


#20

SmartThings only allows you to have one ST hub per location. But you can define more than one location at the same physical address.

https://support.smartthings.com/hc/en-us/articles/203064530-Can-I-use-two-Hubs-in-one-Location-


(Stuart Buchanan) #21

with two locations though, how easy i wonder would it be to link up the two. i.e. trigger notifications from one hub to the others sonos. i could always just suck and see, but it would be adding far more complexity