Zwave implementation is just broken

You can’t do it directly. Each hub owns its own devices and cannot see the devices of the other hub.

I’m not even sure if you can do it indirectly through IFTTT if they’re on the same account.

You’d be better off setting up two completely separate smart things accounts, two completely separate IFTTT accounts, and using notifications in between the two.

So when a switch comes on in SmartThings account a, send a text message to the IFTTT account for B and use that to then trigger a smart app or routine via virtual switch for your B smartthings account.

yup very messy at best :frowning:

So back to the current situation: what about secondary controllers like minimotes?

I have some fobs, but they aren’t zwave controllers. nothing else.

i am still getting CRC16 errors for Guids that dont match any of my zwave devices (i sent through the full list) i am coming to the conclusion the zwave controller in the Hub must be malfunctioning. but still doesnt explain how my zwave devices all kept switching on after the hubs were offline.

I am not going mad, i checked, triple checked. there was nothing in the logs (obviously) so unless someone has managed to hack my hub somehow and add another device just to watch me head scratch…but i very much doubt it and they would have to be outside my house as the zwave network doesn’t stretch that far away from the house.

Edit just seen the event from the SUC showing the ID’s of all connected device ID’s so have just confirmed there are no rogue device id’s on the network.

everyone is stating there is no standard for the devices switching on when there is no controller attached, but i wonder if thats in the standard somehow for the EU zwave devices? theres no other explanation for it.

No it’s not in the standard for EU zwave, either, it just wouldn’t be safe. People run all kinds of devices, sirens, pumps, water valves, garage doors, relays – – you definitely don’t want those coming on just because the controller went off-line.

Because the process for doing a network heal on the smartthings hub for the zigbee devices is to unplug the hub and leave it off power for at least 15 minutes, we’d definitely know if this was a common issue, because every time you wanted to repair the zigbee tables, all of your zwave devices would turn on. And that just doesn’t happen.

I’m sure it is happening at your house, but it is not something that is supposed to happen.

Like I said, at this point the only thing I can think of is the power down all your devices and then create a very small Z wave network with one lamp that is not supposed to have anything happen and another lamp which is supposed to come on when a motion sensor is tripped via direct association and just run them for two days and see if they run OK. But I would do it off of the SmartThings network altogether. If you don’t have a minimote, do you have an Aeon USB stick? Basically just set up the simplest possible hardware network. That way if there is just some freak interference in your area like a neighbor with a walkie-talkie, you should see it Happen even with ST out of the picture.

One other thought… Do you have any beaming repeaters? If so, remove them from the network. That’s the only other thing I can think of which will hold a command for a while and then repeat it. So you could have a basic command issued after the controller was off power.

Also, I know this is a really stupid question, but you did take the batteries out of the hub as well as unplug it, correct? It’s not really off power until the batteries are out.

1 Like

OK, I checked the conformance statement, the key fob is a scene controller with multi channel association. So it can definitely work while the controller is off-line, but only with devices it has previously been associated with.

Do you physically know where all the key fobs are? Find them and either take the batteries out or put them inside a farraday bag or wrap them in aluminum foil.

Do you have any other scene controllers or remotes? Those can work with the controller off-line, but again only devices they were previously associated with.

(It is possible to change the Association group for Z wave device just with software. ( you can’t change their network controller, but you can change their association group for the network that they are on) It’s possible that either open hab or SmartThings is broken and managed to put all of your devices into one Association group, and then there’s a key fob somewhere around that is getting occasionally clicked while the controller is off and is sending out a basic command to all the devices. That would be weird but possible. )


Before I forget, commands sent via association will not necessarily show up in the controller logs, because by definition the controller doesn’t know they happened unless the controller was also part of that association group. So if it’s something being sent via Association, it’s actually not weird that it’s not in the logs. That’s why my brain keeps going there.


cheers for the input I do have only 2 fobs one was with the wife 50 or so miles away and the other was with me on my desk. But these have never been configured to talk to any devices and what makes me lean towards the one not being the problem is because it was all devices that turned on including those only associated with group 1, and those that also support secure encapsulation(aeon sockets) which my fob does not support (the wife’s does but I can 100% account for the location of it).
The hub was 110% unpowered and the hub was removed.
I do have 2 DSD37 repeaters so that leaves them as the culprit maybe? But that’s a lot of commands stored!
I had also been messing around with @ule 's media renderer with upnp on my wall tablets as an alternative to so is notifications. I removed all of that too. And after some initial slow zwave responses and another zwave heal things started to look better maybe a coincidence? But if not that effectively means I cant use and devices for notification which is just plain useless.
I think I need to relook at coming up with a solution to offload all that functionality to my always on server farm and just send web requests for notification.
I was looking at using voxcomando at one point but abandoned the effort as i just don’t have enough time to devote to finish authoring it…but i will need to relook at it I think as its gotta be that causing the huge delays as i seem to be working fine now.

1 Like

Just getting caught up on this thread – crazy stuff. There is a command class called “Switch All” that is sent as a broadcast message to turn on all nearby switches that support it. (Side note: the original aeon minimote will send this if you press the 1 and 2 buttons at the same time for on or 3 and 4 for off)

Maybe your fob was flipping out and sending that? I’d also wonder about power brown-outs as most switches default to on when power is first applied.


@duncan thanks for the feedback. I’m not sure I will ever know as I have no logs to work from. but from since I removed all DNLA and Sonos devices my troubles with zwave network has ceased. And. Have not had any random switch ons since

So I’m trying to work on another method to use TTS notifications on my sonos devices.

Are you aware as to why these devices are affecting ZWave? Is it purely the frequency of SSDP discoveries etc that is causing delays? I am wondering why Zigbee and cloud to cloud stuff is not affected.

As for brown outs I do have 2 UPS’ and these would have reported it (they have in the past) but maybe it was just a perfect storm of not enough loss in a brownout to trigger the UPS alert but enough to reset the zwave devices…but none of my Zigbee stuff turned on, and hue bulbs also default to switch on when power is reset


I am trying to track down some missing Zwave commands on my UK hub, but get a denied “Sorry, you’re not authorized to view this page.” when I do:
I am not sure on the Hub ID you mention, so I assumed this was the hubId field you see in the Hub events.
Is this correct, or should I be using some other Id?

I am logged into graph-eu01 as I was on the live logging page.
I was also assuming that the URL would show you the logs on the Live Logging, but are they somewhere else?

thats exactly the hub id you need just add that id to the end of the URL and you are good to go

Mmm well that’s what I did to get the error. I just didn’t want to post my hub ID here…
I’m wondering if this is yet another US only feature.

no it wasn’t a US only feature. it did work in the UK also, but now i am getting

Sorry, you’re not authorized to view this page.

when trying to do this now, so it looks like they have pulled access to it :frowning: which leaves us up Shit creek without a paddle when it comes to diagnosing Zwave issues.

@duncan do you have any idea why this backwards step has been taken. we have been crying out for more tools of which we are promised some, but to take this away seems to be a very bad idea indeed

Z-Wave debug mode was never a user-accessible utility AFAIK. You guys were just going to an undocumented URL to enable it? Sounds like an access control bug that got fixed.

We can look at opening access to Z-Wave debug mode, but we’ll have to consider the security implications first. What kind of things were you guys mostly using it for? I’m working on adding more Z-Wave reporting so I’m interested to know what you find useful and why.

1 Like

That’s great understood its was undocumented however the servere lack of tools is shocking. I suffered from zwave issues for months. Which was only resolved by removing and replacing pretty much every device. That and removing all my Sonos and DNLA devices

I know this is an old thread, but I thought I might add this. A couple of years ago, most of the zwave devices in my house started turning on and off apparently at random intervals. It was very frustrating. I unplugged and turned off everything related to smartthings, but still things kept turning on and off. Finally I figured it out. The zwave standard allows for devices to talk without each other without going through a hub. The idea was originally to allow device groups so that when one turns on, they all turn on. I never used it but apparently somehow a motion detector got 255 in as the device group and that was a broadcast ID. Every time the device saw motion it sent out an “on” message and when it switched to no motion, it sent out an off message to all the devices. Once I cleaned out the device groups everything went back to working normally.